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Introduction.
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CompiCat is an application for editing and compiling catalogs of earthquakes, which is essential part of
any study of seismic activity. The application combines the features of EdCat and Catal console
applications developed in the early 1980ies (the latest versions of these programs were distributed at
the Abdus Salam ICTP Workshops on Nonlinear Dynamics and Earthquake Prediction, last time in
2005, http://cdsagenda5.ictp.trieste.it/full_display.php?ida=a04209).

CompiCat program is a C++ code using Qt C++ tool kit for multiplatform Graphic User Interface and
application development. It has single-source portability across Linux, UNIX, and Windows.

CompiCat program was designed for reproducible studies of seismic activity based on catalogs of

earthquakes. It could be applied for
- importing catalogs available in different formats and converting them into the standard one;
- exporting catalogs into commonly used formats;
- selection from a given catalog;
- comparison of catalogs;
- editing and compilation of earthquake catalogs, which includes check for errors and disorder;
- converting of magnitudes of different kinds into the common one;
- identification of duplicates and their removal,



- merging several catalogs into a single one;
- calculation and visualization of spectrograms and histograms of a given catalog, etc..

Thus, CompiCat provides a tool-box that allows preparing the catalog of earthquakes in the
standard format without evident errors or disorder.

CompiCat supplies users with online help in three levels of detail. Its project wizard allows users to
create a project file as a sequence of operations on seismic catalogs for future implementations, e.g.,
for reproduction of the analysis by other parties.

CompiCat allows writing down a protocol, which contains information on all corrections of errors,
identified duplicates, parameters used in different operations, etc.

Running CompiCat results creation and output of the following optional files: output catalog of
earthguakes, the project binary file, and the protocol text file.



2. Catalog formats and import/export options.

CompiCat program works with catalogs of earthquakes filed in the standard format that specifies the
origin time, location, and magnitude of event (see Appendix A).

The ASCII text formats of the original seismic data reported by the US Advanced National Seismic
System, the USGS/NEIC Preliminary Determinations of Epicenters, the Northern California
Earthquake Data Center, the Southern California Seismographic Network, and other agencies (see
Appendix B) are supported for importing research information. The supported formats are listed in a
special file, which could be upgraded according to the instructions provided in Appendix B.

CompiCat program allows importing catalogs in the following way:

Click Import /& button in the uppermost tool bar or Import entry of File menu to open the import
catalog browser.

!"';] Choose a catalog and it's format

Look in: [@D:\ecmlmmrt |'] = I+ W )
o My Camp... | Mame / |Size |Type |Date Modified E
=l catsearc.scsn scsn File 16.05...:19:
) sasha t 4 KB Flle 16.05....:19:50
= catsearch-10.anssreadable E93 KB ans..ike  16.05...:19:50
= catsearch.hdf S KB hdf Fle 16.05...:19:50
= catsearch.hypo? 1 6 KB hyp..ile 16.05...:19:50
1] catsearch_96.anss 240 KB anss File 16.05....:19:50
H| catsearchiajnoOg hds 303 KB hds File 16.05....:19:50

File narne: [catsearch_BEl.anssBEh:DI l Open
Files of type: [f-‘«r‘lv files (*) |'l Cancel

Farrnat: [ ahss 80 col - Advanced Mational Seismic Systern |v]

Previs:

12005 1f 1 1:42:24.85 7.290 93920 30,0 5.00 0.000.000.00 O
20 2005f 1/ 1 L43:40,14 7030 92460 355520 0.000.000.00 O
32003f 1/ 1 1552846 2910 95620 245570 0.000.000.00 O

A4

Find and select file for import from the list that appear in the upper left frame. CompiCat tries
recognizing the catalog format automatically and reports in Preview frame either the first three records
of the catalog or ' Error format ' message. Note that (i) errors of the imported catalog, if any, will appear
in Errors page of protocol frame ( see 4.2.3 Protocol Frame ) and can be corrected ( for details see 6.
Catalog editor ); (ii) catalogs with detectable errors cannot be transferred into the standard format (csf.
files).

To simplify import CompiCat program allows classifying catalog files by their type. The following
extensions listed in Files of type box are used in the import browser:




e Any files (*)

o Standard Format - Binary (*.20bytes)

o Standard Format - Text (*.41bytes)

o Standard Wide Format - Text (*.68bytes)

e Advanced National Seismic System (*.anssreadable)
e Advanced National Seismic System (*.anss80col)

e Southern California Earthquake Data Center (*.scedc)
« Southern California Seismographic Network (*.scsn)
e NEIC Preliminary Determinations of Epicenters (*.pde)
e Summary hypo71 format year 2000 (*.hypo71)

e NEIC Hypocenter Database System (*.hds)

When recognizing the catalog format automatically CompiCat uses format description block listed in
ASCII text file named .../ecp/ref/standardformat.list and displays one of the following TITLE strings in
Format box:

e 20 bytes - Standard Binary Format

e 41 bytes - Standard Text Format

e 68 bytes - Standard Wide Text Format

e anssreadable - Advanced National Seismic System

e anss 80-col - Advanced National Seismic System

e pde - NEIC Preliminary Determinations of Epicenters
e scedc - Southern California Earthquake Data Center

e scsn - Southern California Seismographic Network

e hypo71 - Summary hypo71 format year 2000

e hds - NEIC Hypocenter Database System

CompiCat program outputs the compiled catalog of earthquakes in the standard binary format. If
requested, the program exports the compiled catalog either in the 20 bytes - Standard Binary Format, or
41 bytes - Standard Text Format, or 68 bytes - Standard Wide Text Format. (The first two formats were
used previously in the console applications developed at MITP, which applications require "dat™" as the
file name extension.)



To export the catalog toggle on Export -_é ¥ button and select an appropriate format.

Protocol  Tools  Options  Help
32 = =1

20 BYTES - STANDARD BIMARY FORMAT
41 BYTES - STANDARD TEXT FORMAT ﬁ

68 BYTES - STANDARD WIDE TEXT FORMAT [
User defined TEXT output 16 5

=2 2007 1 =] 71z

At this point CompiCat opens Save file browser that allow the user to save the catalog under any name.
CompiCat manages file name extension name automatically, specifically, if for the 20 and 41 bytes
formatted files the extension is ".dat", while for the 68 bytes formatted files the extension is ".68bytes".



3. Quick start
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There are the four possibilities to start CompiCat session. All but the four buttons listed bellow are
disabled when the user enters the program.

1. = Open an existing file in the internal binary Catalog Standard Format (file name extension .csf)
with file navigator

Open an existing catalog file

Laak in: |&} evercizes j &= If'F ,

AHT5E4-04, s PING90-00, csf
Centralamerica?0-00, csf tst1double csf

@.

ty Recent ex3conwverkmags. csf
Documents exdremovedouble, csf
?[: exDselect,csf
exbaddQuick, csf
Desktop exfaddWeekly,csf

exinitial csf
exbmerged, csf
exFupdated,csf
exddifference,csf
exBequivalent,csf
exBnonequiv.csf
exginitial csf
Mewil csf

M}'PTIJ etwork  File name: |Certralsmericadn-00 st | Open |
ACES
Files of type: | Catalog files [*.cf) | Cancel




2. :j - Generate a new project

!‘_T:| Project Wizard - Edit Project: ex1 2initial.csf

Project Info
Define a sequence of operations on catalogls),

—Initial Catalog:

ex 12initial.csf

Browse

Paramneters of Tazks:

® Currently defined () Default

—Tasks:

O @, check specified ranges

® Optional Tasks:

List of Tasks:
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"] Rermove duplicates
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28 Substitute catalogs
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5%
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C¥ Select subcatalog

Merge catalogs

) BEF compare catalogs

< Back I Mext = I Cancel I Help l

See details 8.2 Project Wizard
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4.4 . Import a catalog with file navigator

E'__J Choose a catalog and it's format

Look in: [@D:\ecp\lmport |Yl 0 O 0 2 [
i My Comp... | MNarne / |Size |T3rpe |Date Modified Fi’
] sasha 5] catsearc.scsn 4 KB scsn File 16.05...:19:50

=] catsearch-10.anssreadable G692 KB ans..ile 16.05...:19:50
= catsearch.hdf S KB hdf File 16.05...:19:50
=) catsearch.hypo7l 6 KB hyp..ile 16.05...:1%:50
| catsearch_80.anss80cal 184 KB ans..ile 16.05

catsearch_96.anss 240 KB anss File 16.05...:19:50
= catsearchiajn04.hds 302 KB hds File 16.05...:1%:50

File narme: [catsearch_ElD.anssEchoI ] Cpen

Files of type: [An\; files (*) |'] Cancel

Format: [ anss 80 col - Advanced Mational Seismic System |v]

Preview:

12003 1f 1 142:24.85 7.290 93,920 300500 000000000 O
22005/ 1f 1 1:43:40.14 7030 92460 355520 0.000.000.00 O
302005/ 1f 1 1:55:28.46 2910 95620 245570 0.000.000.00 O

A

When the user selects file for import, the program tries to recognize the appropriate format
automatically. If the program cannot do it then Preview box will report ' Error format '. Otherwise, the
first three records of the catalog will appear in Preview ( for details see 2. Catalog formats and
import/export options ).

If imported catalog contains errors, e.g., records of parameters out of range or sorting disorder, then
these will appear in Errors page of the protocol frame ( see 4.2.3 Protocol Frame for the list of errors
). The user must correct all errors (see details in 6. Catalog editor ).

After starting a CompiCat session the user can execute either the project or any of the catalog Tools
(see 7. Tools ). The user can save current catalog or project or protocol files at any time of a session by
clicking the following buttons:

hj - Save the current catalog file;

& Save the current catalog file under a new name;
E - Save the project file;

E - Save the project file under a new name.

@ - Save the protocol file;

Dﬁ - Save the protocol file under a new name.

CompiCat will prompt the user about saving output files on exit. Catalog files have standard extension *.csf, project files have standard
extension *.pro, protocol files have standard extension *.protocol. All these extensions are added to the filename automatically.

The user can export the current catalog t any time of a session by clicking Export button -_ﬂ ¥ . (For
details of export formats see 2. Catalog formats and import/export options).
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CompiCat remembers the last saved settings (i.e., sizes and positions of windows and some other
options) across sessions. For details see Appendix C.

4. Main window

4.1.1 The File ToolBar.

FrEddGgE-TEFFEEE

= Open an existing catalog file. Correspondent menu option is File->Open and keyboard shortcut is
Ctrl+O.

& - Import a catalog file. Correspondent menu option is File->Import and keyboard shortcut is
Ctrl+1.
- save currently open file. Menu option is File->Save and keyboard shortcut is Ctrl+S.

;_J Save the current file under a new name. Menu option is File->Save as ....

J Save the catalog , project and protocolt files to disk. Menu option is File->Save All ...
&~ - Export a catalog file. Menu option is File->Export ...

-- Generate a new project. Menu option is Project->New Project and keyboard shortcut is
Shift+N.

E— Open an existing project . Menu option is Project->Open Project and keyboard shortcut is
Shift+0.

ﬁ- Edit an opened project. Menu option is Project->Edit Project and keyboard shortcut is Shift+E.

E Execute project task list. Menu option is Project->Execute Project and keyboard shortcut is
Shift+B.

ﬁ- Save the project to disk. Menu option is Project->Save Project and keyboard shortcut is
Shift+S.

E- Save the project under a new name. Menu option is Project->Save Project As ...

4.1.2 The Edit ToolBar.
LAY T xEARNKE @

. Undo edit action. Correspondent menu option is Edit->Undo and keyboard shortcut is Ctrl+Z.
“#. Redo edit action. Menu option is Edit->Redo and keyboard shortcut is Ctrl+Y.
&4 - Cut the current selection's contents to the clipboard. Menu option is Edit->Cut and keyboard

11



shortcut is Ctrl+X.

- Copy the current selection's contents to the clipboard. Menu option is Edit->Copy and keyboard
shortcut is Ctrl+C.

- Paste the clipboard's contents into the current selection. Menu option is Edit->Paste and
keyboard shortcut is Ctrl+V.

X! - Delete the current selection's. Menu option is Edit->Delete and keyboard shortcut is Del.

E- Insert row before the selected row. Menu option is Edit->Insert row and keyboard shortcut
is Ctrl+1 .

- Zoom in. Menu option is View-> Zoom In and keyboard shortcut is Ctrl++.
=%~ Zoom out. Menu option is View->Zoom Out and keyboard shortcut is Ctrl+-.

L&~ Enter What's This? mode. Menu option is Help->What's This? and keyboard shortcut is
Shift+F1.

@ - Exit the application. Menu option is File->Exit and keyboard shortcut is Ctrl+Q.

4.1.3 The View ToolBar.

H @ &

- Information of catalog and view catalog segment. Keyboard shortcut is Shift+1.

E Find catalog record by date or by number. Menu option is View->Find record and keyboard
shortcut is Shift+F.

[ﬁ Save view catalog segment changes. Menu option is View->Save view segment changes and
keyboard shortcut is Shift+V.

[ﬁ Cancel view catalog segment changes. Menu option is View->Cancel view segment changes and
keyboard shortcut is Shift+C.

4.1.4 The Tools ToolBar.

se %0 [EF S5 P Q BN

1y
# 9- Check time order. Menu option is Tool->Check order and keyboard shortcut is Alt+K.
1.

#'9- Sort catalog records by ascending time. Menu option is Tool->Sort by time and keyboard
shortcut is Alt+l.

12
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=] Bl
=L

¥~- Convert magnitudes to common type. Menu option is Tool->Convert magnitudes and keyboard
shortcut is Alt+N.

l#=- Check and remove duplicate records. Menu option is Tool->Remove duplicates and keyboard
shortcut is Alt+D.

i:?:- Select subcatalog. Menu option is Tool->Select and keyboard shortcut is Alt+S.

%— Merge catalogs . Menu option is Tool->Merge and keyboard shortcut is Alt+M.

EE- Substitute parts of the initial catalog. Menu option is Tool->Substitute and keyboard shortcut is
Alt+U.

Cﬁ. Check range of parameters. Menu option is Tool->Check range and keyboard shortcut is Alt+C.
%- Compare two catalogs. Menu option is Tool->Compare and keyboard shortcut is Alt+L.

- Draw the histograms. Menu option is Tool->Draw histograms and keyboard shortcut is Alt+G..

4.1.5 The Protocol ToolBar.

D Iﬁ EG] Protocol: test.protocol

u - Preview Protocol. Correspondent menu option is Options->Preview Protocol and keyboard
shortcut is Shift+R.

Ile - Save the protocol to disk. Menu option is Options->Save Protocol and keyboard shortcut is
Shift+T.

Dj - Save the protocol under a new name. Menu option is Options->Save Protocol As...

4.2 Central Area

13



4.2.1 Catalog Frame
sec | Lat | Lon |Dep | M1 |M2|M3|M4|I|#[*

24 13 1 457 352122 -29.821 0 59 5.8
25 2 49 4873 63538 -146.801 1 3 25
25 4 47 676 51568 16.082 5| 41 38
25 5 10 3265 51.586 16,086 5 4 4
25 10 34 3873 63511 -147.247 67 43 4.2
25 11 43 1187 -16.83 -174.196 ) 1298 67 6.7
25| 14| 17| 10.4 46,1 71 S 25| 235

2004
2004
2004
2004
2004
2004
2004
2004
2004
2004
2004
2004
2004
2004
2004
2004

25 15 12 23 49,1 -128.06 10 54 49
4,82 42009 18.073 o 29 2.8
25 17 11 367 3827 21.539 5 36 35
25 19 19 35 3823 21.58 121 35| 3.4
26 10 2¢¥ 763 51135 178078 367 56 52
26 16 34 5883 51.486 16,159 5| 34 31
26 22 36 2026 57168 -155.192) 449 326 3.5
27 1 49 343 4079 22.06 11 322 28
27 2 4 4539 4081 22.03 5 32 28
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This is catalog part of main window. Table contains part of catalog named catalog workspace (page).
For example, catalog size is 71 records. Workspace size is 50 records. Visual part of catalog is 15
records (records 21-35).
The navigator buttons:
(- Moves to the beginning of the catalog.
©)- Moves to the end of the catalog.
&J- Moves one (workspace) page up.
G-‘ Moves one (workspace) page down.

i - Search by date (upper search frame) or by number (lower search frame). Search frame
contains dates and numbers of the first and the last catalog records.
Catalog workspace frame contains first and last date and number catalog workspace. You can change

workspace size input new size value and click button "..." . Click button Hto save modified workspace
and click button %! to cancel workspace modifications. If you try to click any button and do not saved
modified workspace preliminary then program suggest you save workspace.

Note: Here you save just catalog workspace. Save own catalog using save or save as button from File
menu or File Tool bar. If you try to exit from program without saving workspace you receive
suggestions to save workspace and then to save own catalog.

Built in editor is special editor designed for earthquake catalogs. Details in Catalog Editor Page.

4.2.2 Project Frame

The CompiCat main window has the project frame that appears in its upper-left part. By default it is

14



empty. It is not empty if some project has been either opened or newly created.

Tasks
=l iProject:
H project.pro
= Catalog:
H californ.csf
= Tasks:
| -] Remove duplicates
El =2 Merge catalogs
H secong.csf
B Airst.csf
H third.csf
B fourth.csf
£# Select subcatalog
= Eﬂ Substitute catalogs
B substituted.csf
B substitutel csf
B substitute?.csf
4% Conwerting magnitudes

The frame contains the project name, the input catalog name, and a brief description of the sequence of
tasks considered. If additional catalogs exist in a task, then the list of these add-ins is provided as
branches of the project tree (for details see 8.1 Manage Project).

4.2.3 Protocol Frame

Protocol frame is bellow part of main window and contain three pages
1. Errors page of protocol frame.

Here is Errors page which contains out of parameters range and date errors:

Description
Range check completed, 4 errors found.
1
2 Month (M) is out of range: value 15 ,range [ 1, 12 ]
3_8 Hour (h)is out of range: value 35 ,range [0, 23 ]
:{29 Latitude (Lat) is out of range: wvalue 94.082 |, range [ -90, 90 ]

0 Errors | S/ Messages | W Corrections

Click first or third columns of any row for searching error parameters in catalog.
Click second columns of any row to mark errors as corrected for example.

Program supports the Gregorian calendar and finds errors date (row 7, record 102, date 2003/2/29).
Details in Appendix B. Internal standard file formats.
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Here is Errors page which contains sorting order errors:

_I Record I Descripton #

| gDrder check completed. 4 errors found.,
|T| 2 place in sorted catalog: 90 after:; 21
353 place in sorted catalog: 2 after: 1
';; = place in sorted catalog: 91 after: 2
:: c2 place in sorted catalog: 56 after: 56
T

Errors | [9) Messages |[& Corre-::tior‘lal

Click first columns of any row for searching error record.

Click fourth columns of any row for searching record after which error record will be place in sorting

order.
Click second columns of any row to mark errors as corrected for example.
Third row contains information about place error records after sort procedure.

2. Message page of protocol frame.

Buid Project Messages: =]
Project File: C:/Program Fles/Earthquake Catalog Processing/ecp/exerdses/ex12-project-comp.pro
Initial catalog "ex12inifal.csf" has 46 records from 2007/ 1/ 3 13:14:19.40 to 2007/ 7/15 18:36:52.25

4k Task: Merge catalogs 4%

Current catalog has 46 records from 20077 1/ 2 13:14:19.40 to 2007/ 7/15 16:36:52.25 "
List add-ins files:

1 "ex12-merge-1.csf" has 3 records from 2007/ 7/12 0 932,90 to 2007/ 7715 16:36:52.25

2: "exl2-merge-2.csf" has & records from 20077 6/27 21,27 2,10 to 2007/ &/30 12; 7:29.00

Delta thresholds: Time: 60 ; Latiude: 0.50 ; Longitude: 0.50 ; Depth: 10 ;

Found 3 duplicates. Identficaton complited.

Output catalog has 52 records from 2007/ 1/ 3 13:14:19.40 to 2007/ 7715 16:36:52.25

### End of Task: ;| Merge catalogs *okk @

. Errors | % Messages | B Corrections

This page contains information about input-output catalogs, tools parameters and project execute
action.

3. Correction page of protocol frame.

16



2. Merging current and addHn catalogs. (=]
Current catalog has 47 records from 2007/ 1/ 3 13:14:19.40 to 2007/ 715 16:36:52.25

Add-in catalog "ex12-merge-Z2.csf” has © records from 2007/ 6/27 21:27; 2,10 to 2007/ 6/30 12:
729,00

Found 1 duplicates. Idenfification complited.

1:> 1, 40- 2007 62863204572 106226330000

1> 20 3- 2007628632645751062260032323.12

Output catalog has 52 records from 2007/ 1/ 3 13:14:19.40 to 2007/ 7/15 16:36:52.25
### Bnd of Task: | Merge catalogs *#*

*xk Tack: Substitute catalogs 4k

Catalog in process Catalog in process has 52 records from 2007/ 1/ 3 13:14:19.40 1o 2007/ 7715
15:36:52.25

g

& Errors ‘: Messages | B Corrections

This page contains information about editing catalog or details catalog tool operations such as list of
doubles for example.

Message page and correction page are the content of protocol job file. Details of managing this
protocol file in 9. Protocol Job

4.3 The status bar.

[ Action: | [Edit project || Project| y:

The status bar is horizontal bar suitable for presenting status information.
Each status indicator falls into one of three categories:
1. Temporary - briefly occupies most of the status bar. Used to explain menu entries, for example.
2. Normal - occupies part of the status bar and may be hidden by temporary messages. Used to display
the name of the catalog operation or ready to start operation.
3. Permanent - is never hidden. Used for mode indications: start, tools and project.

5. Menu entries

17



5.1 The File Menu.
The keyboard shortcut is  (Alt+F). The following functions are available from the File menu:

- File->Open ( Ctrl+0O) - Open an existing catalog file.

ﬁ File->Import (Ctrl+1) - Import a catalog file.

. File->Save ( Ctrl+S) - Save currently open file.

J File->Save as ... - Save the current file under a new name.

L_‘J] File->Save All ... - Save the catalog , project and protocolt files to disk.
@~  File->Export ... - Export a catalog file.

File->Open Recent - Displays a list of recently opened files to choose from.
Q File->Close (Ctrl+L) - Close a catalog file.

@ File->Exit (Ctrl+Q) - Exit the application.

5.2 The Edit Menu.
The keyboard shortcut is (Alt+E). The following functions are available from the Edit menu:

“ Edit->Undo ( Ctrl+Z) - Undo edit action.

¥ Edit->Redo ( Ctrl+Y) - Redo edit action.

“. Edit->Cut (Ctrl+X) - Cut the current selection's contents to the clipboard.
Edit->Copy (Ctrl+C) - Copy the current selection's contents to the clipboard.

. Edit->Paste (Ctrl+V) - Paste the clipboard's contents into the current selection.

A Edit->Delete ( Del) - Delete the current selection's.

E Edit->Insert row ( Ctrl+1') - Insert row before the selected row.

Edit->Select all - Select all rows of catalog workspase.

5.3 The View Menu.
The keyboard shortcut is  (Alt+V). The following functions are available from the Edit menu:

@. View->Find record (Shift+F) - Find catalog record by date or by number.
[ﬁ View->Save view segment changes (Shift+V) - Save view catalog segment changes.



E‘.i' View->Cancel view segment changes (Shift+C) - Cancel view catalog segment changes.
5 View-> Zoom in (Cntrl++) - Increase the display font size.

= View-> Zoom in (Cntrl+-) - Decrease the display font size

5.4 The Project Menu.
The keyboard shortcut is  (Alt+P). The following functions are available from the File menu:

=

s |
r

= Project->Open Project (Shift+O) - Open an existing project .

Project->New ( Shift+N) - Generate a new project.

Project->Edit project(Shift+E) - Edit an opened project.

H Project->Execute project ( Shift+P) - Execute project task list.
Project->Save Project ( Shift+S) - Save the project to disk.

E Project->Save Project As ... - Save the project under a new name.

Project->Open Recent - Displays a list of recently opened project files to choose from.
E Project->Close ( Shift+L). - Close an opened file project.

5.5 The Protocol Menu.
The keyboard shortcut is  (Alt+R). The following functions are available from the Protocol menu:

I:1 Protocol->Preview Protocol (Shift+R) - Preview protocol.
|__|;|'J Protocol->Save Protocol ( Shift+T) - Save the protocol to disk.
Djl Protocol->Save Protocol As... - Save the protocol under a new name.

5.6 The Tools Menu.
The keyboard shortcut is  (Alt+T). The following functions are available from the Tools menu:

1 g

%9 Tool->Check order ( Alt+K) - Check sorting oder.

1

#'0 Tool->Sort by time (Alt+]) - Sort catalog records by ascending time.

M. . .
?\FTool->Convert magnitudes (Alt+N) - Convert magnitudes to common type.
Z=Tool->Remove duplicates (Alt+D) - Check and remove duplicate records.



EFTool->Select (Alt+S) - Select subcatalog.
%TooloMerge (Alt+M) - Merge catalogs .
EETOOI»Substitute (Alt+U) - Substitute parts of the initial catalog.

E42|uTooI->Check range (Alt+C) - Check range of parameters.
%TooIoCompare catalogs (Alt+L) - Compare two catalogs.

Tool->Draw histograms (Alt+G) - Draw histograms.

5.7 The Options Menu.

The keyboard shortcut is  (Alt+O). The following functions are available from the Protocol menu:
Option->Catalog view segment - Change the number of records in a segment on catalog part of main
window.

Option->Change Errors page size - Change the maximum error lines on the Errors page of the mane
window protocol frame .

Option->Change Correction page size - Change the maximum number of lines on the Correction page
of the mane window protocol frame .

5.8 The Help Menu.
The keyboard shortcut is  (Alt+H). The following functions are available from the Help menu:

{;_‘)Help->Content (F1)

L:¥ Help->What's This  (Shift + F1)
Help->About - Displays a simple message box about compicat program.
Help->About Qt - Displays a simple message box about Qt C++ tool Kit.

6. The catalog editor.

The Catalog editor provides a catalog visualization that is used to edit and display earthquake

catalog (see 4.2.1.Catalog Frame).
Catalog editor works with two dimensional table. Table contains part of catalog named catalog
workspace (page), size of which defines by users (Use menu command Option->Catalog view segment
to define new catalog workspace size). Finished editing one catalog workspace you may continue
editing other one. Before changing workspace after editing you have to save edited workspace.
Program will suggest do it if you try to leave not saved workspace.

Each the row of table contains items (parameters): year,month,day and etc. Each item supports it's
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range.Details in Appendix A . The catalog editor provides validation of input text for each item
according own range. For example you cannot input character for item month accept digital 1 - 12. For
latitude acceptable characters : '-', [0-9], "." and tree digitals after decimal point. Corrected items mark
bold font and blue color.

Editor allows many-item selections.
The list of key-bindings and buttons which are implemented for editing:

©5- Cut the current selection's contents to the clipboard. Menu option is Edit->Cut and keyboard
shortcut is Ctrl+X.

- Copy the current selection's contents to the clipboard. Menu option is Edit->Copy and keyboard
shortcut is Ctrl+C.

L. - Paste the clipboard's contents into the current selection. Menu option is Edit->Paste and

keyboard shortcut is Ctrl+V.
Note: The copy (cut) and paste areas must be have the same size.

%] Delete the current selection's. Menu option is Edit->Delete and keyboard shortcut is Del.
Note: You can delete many-item selections.
- Insert row before the selected row. Menu option is Edit->Insert row and keyboard shortcut

is Ctrl+l .
Note: You can insert just one row before selected row. Inserted row will be copy of selected row.

“&_ Undo edit action. Correspondent menu option is Edit->Undo and keyboard shortcut is Ctrl+Z.

“¥_ Redo edit action. Menu option is Edit->Redo and keyboard shortcut is Ctrl+Y.
Undo-redo buffer is unlimited. All corections of workspace write in correction page of protocol
page of main window. See Protocol frame

7. Tools

7.1 Convert magnitudes.

Catalogs may report magnitudes of different types, which values should be calibrated if used in
calculations together. CompiCat allows the user to make linear conversions of the four magnitudes
reported in a given catalog. To open the window for magnitude conversion (Convert magnitudes) click

.
button %=,
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B Converting magnitudes

Cutput magnitude:

~Common magnitude:

Magnitude flnction:

® f ml e 3if(me= (00 |ythen (m* 240 | + -7.08]yeke 00 |
® f m2 |v|yif(m==[01 |ythen(m* |10 | + (00 |)eke |00 |
D¢ [ma [+ (me=[00 | ythen (m* [10 | + 00 |yeke 00
L) (ma ||y (me=[00 | ythen (m* [10 | + (00 |)eke [00 |

Reset Default

0% ]

0
(o ][ cawa |

A4

Each of the boxes with magnitudes, e.g., -, allows to chose one of the four magnitudes (m1, m2, m3,
m4) reported in the catalog to be used in recalculation.

Output magnitude identifies the magnitude field where the result of the magnitude conversion
described in the block Common magnitude. All the four magnitudes reported in the catalog in process

could participate in the unique determination of the four magnitudes in the output catalog.

The Magnitude function box in Common magnitude allows the four choices - value, maximum,

minimum, average - that determine the unigue conversion:

« value - The output value is determined by the priority order of recalculated magnitudes that are

checked in below. The higher rows are of higher priorities.

e maximum - The output value is the maximum of recalculated magnitudes that are checked in
below.

e minimum - The output value is the minimum of recalculated magnitudes that are checked in
below.

e average - The output value is the average of recalculated magnitudes that are checked in below.

The user can introduce up to four recalculated magnitudes to be used to derive the converted,
presumably, calibrated value by clicking with the left-mouse button the appropriate check-boxes Llon
the left. To avoid using the magnitude function f(m) in the absence of input magnitude determination

you can adjust the values in the leftmost and rightmost edit boxes to a desired magnitude cutoff and
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output constant, respectively. In the presence of input magnitude determination (i.e., when input
magnitude equals to or is above magnitude cutoff) the recalculated value equals to the linear function,

which coefficients should be typed in the two appropriate edit boxes.

By clicking the Default button the user sets the default values of the Tool. By clicking the Reset button
the user can remove all the changes introduced after entering the Tool window. (Note that Reset button

during the first usage of the Tool is equivalent to the default values.)

7.2 Remove duplicates.

Catalogs may have duplicate entries referring to the same events. CompiCat allows the user to make
search for duplicates and either to delete or to leave intact the candidates for being duplicate entries

reported in a given catalog. To open the window for duplicate removal (Remove duplicates) click

button =,

B Remove duplicates

Proximity limits: [ Criterion for autoremaoval; ]

—Proximity limits:

Time: E Latitude: Longitude: |D.5| ‘Depih: [IDEI]%] Magnitude

—Common magnitude:

Magnitude function: H

% f¢ )if(m >=)iﬁen(m*+ )else
® f( [m2  [+])if(m >=[00 |yten(m* (10 |+ (00 |)eke (oo |
® f¢ [m3  [+])if(m >=[00 |yten(m*[10 |+ [00 |y eke (oo |
® f( [md  [<])if(m ==[00 |yten(m* (10 |+ [00 ]y eke (00 |

Resat Default

) |
ey || ok || cancel |
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The Proximity limits tab of Remove duplicates window allows setting the limits of the temporal,
location, and magnitude differences to be use in duplicate search. Specifically, the two catalog entries
are considered candidates for being duplicates if all the differences are less than or equal to the selected
values in the five Proximity limits boxes. Note the difference in magnitude is related to the Common

magnitude, which definition could be adjusted by the user in the same way as Common magnitude from

B Remove duplicates

Proximity limits: | Criterion for autoremaval: I

Duplicate remaval:
[Cj Automatic @ Interactive

Rermave by magnitude: [\talue greater |v]

—Priority: ———— ~Then by order:
[ [Cﬁj first () second

x % (%
3|3z
SEE

Default

Found so far: 2 Remove record <63 by magnitude: "value greater" > <6>:7.50; <7>:8.50

|Lat| Lon |DEp|M1|M2|M3|M4EI # ‘

0 32.97 -116

Leave intact

21% | [t

[ Apply H oK H Cancel ]

The tab Criterion for auto removal allows switching the program from Interactive to Automatic
removal of duplicate entries by choosing the appropriate radio-button in the Duplicate removal section.
Moreover, in the Automatic mode the user has an option to define the rule of unique identification and
removal of catalog entries. Specifically, the user defines the criterion for choosing one of the two
candidate entries by magnitude and, in case of the equality, by their order (the program simply removes
either first or second entry marked with the appropriate radio-button). The magnitude value greater (or
value less) indicates higher priority for the entry to remain in the output catalog; in these cases, the
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choice of magnitudes in the checked boxes [lon the left define the priority for the unique magnitude
determination. Each of the magnitude indices maximum greater, maximum less, minimum greater,
minimum less, average greater, average less applied to the checked magnitudes defines higher priority
for the entry to remain in the output catalog.

In the Interactive mode the user has an option to follow the automatic suggestion, or to chose the
alternative entry, or leave both entries intact. The two candidates for removal are shown in the lower
part of either Proximity limits and Criterion for autoremoval tabs. The button Next confirms the choice
and proceed to the next candidates for duplicate removal.

The button Apply confirms the choice from the Proximity limits and Criterion for autoremoval tabs and
runs duplicate removal procedure.

The button OK confirms the choices already made in the Interactive mode and, from this very point,
continues duplicate removal procedure in the Automatic mode. The button OK is also used to accept all
the results of the Tool. To rerun duplicate removal anew without saving the current results the user can
change some of the Tool parameters and click the button Apply.

The button Cancel is used to cancel all the actions performed by the Tool earlier and closes the Remove
duplicates window.

By clicking the Default button the user sets the default values of the Tool. By clicking the Reset button
the user can remove all the changes introduced after entering the Tool window. (Note that Reset button
during the first usage of the Tool is equivalent to the default values.)

7.3 Select subcatalog.

Working with the entire catalog, a large or humongous one, in particular, may appear inconvenient
and/or time consuming. CompiCat allows the user to make searches from a given catalog and to create
its subcatalog(s). The program may perform different kinds of selection of earthquakes by time, record
number, geographic location, depth, magnitudes (or their linear function), and intensity. To open the

window for subcatalog search (Select subcatalog) click button 1. The window has the four tabs. To
activate searches by parameters listed in the tab, the user must check on the box Lin its upper leftmost
corner.
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M Select subcatalog

Date or number | Hypocenter | Magnitudies | Intensity]

(%] @ DateTime (O Number

—Date:

1984/01/23 05:40:19

Date: from |1984/01/23 05:40:19 || to [1989/10/18 10:04:15 |5

2001,/08/10 20:19:00

1

Murmber: from C@ to C@

191

Default

Process completed: 91 records selected.

| ey || ok || cancel |

The Tab By date or number allows the user to set the limits either for the time period or for the segment
of consecutive record numbers by checking the appropriate radio button.

26



M Select subcatalog

Date or number | Hypocenter | Magnitudies | Intensity]

(% @ Rectangle O Circle O Polygon

~Rectangle:
Latitude: from |-90.0 | o [o0.0 ]
Langitude: from |-180.0 | o[ 2800 | [ Acrass longitude 150

Latitude: :] Longitude: [ l Radius [ l
~Paolygon:
Humber of vertices: [:@ ‘
®| Depth: from |0.0 | o |993.0 |
Process completed: 91 records selected.
[ 100% ]
o o ][ owen

The Tab Hypocenter allows the user to set the location limits. There are several options each associated
with a choice of the three radio buttons and/or interval of depths. The Rectangle, Circle, and Depth
sections are rather self-explanatory and fool-tolerant, while the Polygon one needs a few explanations.

CompiCat can select earthquakes with epicenter coordinates inside any simply connected polygon,
which vertices must be listed in the clockwise order. Click Set Vertices button to open Set Polygon

Vertices window.

b set Polygon Vertices

Lat Lan Iil [ Impoart ... l

1 37 -122.5
2 3775 -121.5
=l 36.2 -120.5

Help

] Across longitude 180

Check on Polygon crosses 180, if the vertices are located on both sides of the 180 meridian and fill in
the desired coordinates of the polygon vertices. If needed, select any row then invoke the context menu

by clicking the right mouse button on the selected row
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and complete insertion or deletion.

and Ctrl+I to insert one.)

7 Delete Del
=, Insertrow  Ctrl+l

M Select subcatalog

[ Date or number | Hypocenter | Magnitudies I Intensity ]

(% @® Range O Common magnitude

~Range:

® i from 5.0 |t [30 |

® m2 from |3.0 |t [0.0] |

O] wafrom 0.0 |0 30 |

) md from |00 [ |
Magnitude function: [valie || from | | o | |

@ f [mufe] )i (me=[00]ythen ¢m* [10] + [20]) eke [00]
@ f( [mefe]yif(m>=[00])yten (m [L0] + [00]) ete [00]
@ f [ma]e))f(m>=[00]ythen¢m* [10] + [00]) eke [00]
@ ¢ [ma]e))fome=[00]ythen ¢m* [10] + [20]) eke 0]

Default

Process completed: 91 records selected,

aply || ok || cancel |

(The user can also use the standard hot keys Del to delete a row

The Tab Magnitude allows the user to set the limits either for any set of checked magnitudes or for the

the common magnitude range by checking either Range or Common magnitude radio button. (For

details on definition of the common magnitude, see 7.1 Convert magnitudes.)
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M Select subcatalog

[ Date or number | Hypocenter | Wagnitudies J Intensity

(%] Intensity: from to

Default

Process completed: 91 records selected.
[ 100% ]

aply || ok || cancel |

The Tab Intensity allows the user to set the limits on the reported intensity of an earthquake.

The button Apply confirms the choice of parameters from all activated Select subcatalog tabs and runs
the requested search.

The button OK accepts all the results of the Tool. To rerun Select subcatalog anew without saving the
current results the user can change some of the Tool parameters and click the button Apply.

The button Cancel is used to cancel all the actions performed by the Tool earlier and closes the
window.

By clicking the Default button the user sets the default values of the Tool. By clicking the Reset button

the user can remove all the changes introduced after entering the Tool window. (Note that Reset button
during the first usage of the Tool is equivalent to the default values.)
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7.4 Merge catalogs.

Catalog compilation may require merging data from different source catalogs. CompiCat allows the
user to merge the records of the catalog in work (called Initial) with those from a number of additional
source catalogs. When being merged into Initial catalog the Catalog add-ins pass through automatic
identification and removal of duplicates according to the user defined choice of Proximity limits.

To open the window for duplicate removal (Merge catalogs) click button %

B Merge catalogs

Merged Catalog(s): | Proyrnity limits: |

—Catalog add-ins:

—Initial catalog

secong.ct . )

third.ct Catalog: "41Double.ct

fourth.ct First record: 1934/12/30 13:52: 0,00
Last record: 1987/12f 1 1: 1: 0.00
Records: 26
— Additional catalog:

~Info:

Catalog: "First.ct”

First record: 1934/12/30 12:52; 0.00
Last record: 198712/ 1 1: 1: 0.00
Records: 11

Doubles {32 ) have found. Process of identification of doubles is cormpleted.
[ 100% |
oo )2 [ o

If Catalog add-ins list is empty or its content would not be used in merge, click Browse button, browse
the directories on your computer for the catalog add-ins to Initial catalog and open one or several of
them in any order. To add one by one more add-ins to the existing Catalog add-ins list from any
directory use Insert button. Other buttons - Delete, Down, Up - permit to manage the list. Note that the
order of the add-ins defines the priority in automatic duplicate removal during the catalog merge: the
higher is the file position in the list the higher priority has its record in duplicate removal.
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B Merge catalogs

| Merged cCatalogis): | Provdmity limits: l

—Proximity lirits:

Tirne: Latitude: Longitude: Diepth: Magnitude:

—Cammon magnitude:

Magritude function:

® £ [miv])f(m s=[00 |ythen(m*[Lo |+ (00 |yeke[oo |
® £ [m2|v])f(m s= (00 |ythen(m*[Lo |+ (00 |yeke[oo |
X f[m3| v )f(m =00 Jothen(m* (Lo |+ (00 |) eke
X f (|| 3if(m >=[00 | )then(m*[L0 | + [o0 |y eke [0 ]

Doubles | 32 ) have found. Process of identification of doubles is completed.
[ 100% |

oAy || ook || corem |

The content of Proximity limits tab window of Merge catalogs tool is the same as of Remove
duplicates.

Note that Merge catalogs tool PERFORMS AUTOMATIC removal of duplicates. For a finer
identification of duplicates the user may wish, first, to make merge with extremely restrictive Proximity
limits, then process the result with Remove duplicates tool .

The button Apply confirms the choice from the Catalogs and Proximity limits tabs and runs merge
procedure. To rerun merge anew without saving the current results the user can change some of the
Tool parameters and click the button Apply.

The button OK is used to accept all the results of the Tool.
The button Cancel is used to cancel all the actions performed by the Tool earlier and closes its window.

By clicking the Default button the user sets the default values of the Tool. By clicking the Reset button
the user can remove all the changes introduced after entering the Tool window. (Note that Reset button
during the first usage of the Tool is equivalent to the default values.)

7.5 Substitute catalog parts.

Catalog compilation may require addition and/or substitution some parts of data from different source
catalogs. CompiCat allows the user to upgrade the catalog in work (called Initial) with data from a
number of additional source catalogs (called Catalog add-ins). The Substitute tool may seem rather
similar to Merge catalogs tool although the rules for merging the data from different sources are quite
different. Contrary to Merge catalogs tool, the Catalog add-ins have higher priority than Initial catalog
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- all the records of the initial catalog that fall within any of the time spans of all add-ins will not appear
in the resulting output catalog being substituted with data from add-ins. Specifically, Substitute starts
with the uppermost add-in from the list, determines its time span from the first to the last record, and
substitutes all the data from the initial catalog from this time span with all data of the add-in (note that
depending on the initial catalog time coverage and the add-in time span, the add-in data would either
prepend or insert or replace or append records to the initial catalog). Turning to the next add-in, if any,
Substitute considers the result of the previous step as the initial catalog and proceeds with the current
add-in. Finally, step by step Substitute comes to the last add-in and completes the task. Note that the
order in in Catalog add-ins list defines the ascending add-in priority, according to which the records
from the last add-in, evidently, will all be present in the output catalog.

To open the window for duplicate removal (Merge catalogs) click button EE

M Substitute catalogs

—Catalog add-ins:
first.csf Browwse
secong.csf [—]
third.csf Up
fourth,csf -
~Info
~Initial catalog: Add-in catalog:
Catalog: "californ,csf" Catalog: "secong.csf”
First record: 1932f 1f 3 17:57: 0.00 First record: 1980f 1/ 3 3:37: 0.00
Last record: 1985/ 6/29 18:23: 0.00 Last record: 1980f 1/ 3 22: 6: 0.00
Records: 19668 Records: 17
Defavlt
Result: Tirme: ( 1932 1/ 2 1757, 0,00 ) - { 1987/12/ 1 1: 1: 0.00 ) Records; 732
(oo J[ oc | coea |

If Catalog add-ins list is empty or its content would not be used, click Browse button, browse the
directories on your computer for the catalog add-ins to Initial catalog and open one or several of them
in any order. To add one by one more add-ins to the existing Catalog add-ins list from any directory
use Insert button. Other buttons - Delete, Down, Up - permit to manage the list.

The button Apply confirms the choice of the Initial catalog and Catalog ins list and runs Substitute
procedure. To rerun the procedure anew without saving the current results the user can change Catalog
ins list and click the button Apply.

The button OK is used to accept all the results of the Tool.

The button Cancel is used to cancel all the actions performed by the Tool earlier and closes its window.
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By clicking the Default button the user sets the default values of the Tool. By clicking the Reset button
the user can remove all the changes introduced after entering the Tool window. (Note that Reset button
during the first usage of the Tool is equivalent to the default values.)

7.6 Compare catalogs.

CompiCat allows the user to compare the initial catalog with the reference one and determine their

intersection or difference and catalog of equivalent pairs or nonequivalent events. The tool makes use

of the definition of equivalent events set up by the user defined Proximity limits.

To open the Compare catalogs tool window click button %
B Compare catalogs

Catalogs Prosirnity limits

Reference catalog: ~Infio:
"exGinitial.csf” ~Initial catalog
- Catalog: "exererged.csf”

First record: 2007f 1/ 2 13:14:19.40
Last record: 2007f 715 16:36.52.25
Records; 52

—Reference catalog:

Catalog: "exGinitial, csf"

First record: 2007f 1/ 3 13:14:19.40
Last record: 2007f 7/15 16:36:52.25
Records: 46

0% |

[ Reset |
]
Coapoy [ o0 || cance |

The Catalogs tab allows to chose Reference catalog for the comparison with Initial catalog along with
the method of this comparison.

Click Browse button, browse the directories on your computer for the reference catalog, and open it.
The two catalogs could be compared by Intersection, Difference, Equivalence, and Nonequivalence.
Intersection mode selects all events from Initial catalog that have equivalent in Reference catalog.
Difference mode selects all events from Initial catalog that have no equivalent in Reference catalog.
Equivalence mode creates the catalog of groups of equivalent events from Initial catalog and Reference
catalog.

Nonequivalence mode selects all events from either catalogs that do not appear in groups of equivalent
events.

The resulting catalogs could be Exported in the standard 68-bytes ASCII format. In case of
Equivalence and Nonequivalence modes the records from Initial catalog and Reference catalog are
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marked respectively with 1 and 2 in the field of Intensity (which original content is lost after
completion of Compare catalogs).

B Compare catalogs

Catalogs | Proximity limits

—Proximity limits:

Tirne: Latitude: Longitude: [0.25 ]Depth: [llj ]%] Magnitucde:

—Common maghnitude:

Magnitude function:

Ol [ma [+ 0if(m »= (00 ithenim* (10 | + [0 |y eke (oo |
Clfe [m2 [« )if(m »>=[00  |)then(m*[10 | + [0 |)ese(on |
[]f¢ |m3 = 3f(m >=)then(m*[1.tl ]+[EI.D ])else [D.EI ]
[ f¢ |ma |=| 3if(m >=)then(m*[1.D l+[D.D ])else[D.D l

Found 46 duplicates, Identification complited.
[ 100% |

| epoy || oc || cancel |

The content of Proximity limits tab window of Compare catalogs tool is the same as of Remove
duplicates. By definition, the two events, one from Initial catalog and another one from Reference
catalog, are equivalent, if all the differences are less than or equal to the selected values in the five
Proximity limits boxes. (Note that CompiCat program presumes no equivalent events in Initial catalog.
Therefore, a record from the initial catalog may have several equivalent records in the reference
catalog, while a record from the reference catalog may have no more than 1 equivalent in the initial
catalog.)

The button Apply confirms the choice from the Catalogs and Proximity limits tabs and runs the selected
procedure. To rerun Compare catalogs anew without saving the current results the user can change
some of the Tool parameters and click the button Apply.

The button OK is used to accept all the results of the Tool.

The button Cancel is used to cancel all the actions performed by the Tool earlier and closes its window.
By clicking the Default button the user sets the default values of the Tool. By clicking the Reset button

the user can remove all the changes introduced after entering the Tool window. (Note that Reset button
during the first usage of the Tool is equivalent to the default values.)
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7.7 Check specified ranges.

Catalogs may have records that were put in by mistake from irrelevant sources or are erroneous though
their parameters being quite acceptable. CompiCat allows the user to search for the records that fall
outside the user defined ranges of the parameters and, if needed, to correct those that appear the first
records (with up to 200 misfits).

To open the window for checking the specified ranges (Check ranges) click button ..

®| Check specified ranges

—Range Limits:

latitude  from (43 | to [sO |
longitude fram [5 ] to [15 ]
depth  from [-10.0 | to [goo0.0 |
ml from (0.0 | to 2.0 |
mz from (0.0 | to [2.0 |
3 from 0.0 | to [2.0 |
e from (0.0 | to [o.0 |

2 walues of pararneters out of range
have been found in 1 records,
I total 532 records have been checked.

[ Help ][ Anply ][ Ok ][ Cancel ]

If needed, change any content of the boxes for the preferred limits.

The button Apply confirms the choice of the ranges and runs Check ranges procedure. To rerun Check
ranges anew without saving the current results the user can change some of the Tool parameters and
click the button Apply again. The statistics of the run, i.e., the total number of misfits of the ranges
along with the number of the corresponding records, appear on top progress bar.

To accept the results of the Tool click OK. The tool completes Check ranges procedure with (i) the
report to Messages tab page the list of user defined ranges and the total number of misfits of the ranges
along with the number of the corresponding records and (ii) the listing in Errors tab page of the
references to the first records with misfits (up to 200 misfits, 25 by default). To change the number of
misfits to report use Options->Error page size (see 5.7 Option menu ).
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57| exinitial. csf - Compilation Catalog Panel |;||§|rg|

File Edit Wew Project Protocol  Tools  Options  Help

FRdd G- DFFREE  «~vd4 HE X »
;.u; |Tasks . Ay ﬂ seC | Lat | Lon | Dep | M1 | MEB [:]
\ Mo Project 2007 3 31 10 12 155 45678 7.406 5 3 ED

“a 2009 4 1 0O 22 559 46,1 7.1 2 3 @ [ﬂ
1. 2007 4 1 20 39 S6 846 157044 10 68 7 £
= | an &
% Record | Description | # |

EE Range check completed. 2 errors found,

Q 1(25 Latitude (Lat) is out of range: value -8.46 , range [ 43, 50 ]

— 2 Longitude (Lon) is out of range: value 157,044 ,range [ 9, 15 ]

EE| & Errors [ %) Messages | B Corrections

@} Iﬁ ﬁ Protocal: unnamed
Ready || ||T00|s|ﬁ

To correct the records with misfits follow instructions described in 4.2.3 Protocol frame.
The button Cancel is used to cancel all the actions performed by the Tool earlier and closes its window.

By clicking the Default button the user sets the default values of the Tool. By clicking the Reset button
the user can remove all the changes introduced after entering the Tool window. (Note that Reset button
during the first usage of the Tool is equivalent to the default values.)

7.8 Draw histograms.

CompiCat allows the user to display graphically different kinds of tables associated with the catalog in
work. The graphical output could be a traditional (i.e. 1-D), as well as a 2-D histogram. Moreover, the
tool permits producing a series of histograms, which display slices of the frequencies considered by an
additional parameter, and, therefore, represent either a 2-D or 3-D histogram. Besides frequencies,
which is the default option, CompiCat may display maps of some other catalog integrals (like sum of
energies etc.) denoted as Intensity. The tool may export output tables as comma separated values (the
Microsoft Excel CSV format), as well as print and make PDF of the display.

To activate Draw histograms tool click button .. By default, CompiCat displays the 2-D histogram of
the earthquake frequencies on the longitude-latitude plane.
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The 2-D histogram displays frequencies as color coded cells, which size could be adjusted by changing
the Number of intervals (from 10 to 150) and the min and max limits attributed to X and Y axes. The
associated colors of Intensity scale are shown on the right side of the histogram. The user may change
the X and Y axes to time (in years), latitude, longitude, depth, and any of the four magnitudes. To
confirm the choice and redraw 2-D histogram, click button . ..

The button allows the user to zoom on an area of interest in a 2-D histogram. Toggle the button, bring
the cursor on the histogram plate, outline the area of interest by pressing the left mouse button and
dragging the cursor. (With the left mouse button pressed at any place of the histogram plate the
program displays the cursor XY coordinates. Clicking the right mouse button will zoom out the display
one step back . Zooming can operated as often as possible.)

The button .allows the user to switch Intensity scale from linear to logarithmic one. To switch scales
toggle the button and redraw histogram.

To display a traditional 1-D histogram either for X- or Y-axis click either button . or ., respectively.
Traditional histograms displays frequencies as bars of different heights.

The user may wish mapping catalog integrals that differ from the default frequencies. CompiCat
provides making a choice between sums of earthquake energy, area, and length, as well as the user
defined 10%*™® weights (where a and b are arbitrary constants, and m is the earthquake magnitude).
These quantities permit better understanding of of the energy release, or the area ruptured, or the total
length of ruptures in the area of interest. To specify weights open Weight tab on the left; click on radio
button and make the choice of weights.
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Type | Axis¥ | Az | Weight
Settings:

Type: | Energy I~

Magnitude: | mi [

ar 118

b 1.5

To produce series of histograms toggle Invoke by List button .. Make the choice of an additional
parameter, Number of intervals (from 2 to 20), and the min and max limits to be used. Toggle button
Switch image scale to specify either a common or interval dependent normalized scales of intensity.
Click either of Redraw buttons to display a series of 1-D or 2-D histograms. Click or button to display
the previous or the next histogram in a series.

If needed, invoke help text on buttons by clicking ., then click a button to get the appropriate quick help
on it.

--opens the dialog for printout. (Note that a histogram image can be saved in the PostScript format by
using print to file option.)

--saves a histogram image as a PDF file

--saves a histogram table as a Comma Separated Values (CSV) Microsoft Excel file. Note that there
might be a problem in reading CSV format files due to Regional Options and Microsoft Excel
International Options (see Appendix C. Platform Notes).

Click Ok button to leave Draw histograms window. CompiCat saves Number of intervals for each of
the X, Y, and additional axes.

Click Cancel to leave window with no save.
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8. Project

8.1 Managing Projects.

When using CompiCat on routine basis the user may wish repeating the same or similar sequences of
tasks. This is of special importance when reproducing the results of compilation achieved in the past.
CompiCat allows the user to create project files that specify sequences of operations performed with
seismic catalogs. This could be done with the project wizard, which invokes when the user opens either
New project or an existing project for editing (Edit project). The project wizard allows the user to
define a project file as a sequence of catalog operations for implementation in the future. Any single
sequence may include the following tasks in any order although without a repetition:

1. Check specified ranges
. Convert magnitudes

. Remove duplicates

. Select subcatalog

. Merge catalogs

. Substitute catalogs

7. Compare catalogs

OO WN

Note that tasks 1. Check specified ranges and 7. Compare catalogs define a single sequence by
themselves and could not be combined in one project with tasks 2-6.

The following buttons and menu entries (ordered as they appear on the upper Tool bar) facilitate
managing of the projects:

Tgenerates a new project (optional entries Menu item Project->New Project or keyboard shortcut
Shift+N). See Project Wizard.

%opens an existing project (optional entries Menu item Project->Open Project or keyboard shortcut
Shift+0).
=i

cE-edits an opened project (optional entries Menu item Project->Edit Project or keyboard shortcut
Shift+E). See Project Wizard.

Eexecutes the project task list (optional entries Menu item Project->Execute Project or keyboard
shortcut Shift+P). See Execute Project.

Esaves the project file to disk (optional entries Menu item Project->Save Project or keyboard
shortcut Shift+S).

Esaves the project file under a new name (optional entries Menu item Project->Save Project As ...).
Ecloses the project without saving (optional entries Menu item Project->Close project or keyboard
shortcut Shift+L).

Menu item Project lists the most recent project files, which could be loaded easily.

The project file names have extension ".pro’ or .PRO" as a CompiCat standard added automatically
when you save project files.
In case, some of the catalogs listed in the project files are not found, the user is given automatically an
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opportunity to fix the problem (see Repair Project).

8.1 Project Wizard.

The project wizard allows the user to define a project file as a sequence of catalog operations for
implementation in the future. Its window appears when the user generates a new project (e.g., by

clicking button m) or opens for editing an existing project file (e.g., by clicking @ ). An example of

Project wizard window for the existing project file is given below.

b Project Wizard - Edit Project: ex1 Zinitial.csf

Project Info A
Diefine a sequence of operations on catalogis), J
~Initial Catalog: Pararneters of Tasks:
e 12initial csf ‘ { @ Currently defined O Default
— Tasks:
O %, Chedk specified ranges
@ Optional Tasks: List of Tasks:
= Convert magnitudes add -= {.‘3 Conwert magnitudes
= Rermove duplicates % Merge catalogs
CF Select subcatalog 28 Substitute catalogs
% Merge catalogs C¥ Select subcatalog
28 g hstitute catalogs
) B3 compare catalogs
[ = Back l Memt = I Cancel l Heln ]

The window consists of the two frames - Initial Catalog and Parameters of Tasks - on the top and a
larger Tasks frame below.

To change Initial Catalog for different one Browse computer directories and select a CSF formatted
catalog.

The Parameters of Tasks could be set either to Default values or to Currently defined ones, those in
progress before Project wizard has been invoked. The Currently defined values of parameters can be
obtained by opening some previously saved project file or by working out the tasks parameters anew,
without reference to any project.

Tasks frame lists on the left the five Optional tasks along with Check specified ranges and Compare
catalogs. low. The user defines the tasks by toggling one of the three radio buttons, adding (Add ->) a
selected task to the List of Tasks, deleting (<- Del) a selected task from the List of Tasks, and by using
Up and Down buttons for setting the desired order of tasks.

Reset button removes all the changes made after invoking Project wizard. Project button reloads the
initial project parameters. Default button sets default project parameters. In case of a new project,
clicking any of the three buttons would lead to the same (Default) values.

40



Clicking Next-> button invokes one by one, from the first to the last, the current task tool window for
setting the desired parameters. (For details of the tools see the appropriate chapter in 7. Tools.) At any
moment of time the user can return to the previous task tool window by clicking <-Back button or exit
Project wizard without changes by clicking Cancel button. After setting the last task parameters click
Finish button (i) to complete formation of the project, (ii) to close Project wizard, and (iii) to put the
brief info into the project frame of the CompiCat main window.

After formation of the project the user can execute the project and save (i) the project file, (ii) project
output catalog, (iii) project protocol, etc.

8.3 Execute Project.

Tasks
=] iProject:
3 project.pro
=] Catalog:
8 californ.cst
= Tasks:
=] Rernove duplicates
El 5= Merge catalogs
8 secong.csf
B Airst.csf
8 third.csf
B fourth.cst
C¥ Select subcatalog
=] FE‘ Substitute catalogs
B substituted.csf
B substitutel.csf
B substitute2.csf
2% Comverting magnitudes

This window is tree view visualization of project file

Click button .- Open an existing project to browse existing project file and this part of main window
named project will appear. You also receive this window after using project wizard dialog. See 8.2
Project Wizard.

Click button E or menu option is Project->Execute Project, or use keyboard shortcut is Shift+P to
execute actions list. Waite cursor will appear and action rows will change color (black-blue) while
project executing. After execution message and correction page of protocol frame will be contains
information about executed actions. See 9. Protocol job.

The unnamed resulting catalog will place central part of main window. Save it under any name, save
the project file if it was modified and save the protocol file if you need. If you forgot to save one of
these files program will remember you about saving them when you try to exit program.
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8.4 Repair Project.

M Repair Project Dialog

Tasks
= Project:
E ¢ fDocurments and Settings/sasha/ecpfexamples/project/praject.pro
= Catalog:
B C/Documents and Settingsfsashafecpfexamples/californ.csf
[ Tasks:
5] Remove duplicates
El 53 Merge catalogs
B ¢ /Documents and Settingsfsashafecpfexamples/secong.csf
B C/Documents and Settingsfsashafecpfexamples/first. csf
H C/Documents and Settingsfsashafecpfexamples,third. csf
C:/Docurmnents and Settings/sashafecnfexarmples/fourth.csf
P Select subcatalog
=] EE Substitute catalogs
E € fDocurnents and Settings/sasha/ecpfexamples/substituted. csf
B C:fDocurments and Settings/sasha/ecpfexamples/substitutel csf
# CfDocurnents and Settings/sasha/ecpfexamples/substitute? csf
E-.'",'!e Converting magnitudes

[ (4 H Cancel l

This opportunity is automatically given to the user, when he opens existing project and some project
files are not exist.
It may be following files: initial catalog, merge, substitute and compare actions file.
They may be was changed it's pathes: housing directory or using platform was changed.

In this cases Repair Project window appiers when user pushes button ., select menu item Project-
>Q0pen Project, use keyboard shortcut is Shift+O and select project file name or select one of the
recently project file list of the Project menu.

Double click left mouse button on tree veiw row marked icon . The row editor will appear. Push
it's button #¥for open file navigator. Find new file location and select needed file. After the row editor

will be close, this row will be contain new file wtith it's full path, change icon by = and drow blu
foreground font color.
When you find all missing files press OK button for accept repair file names of project file.

9. The Protocol Job.

These following two pages are content of protocol job of program;

1. Message page of protocol frame.
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Buid Project Messages: (=]
Project File: C:/Program Fles/Earthquake Catalog Processingfecp/exerdses/ex12-project-comp . pro
Inifial catalog "ex12inifal.csf has 46 records from 2007/ 1/ 3 13:14:19.40 to 2007/ 7/15 16:36:52.25

HoHk Tack: Merge catalogs *k

Current catalog has 46 records from 20077 1/ 3 13:14:19.40 to 2007/ 7/15 16:36:52.25 i
List add-ins files:

1 "exiz2-merge-1.csf" has 3 records from 2007/ 7/12 0: 9:32.90 to 2007/ 7/15 16:36:52.25

2: "ex12-merge-2.csf" has & records from 20077 6/27 21:27: 2,10 to 2007/ &/30 12; 7:29.00

Delta thresholds: Time: 60 ; Latiude: 0.50 ; Longitude: 0.50 ; Depth: 10 ;

Found 3 duplicates. Identification complited.

Output catalog has 52 records from 2007/ 1/ 3 13:14:19.40 to 2007/ 7/15 16:36:52.25

4k End of Task: ;| Merge catalogs @

..; Errors | 1= Messages | ] Correcijonsl

This page contains information about input-output catalogs, tools parameters and project execute
action.

2. Correction page of protocol frame.

2. Merging current and addHn catalogs. (=]
Current catalog has 47 records from 2007/ 1/ 3 13:14:19.40 to 2007/ 715 16:36:52.25

Add-in catalog "ex12-merge-Z2.csf” has © records from 2007/ 6/27 21:27; 2,10 to 2007/ 6/30 12:
729,00

Found 1 duplicates. Idenfification complited.

1:> 1, 40- 2007 62863204572 106226330000

1> 20 3- 2007628632645751062260032323.12

Output catalog has 52 records from 2007/ 1/ 3 13:14:19.40 to 2007/ 7/15 16:36:52.25
### Bnd of Task: | Merge catalogs *#*

*xk Tack: Substitute catalogs 4k

Catalog in process Catalog in process has 52 records from 2007/ 1/ 3 13:14:19.40 1o 2007/ 7715
15:36:52.25

g

. Errors | Messages | B Corrections

This page contains information about editing catalog or details catalog tool operations such as list of
doubles for example.
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__The button and Option Menu entries manage protocol job.
u - Preview Protocol. Correspondent menu option is Options->Preview Protocol and keyboard
shortcut is Shift+P. You get text window and can edit it. Click L_'ibutton to save protocol.

LG - Save the protocol to disk. Menu option is Options->Save Protocol and keyboard shortcut is
Shift+S.

Djl - Save the protocol under a new name. Menu option is Options->Save Protocol As...
The standard extension name for protocol file is *.protocol or *.PROTOCOL. When you save
protocol file type just name of protocol and extension name will add automatically.
The program will suggest you to save the protocol on a disk if you have not made it earlier.

10 The Help Online.
Compicat program provides online help, with three levels of detail:

1. Tool Tips and Status Tips.

Tool Tips is extremely brief help, that appears when cursor is hanging over a toolbar button for a
certain period of time. Tool Tips are presented with black text on a yellow background. Status Tips
are also a short piece of descriptive text, a little longer then a tool tip. When the mouse hangs over a
toolbar button, a status tip appears in the Status bar.

2. What's This? provides a single Wind_qw with an explanatory text that pops up when the user asks
"What's this?" When you push button Q_‘?or push keyboard buttons (Shift + F1) the cursor changed
to 17 and you can click on any toolbar button to obtain its help text.

3. Online Help is provided by a help browser. Ecp programs have a "Content" entry in the Main

Window Help menu and help buttons in other dialog windows. Click "Content" entry of Windows Help
menu (keyboard button - F1) to open HTML-based program manual ( see Help browser ).

11. The Help Browser.

Online Help is provided by a help browser. Ecp programs have a "Content" entry in the Main
Window Help menu and help buttons in other dialog windows. Click "Content" entry of Windows Help
menu ( keyboard button - F1) to open HTML based program manual.
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10. Help Online.

CompiCat pragram provides online help with three levels of detail:

1. Tool Tips and Status Tips.

Tool Tips is extremely brief help that appears when cursor is hanging over a koolbar button for a certain period of time, Tool
Tips are given in black on yellow, Status Tips provide a short piece of descriptive text, a little longer then a toal tip, WWhen
the mouse hangs over a toolbar button, a status kip appears in the Status bar.

2. What's This? provides a single window with an explanatory text that pops up when the user asks "What's this?" When you push buttan

L7
@(Dr push keyboard buttons shift + F1) the cursor changed to | and vou can click on any toolbar button to obtain help text onit,

3. Online Help is provided by help browser, CompiCat program hawve Confanéentry inthe Aaf menu and Sefp buktons in all other windows,
Click Contantof Hafpmenu (or kevboard button F1) to open HTML-based program manual { see Help browser ),

Compilation Catalog Progran

Caopyright @ 2005 - 2007 Mitpan Ecp-1.2.4

Menu entries and tool bar

View menu:
View->Print (Cntrl P) - print current HTML page.
View->Zoom in (Cntrl++) - Increase the display font size.
View->Zoom in (Cntrl+-) - Decrease the display font size
View->Exit (Ctrl+Q) - Exit the application.

Go menu:
Go->Backward (Alt + Left Arrow) - Go back one page.
Go->Forward (Alt + Right Arrow) - Go forward one page.
Go->Home (Alt + Home) - Go program contents page.

Help menu:
Help->About - Displays a simple message box about Help Browser program.
Help->About Qt - Displays a simple message box about Qt C++ tool Kit.

Bookmarks menu:
Bookmakrks->Add Bookmark (Cntrl++A) - Add Bookmark.
Bookmakrks->Manage Bookmarks ... (Cntrl++M) - Manage Bookmarks.
List of chosen bookmarks.
Manage Bookmarks:
Click this menu item to manage bookmarks and following the dialog window will appear:
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E] Manage Bookmarks

Compicat Program:; Table of Contents b
Zompicat Program: The Oplions Menu

Compicat Program; The File ToolBar
Zompicat Program: Subskitube subcatalog

Diown

[ o [ coe

Click Up, Down buttons to change the position of bookmarks. Click Del button to remove one, click
Del All to cleare bookmarks list.

Appendix A. The MITP standard formats for earthquake data, program project,
and job protocol.

1. Earthquake catalog format.

The standard format specifies -
- the origin time, i.e., year, month, day, hour, minute, and second with the accuracy of one hundredth,
- the latitude and longitude in degrees with the accuracy of one thousandth,
- the depth in km with the accuracy of one tenth,
- the four magnitudes (presumably mb, ms, m1, m2) with the accuracy of one hundredth, and
- the macroseismic intensity (presumably, Modified Mercalli Intensity; 0 — no data, 1-12).

CompiCat program supports the Gregorian calendar. This calendar was adopted by England from
September 14, 1752. The valid year range is [0, 8000]. The standard ranges of other parameters are as
follows - latitude [-90, 90], longitude [-180, 180], depth [-10, 999], magnitudes [-10, 10], intensity
[0, 12].

CompiCat program checks the ranges of parameters each time you edit catalog and set parameters for
catalog operations. Therefore, you cannot type in the value which is outside the standard range.

2. Project format.
CompiCat program creates the binary project file to be used for a repetition of the compiled catalog
in the future. See Manage Project.

3. Job protocol file.
CompiCat program creates automatically the protocol job file, which lists information about every
step and decision you make when compiling the catalog. See Protocol.

Earthquake catalogs (in the MITP standard format) and CompiCat project files are binary files of
encoded information, which is compatible with the package running under MS Windows, and LINUX.
Thus, for example, a catalog compiled on a PC under MS Windows can be used for further runs of the
package installed on a PC under LINUX. CompiCat project files are compatible with the package
running under UNIX (e.g. a Sun SPARC under Solaris ).
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Appendix B. How to register a new format supported?

CompiCat program helps to upgrade the list of supported earthquake catalog formats, so that only a
few lines of description are needed to access earthquake catalog data in a text format.

CompiCat program generates formats from the information listed the file named standardformat.list
located in the subdirectory Install Directory/ecp/ref ( see Installation Notes )

To register a new format in the list of supported put an additional block of description at the end of
the standardformat.list file. Each block should start and end with a line of minus characters, which
embrace the description. Each line of description starts with one of the following locators — TITLE,
URL, REF, TIME, LAT, LON, DEP, M1, M2, M3, M4, INTEN, SKIP, REM (note that some of the
locators like URL, REF, REM could be not necessary). A locator may have parameters listed in the
brackets. Usually, these indicate the starting position of the value followed by the string of its format.
For example, TIME(1,YYYY/MM/DD HH:mm:SS.ss) indicates that the origin time is given in
positions 1-22, DEP(34,DDDd) — the string of depth format is DDDd, SKIP(1,!GS) — each record that
starts with GS will not be skipped, etc. The format specifications for each locator are as follows -

TITLE - used by CompiCat to display the format name;

TIME: Y (year), y(fraction of the year), M(month), D(day) or d(day of the year from January 1st),
H(hours), m(minutes), S(seconds), s(fraction of the second);

LAT: D(integer degrees), d(fraction of a degree) or M(minutes, '), m(fraction of a minute) or s(seconds,
"), - or N or S(sign);

LON: D(integer degrees), d(fraction of the degree) or M(minutes, '), m(fraction of the minute) or
s(seconds, "), - or E or W(sign);

DEP: D(integer including sign if any), d(fraction);

M1, M2, M3, M4 - D(integer), d(fraction);

INT: one character;

SKIP: If the string starts with “!”” character than each record that contains this string at the specified
position will be read or skipped otherwise. Up to ten SKIP lines are allowed;

URL - the web site reference to receive catalogs, not used by the program;
REF - the place for the reference to format description, not used by the program;
REM - remarks, not used by the program.

The following formats are initially supported after installation of CompiCat program -

1. 20 byte - Standard Format - Binary - used in some MITPAN programs.

2. 41 byte - Standard Format - Text - used in some MITPAN programs.

3. swf.txt - Standard Wide Format - Text - text format of internal standard CompiCat binary format.
4. anss - Advanced National Seismic System - URL http://quake.geo.berkeley.edu/anss/catalog-
search.html

5. anss 80-col - Advanced National Seismic System - URL
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http://quake.geo.berkeley.edu/anss/catalog-search.html

6. pde - NEIC Preliminary Determinations of Epicenters - URLs PDE-monthly -
ftp://ghtftp.cr.usgs.gov/pub/pde;

PDE-weekly and QED - ftp://ghtftp.cr.usgs.gov/pub/weekly

7. scec - Southern California Earthquake Data Center - URL
http://www.data.scec.org/ftp/catalogs/SCEC_DC/

8. scsn - Southern California Seismographic Network - URL
http://www.data.scec.org/ftp/catalogs/SCSN/

9. hypo71 - Summary hypo71 format year 2000 - URL
http://www.data.scec.org/catalog_search/date_mag_loc.php

10. hds - NEIC Hypocenter Database System - URL VX-format - ftp://hazards.cr.usgs.gov/hds

For example:

TITLE pde - NEIC Preliminary Determinations of Epicenters
URL PDE-monthly - ftp://ghtftp.cr.usgs.gov/pub/pde

URL PDE-weekly and QED - ftp://ghtftp.cr.usgs.gov/pub/weekly
REF

TIME(5,YYYYMMDDHHmMMSSSS);

LAT(21,DDdddN);

LON(27,DDDdddE);

DEP(34,DDDd);

M1(48,Dd);

M2(52,Dd);

M3(57,Ddd);

M4(67,Ddd);

REM a - ascii character list(X -10,E - 11,T - 12)
INTEN(80,a,XET);

SKIP(1,!GS);

Examples of the format files

TIME(L,YYYY/MM/DD HH:mm:SS.ss);
LAT(24,-DD.dddd);
LON(33,-DDD.dddd);
DEP(43,DDD.dd);M3(51,D.dd);
SKIP(L,--):

SKIP(1, );

TIME(3,YYYYMMDDHHMmMSSss);
LAT(21,DDdddN);
LON(27,DDDdddE);

DEP(34,DDDd);

M1(48,Dd);
M2(52,Dd);



M3(57,Ddd);
M4(67,Ddd);
INTEN(80);

SKIP(1,!GS);

TIME(L,YYYY/MM/DD HH:mm:SS.sss);
LAT(35,-DD.ddd);

LON(43,-DDD.ddd);

DEP(52,DDD.d);

M1(73,Ddd);

TIME(L,YYYY MM DD HH mm SS.ss);
LAT(25,-DD MM.mm);

LON(34,-DDD MM.mm);
DEP(54,DDD.dd);

M1(47,D.d);

SKIP(L,#);

Name of the fields:
TIME - year, month, day, hr, minute, second | have not considered possibility to give time in years and
fractions
LAT - latitude
LON - longitude
DEP - depth
M1 - first magnitude, or "MS"
M2 - first magnitude, or "MS"
M3 - first magnitude, or "MS"
M4 - first magnitude, or "MS"
INT - intensity (only one character can be read)
SKIP - to manage skipping non-data records

Format specificators:
TIME: Y (year) y(fractions of the year) M(month) D(day) d(day from 1 January of the year) H(hours)
m(minutes) S(seconds) s(fraction of second)
LAT: D(integer degrees) d(fraction of a degree) M(minutes,") m(fraction of a minute) s(seconds,"”) -, N
or S(sign)
LON: D(integer degrees) d(fraction of a degree) M(minutes,") m(fraction of a minute) s(seconds,") -, E
or W(sign)
DEP: D(integer part including sign if any) d(fraction part)
M1,M2,M3,M4 - D(integer part) d(fraction part)
INT: no specificators, only one character will be read
SKIP: multiple (up to 10) strings of SKIP are allowed. If first character after position and comma is ! -
including rule will apply, otherwise excluding rule will apply; the following string up to ) will be
compared with the input string starting from the indicated position.
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