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Lab Introduction

Requirements

These labs will tike you step-by-step through the process of capturing, simulazing and netlisting a
design which vou will then program into an Actel FPGA.
These labs reflect the Actel DeskTop version R3-1998.

Windows 95 is the assumed operating system.

General Format

All the labs in this manual are organized the same way. On the left, you will see a TASK column.
This is what vou do.

On the right. there is a RESULT column. This is the result of the task on the teft and, in some cases,
offers extra explanation or questions to remind you of why you are performing this task.

[t is hoped that the TASK column will suffice for quick refreshers later when you get back to work.
All typed commands will appear in lower case bold, for example: Type comp
A carriage return must be entered after every typed command

All menu selections will be shown in Bold with only the first letter capitalized (the way they appear
in the menu), Walking selections will be separated by a “>" character, for example: Select File >
QOutput Format

All directory and file names will appear in lower case italics, lor example: \actel _designs\dmac
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Lab Setup

Creating a VeriBest Project with Actel Libraries

TASK

RESULT

0.

1

Insert vour training floppy into the A drive.

From the Windows Start button, select
Programs > Actel DeskTOP > Actel
Desk TOP

From the top line menu, select
Project > New

Make the following entries:

Project Name = DMAC

Location of Project File = C:\actproj\dmac
Click Next.

From the Simulation Language pull-down:
e Verify that VHDLS87 is selected.

e From the Technology listing, select Actel
3200DX Technology

e (lick Next
Click Next

Click Next

Verify that vour project matches the one shown
in Figure 1 betow,

The VeriBest DesignView window will
open.

A dialog will appear prompting you to
specify the project name and location.

Another dialog will appear prompting
you to specify a simulation language
and an Actel technolegy (family).

A window will appear prompting vou to
add stimulus files to the project.

A window will appear prompting vou to
add design files to the project.

A window will appear displaying a
summary of your project detinition,



Figure 1. New Project Information Summary for DMAC Project

10. Click Finish.

Adding Your Own Libraries to the Project

We have created an Actel border symbol and placed it in our own library. In order to access this border, you
must add our border library to the Actel libraries already present in your project.

TASK RESULT

I. Insert your training floppy into the A drive.

2. From the DesignView top-line menu, select A Projecrt Settings window will open
Project > Settings with three tabs:
Design
File Locations
Libraries
3. Click the Libraries tab. In the Library Search A new library line will be added to the
. . . end of the search order.
Order toolbar. click the New Library icon ki
-+ Atthe end of the new. blank library eniry, click The act _bord.sth file will be added 10
the Browsericon wi In the resulting browser. the end of the search order. A #.s1b file
locate and open the following file: 1s a hibrary file that contains various
symbols.
A:\DeskTOP_Training\act_bord.slb
We need our custom border symbal to be found
first. so iU's .stb file must be first in the tibrary
seach order.
5. Highlight the act_bord sib entry and click the

Move Upicon ' until it is listed first.

6. Click OK 1o exit the Project Settings window.,

~1

Select File > Exit to quit from VeriBest
DesignVicuw,

-
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Lab 1

Generating Macros with ACT. gen

Tusks
In this Lab, the student will:

. Invoke ACTgen.

[

Generate a 6x8 RAM macro in structural VHDL format.
3. Generate an up counter macro in structural VHDL format.

4. Generate a down counter macro in structural VHDL format.

Generating Macros with ACTgen

TASK RESULT
. Select Programs > Actel DeskTOP > Actel The VeriBest DesignView window will
DeskTOP open.
2. Select Project > Open A browser will appear.
3. Find and open vour Cactpropdmacdmac.pry file. The project you created in the last lab will

open showing an empty design hierarchy
4+ Inthe right side of the top ool bar., click the ACTgen  The ACTgen window will open.
con

3. Fromthe Fannls pull-down menu. select 3200DX The RAM fill-in-the-blank form wili open.
family then ohick the RAM macro type.

O Inthe appropriate fHields, describe the RAM as

Fodlows:

Depth =6

Width = 8

RANM Fanin = Auto

Write Enable = Active High
Read Enable = Active High
Write Clock = Rising

Read Clock = Rising



|

I

18

e

-

7. Verify that your settings match those shown in Figure
2

—

Figure 2. The ACTgen RAM Window

8 Click the File > Generate button (as shown in

Figure 2.)
0. From the Netlist/CAE Formats list, select VHDL
For the File Name enter MY_RAM and click OK

10. Verify that MY_RAM has been added to the design
hierarchy shown in the DesignView window.

14, In the ACTgen Macro Builder window. click the
Counters button,

Y

The Generate Macro window will open

An ACTgen Report window will open.
listing pertinent implementation
information.

This will take a minute to complete.

The counters form will appeur.



12, Specify the parameters listed below:

Counter = Linear
Variations = Balanced
Width = 8

Sequential Type = Default
Direction = Up

Asyn Clear = Active Low
Sync Load = Active High
Count Enable = Active High
Clock = Rising

Terminal Count = None

I3. Generate the macro with the file name UPCNT,
Verify that it is added to your design hierarchy.

I4. Return to ACTeen. This time generate a linear,
balanced. 8-bit DOWN counter with an active high
Terminal Count.

Accept all the other default values.
Name it DWNCNT.
15. Try to exit ACTgen.

16, Electto save the log file to a file called actgen.fog.
Notice where the file is saved.

I'7. Chek OK to save the file and then exit ACTgen.

File ;jame i
{&CTaenog

You will be prompted to save the log file.

Your Save As window should match Figure
3.

Y actproj
" dmac

7 edif

= design_defirition
7§ actgen

Figure 3. The Save As Window for the AC Tgen Report File

10
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L.ab 2

Generating VHDL Blocks with VeriBest

Tasks

In this lab. the student will:
1. Create new VHDL files in a VeriBest project.
2. Add existing VHDL design files to the current VeriBest project.

Creating New VHDL Files in a Project

This tab assumes that the Actel DeskTOP is running and that the dmac.prj project is open.

TASK RESULT

1. In DesignView's top line menu, select File > New A window will appear prompting you to
specify the type of the new block.

2. In the resulting dialog box, select VHDL File The VHDL editor will open for a new file
and click OK. named VHDL Filel,

3. In the VHDL editor, type in the description
below. Notice that ali VHDL key words are
recognized by the editor and displayed in a
different color.

library ieee;
use ieee.std logic_1164.all;
entity decode is
port (data: in std logic_wvector(4 downto 0);
aeb: out std logic);
end decode;
architecture behave of decode is
begin
with data select
aeb <= '1l' when "11111",

'0' when others;

end behave;



4.

5.

When finished. select File > Save As and enter
decende as the new name.

Select File > Close

The VHDL wiil close and you will be
returned to the Design Hiearchy view. Notice
that the new DECODE block has beeq added
to the project.

Adding Existing VHDL Files to a Project

In the last section. vou created a VHDL block “from scratch”.

files into your project.

In this section, you will copy existing VHDL

TASK

RESULT

129

6.

In the top tine menu. select Project > Add to
Project > Add Design File

Focus the resulting browser on your A: drive.

Select controll.vhd and click Open.

Click Copy

Use the sume procedure to copy in the
strobe_gen.vhd file.

From the Design Hierarchy, highlight the
strobe_gen.vhd file. right-click your mouse and
select Open from the resulting pop-up.

)

A browser will open.

Three VHDL. files will appear:
strobe_gen.vhd, controfl.vhd and
dmac_stim.vhd.

A window wiil appear asking whether the file
should be linked to the project or copied.

The VHDL block will be added to the project.

Notice that DesignView recognizes the block
as a VHDL file and opens the VHDL cditor
accordingly.
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Lab3

Simulating with Veribest VHDL Simulator

Tasks

in this fab, the student will:

1.

2.

3.

Generate sumulus for VHDL blocks.

Associate stimulus for VHDL blocks.

Use the VeriBest VHDL Simulator to simulate VHIDL blocks.

Generating and Associating Stimulus for a VHDL Block

TASK

RESULT

1]

From the Design Hierarchy view, highlight the
decode.vhd file, right-click your mouse and try
to select Generate Stimulus,

What happens?

Right-click your mouse again, but this time
select Set as Root.

Now select Generate Stumulus

Click the Insert Edge icon fi

Move yvour cursor to the waveform area of the
Dataj4:03 bus and click the mouse to insert
transitions at approximately 20, 40, 60 and 80
ns.

Don't worry about the values in each segment of
the bus vet.

Click the Escape icon B 10 exit from the
"Insert edge” mode.

QOPS - the menu is greyed-out!

This is because decode has not been set as the
"root” design.

The decode.vhd fite will change to bold face.

A Wavebench tool will open with i new tile
named decode.wsw

Bus transitions should appear at each insert
point.



6.

el

In the first bus segment of Data[4:0] (from Ons
to 20ns). doubie click the value (for example,
hZZ)

Enter a value of 00 and hit Enter.

Repeat this procedure to assign five values as
shown in Figure 4 below:

The value will highlight and turn into an
editable field.

Notice that the value shown is h 00. The hex
prefix is added automatically.

> data(4:0]

& acb

Figure 4. The decode.wsw Stimulus File

When you are done. select File > Close and
eleet to save the file in all the resulting
windows,

You will be returned to the Design Hierarchy
view.,

Congrawlations! You just created a stiumulus file! This file has automatically been named and
saved to the current project. To see the file .

0. Click on the Simulation Manager tab.

. Double clhick von decode.wsw

The VB Project Simutation Environment
display will appear.

All the stimulus files for the decode block
will be displayed. At this point. there should
only be one: decode_stim.vhd,

To create different stimulus files for this same
block in the future, make sure you select

File > Save As in WaveBench tool.
Otherwise. this same _stim.viid file will be
overwritten.
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Associating Stimulus to a Block

Before simulation can begin, you must associate a particular stimulus file to the block that you want to

simulate.

TASK

RESULT

. Inthe DesignView window, return to the Design

Hierarchy tab.

2. Highlight decode. right-click your mouse and

select Associate Stimulus

3. Under the decode.wsw entry, select the
decode_stim.vhd file and click OK.

4. 1In the future. you may forget which stimulus file

has been associated.

To determine this, highlight the block (in this
case. decode) and right-click your mouse to

select Properties.

A window will open displaying all the known
stimulus files for this block.

The decode block is now ready for simulation.

Notice that a small blue symbol has been
added to the decode block icon. This symbol
indicates that the block has been associated
with a stimulus file.

A Properties window will appear. Notice the
Stimulus File entry at the very bottom.

Performing Behavioral Simulation of a VHDL Block

TASK

RESULT

. From the Design Hierarchy tab, highlight the
decode block and right-click your mouse to

select Open in Simulator.

2. Verify that vou have two files shown in the

Decode source hierarchy in this order:

Decode vid
Decode_stim.vhd.

You may see a prompt stating that:
There 1s existing library environment . . . et

If you do. select Yes to reinitialize.
Eventually. your simulator will open
displaying the decode source hierarchy.



9.

10.

Click the Compile All icon lﬁ

If any errors are listed. double click them. A
VHDL editor will open and display the
offending code. If you have questions about
how to correct the error, call the instructor.

Click the Execute Simulator icon «

Chick the Wavebench icon 3

From the

. . o
Signals icon "=

Highiight the Data(4 downte 0] vector click the

Wuvebench toolbar, select the Add

Add button. Repeat this for the AEB output

signal.
Click the Run Simulation icon -
tor 100ns by default)

From the

Fit icon 'i@_j

L (it will run

Wavebench toolbar, click the Zoom

Vertly that your simulation results match those

shown in Figure 5.

All the .vhd files will be compiled in the
appropriate order.

All the .vhd files will be linked and the
simulator will be invoked.

The Wavebench tool will apen.

A window will open displaying all the I/O
signals of the decode block.

Partial waveform data will appear in the
Wavebench tool.

Fuil waveform data will appear.

Gotr |0

S-:aIE']4

[ne =]
7| B :l’::lﬁllj.

]n\ ‘]‘)J :

{1 LEE ]
© {71 DATE (4 dowmnto 0

4! g l ) .

b'oooc:

e o
¢
.b"OIJOIJO":I: ]:\“.LLLL].":I: Lepugol” ]:-"ll_LLI.“:I: Lonang :

Figure 5. Results from the Decode Simulation

I Exitfrom the Wavebench tool and the simulator,
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L.ab 4

Synthesis with Synplify

Tasks

In this lab, the student will;

I. Synthesize a behavioral VHDL block with Synplicity's Synplify.

2. Perform post-synthesis VHDL simulation withVeriBest's VHDL Simulator.

Svathesizing a VHDL Block

TASK RESULT
|. From the Design Hierarchy view, highlight the ~ The Synplify tool will open displaying
decode.vhd file and right-click your mouse to various pieces of information about the block
select Open in Synthesis. you have selected to synthesize.
2. Maximize the Synplify window.
3. Take a fow minutes to verify that the files listed in the Source section are correct.
What is the name of the Result file and where will it be placed?
4. Click the Change button adjacent to the Target A Set Device Options window will open.
options.
3. Inthe Part puli-down, select the A32100DX This defines the target FFGA device and
device and check the Disable /O Insertion box. prohibits the synthesis tool from inserting /0
macros on the ports of the VHDL block.
If this VHDL file represented the entrire
FPGA, the insertion of /(O macros would be
desirable, bat this is only one block of many
in the design so I/Os are NOT desireable.
6. Verify that vour settings match Figure 6 and The Set Device Options window will close
click OK. and your new options will appear on the

Target line of the Synplity window.



Set Device Oplions

Figure 6. Svnplify's Set Device Options Window

Click the Run button.

Click the View Log button and scroll down in
the log file until you see a line that is highlighted

yellow.

All errors, warnings or notes are highlighted
yellow.  Each highlighted line should be
investigated.

Doubie click on the highlighted Jine.

. Verify that you only have notes. If you have

errors or warnings, call the instructor.

- Select File > Exit 1o quit the Synplify tool.

R N e e nae st

1o

- Torsee i errect of the synthesis. g0 10

DesienNiew ang chek the Vendor Manag:r

Ay vvar e i

The synthesis will start by compiling, then
mapping and will then be done.

A VHDL source editor will open and
highlight the part of the description that
caused the error, Warning, or note.

You will be prompted to save the current
information to decode . pry.

DestnView v, i atematicalls ecog

g I B L Y [

ot rurab VHDL file by running a
progran. wdoedial ol
A Default « ' v Configuration hierarchy

will appear
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14. Verify that decode.edn appears under the Place-

Route Files directory and that decode.vhd
appears under the Synthesis Files directory.

15. Highlight decode.vhd, right-mouse click and A VHDL source editor will open.

select Open . - .
p Notice that 1t is a structural description

comprised of CM8 modules (Actel's basic
building block).

16. Close the VHDL editor and return to the Design

Hierarchy tab in DesignView.

Review: Simulating Structural VHDL

To simulate a structural VHDL block, you can use the same stimulus that you created for behavioral

simulation.
TASK RESULT
1. In DesignView, select the Vendor Managei' The Synplify tool will open displaying
tab. * various pieces of information about the block

I~

6.

that you have selected to synthesize.

Is the decode.vhd file (under Synthesis Files) associated with a stimulus file?”

How can you tell?

Highlight decode.vhd and associate it to the (Hint: decode. wsw > decode _stim.vhd)
same stimulus file that you used for behavioral
simalation.

Again highlight decode.vid and right-click your  The VeriBest VHDL Simulator will open.
mouse to select Open Post-Synthesis
Simulator.

Compile afl the VHDL files (#_;'!} ) and execute
the simulator < ).
Open the WaveBench tool (221 ) and add all the

. IR
I/O signals ( f}l ) to trace

-4 and check your results to
see il they match the behavorial results we saw

Run the simulator

in the last fab.,



7.

8.

When you are finished, exit the simulator.

Under the Simuiation Manager tab, expand the
decode wsw and decode_stim.vhd directories,

20

Notice that two .vpd files exist: decode. vpel
andPostSyn.vpd

These two files are a record of the workspace
settings of the behavioral simulation
(decode.vpd) and the structural. or post-
synthesis simulation (PostSyn.vpd)

‘The next time you stmulate this block, its .vpd
file will be opened and you won't have to
configure the WaveBench tool.
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Completing the DMAC Schematic

Tasks

in this lab. the student will:

I.  Add an existing schematic file to the current project.

2. Add ACTgen blocks and VHDL blocks into a top-level schematic. .

Adding an Existing Schematic to the Current Project

This lab assumes that the Actel DeskTOP is running and that the dmac.pryj is open.

TASK

RESULT

I. Select the Design Hierarchy tab in DesignView.

From the top line menu in DesignView, select
Project > Add to Project > Add Design File

2. Focus the resulting browser on your A: drive.

3. Select dmae.sbk and click Open.

4. Chick Copy

N

right-click vour mouse and select Open from the
resulting pop-up.

From the Design Hierarchy, highlight the dmac file.

A browser will open.

One schematic file will appear: dmac.sbk

A window will appear asking whether the files
should be linked to the project or copied.

The schematic file will be added to the
project.

Notice that DesignView recognizes the lile as
schematic and opens the schematic editor
accordingly.

The schematic editor is called the VeriBest
Design Capture tool. or VBDC.



Completing the Schematic - Adding VHDL Blocks

TASK RESULT

I. Compare page | of your hard copy of the DMAC
schematic to page | of what you see in
DesignView. Notice that the schematic that you
Just added 10 the project is only partially

completed,

2. To add the missing VHDL blocks, click the A blank Place Block window will open.
Block icon .

3. In the Block name field, click the Browser A list of available blocks will appear. Notice that
bULLON e all your VHDL blocks are included in the list.

4. In the resulting list of available blocks, double  The window will close and the CONTROLL
click the CONTROLL biock. block will be attached to YOur cursor,

5. Move the CONTROLL block into position (use
your hard copy schematic as a guide) and lefi-
click your mouse to place it.

Verify that it is truly connected by moving it and
making sure that the wires "rubber band” with it.

6. Repeat this process to add the other two VHDL
blocks: STROBE_GEN and DECODE.

Completing the Schematic - Adding ACTgen Blocks

TASK RESULT

I. In the lower teft-hand corner of the Page 2 of the schematic will open.

schematic. click the number 2 tab

LalaTe D D A2A5T o view page 2 of the

sehemarice,

6. Notice that three ACTgen blocks are A Symbol Menu window will appear.
nissing: MY_RAM, UPCNT and
DWNCNT.

Select the Symbol icon &

7. Double click the VBACTeen entry. A list of the ACTgen macros in this project will
appear.




Double click the MY_RAM entry and place
it in the schematic (use your hard copy as a
guide).

Verify that it is truly connected by moving it
and making sure that the wires "rubber band”

)

il

e

with it.

Double click the MY_RAM block.

as shown in Figure 7.

DWNCNT.

Don't forget to change their instance names.

Save the schematic.

Properties

. In the Properties window, click the Text tab
and change the Instance Name to MY_RAM

. Click OK to close the Properties window.

. Repeat this procedure to place UPCNT and

A Properties window will open.

Initially, ACTgen blocks have generic instance
names (something like XCMP15). To make
timing analysis easier later on, it is a good 1dea to
change the instance name to something
meaningful - like the title of the block.

Fart Hame
Block Mame

upcnt

Mone
i Nkone

Figure 7. Adding a Meaningful Instance Name

| ]
Y]



Verifving the Schematic

Once you have completed and saved the schematic, you must verify it.

TASK RESULT

A File Verify window will open displaying the

I ick the Verify i _ /
Click the Verity icon various checks that will be run on the design.

12

Accept the default checks and click OK The verification will run and any errors or
wamings will be displayed below the schematic.

3. It you have any errors or warnings, double
click them and the erroneous component of
the schematic will be highlighted.

Call the instructor if you have errors you
cannot correct,

Debug and verify until you have 0 errors and
0 warnings.
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Lab 6

Synthesizing and Simulating the DMAC Schematic

Tasks

In this lab, the student will:

I. Force Synplcity's state machine encoding method to sequential.

2. Synthesize the top level DMAC schematic.

3. Add an existing stimulus file to the current project and associate it to DMAC

4. Perform the post-synthesis simulation of the DMAC design.

Synthesizing the Top Level Design

This lab assumes that the Actel DeskTOP is running and that dmac.prj is the open project.

TASK RESULT

i. From the Design Hierarchy view in DesignView, Synplicity's Synphfy tocl will open.
highlight dmac and right-mouse click to select
Open in Svnthesis.

2. From the top-line menu, sefect The VHDL Compiler Configuration window
Options > Configure VHDL Compiler will open.

3. From the Default Enumeration Encoding pull- This will override Synplicity's Symbolic FSM
down. sclect sequential. Compiler and force the encoding method to be

sequential.

Click OK

4. Click the Change button adjacent to the Target The Setup Device Options window will
options display. appear.

5 Select the 32100DX device but DO NOT disable /O Since this is the top level design, we want to
insertion as shown in Figure 8. insert /O macros. Otherwise, the final EDTF
netlist will not import into Actel's Designer.



9.

Set Device Options

Figure 8. Svnplify's Target Set Device Options Window for Top-Level Synthesis

Click OK and click the Run button to begin the The Set Device Options window will close
synthesis. and the synthesis will compliete

When the synthesis is done, click the View Log A log of the synthesis will appear.

button.

There should only be notes and warnings - no errors.
Double click each highlighted entry in the log file to
view the code that caused the note or warning.

Call the instructor if you have errors or warnings
that you don't understand.

Exit from Synplity. It will ask if you want to save the changes to
vour dmac.prj file. 1t is referring to the Target
changes we made (that is. device and 1/O
insertion)

Elect to save the changes. Synplify will close and two new files will
appear under the Vendor Manager tab:

Dmac.vhd - a structural VHDL representation
of the design

Dmac.edn - an EDIF representation of the
design.
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Adding and Associating an Existing Stimulus File to the Current Project

TASK

RESULT

From the top line menu in DesignView, select
Project > Add to Project > Add User Stimulus

Focus the resulting browser on your A: drive.

Select dmac_stim.vhd and click Open.

Click Copy

Click OK

Select the dmac block and click OK

In the Vendor Manager tab, highlight dmac and
right-mouse click to select Associate Stimulus.

Double click the dmac_stim.vhd file.

A browser will open.

One stimulus file will appear: dmac_stim.vhd

A window will appear asking if you want to
copy or link the file.

A window wiil appear stating that you need to
select the block to which the stimulus file
applies.

Another window will appear listing all the
blocks in the current project.

An Associate Stimulus window will open
listing all the stimulus files available for the
dmac design.

A small blue symbol will be added to the
dmac icon in the Design Hierarchy view - this
indicates that the block has an associated
stimulus file.

Simulating the Structural VHDL DMAC Design

TASK

RESULT

From the Vendor Manager tab, highlight
dmac.vhd and right-mouse click to select Open
Post-Synthesis Simulator

Elect to reinitialize the library environment if
asked.

vl
Compile all_!._%i the VHDL files and execute the

ey

simulator =

o Y

Invoke the WaveBench tool
display all the /Os (Hint: Click the Zzlicon).

and setitup to

VeriBest's VHDL Simulator will open.




4. Setthe simulation time to 3500ns and click the ~ The simulation will complete and the partial
> ’ waveforms will be displayed in WaveBench.
Run icon

to see the full

5. Click the Zoom Fit icon
wavetforms.

Verify that they match those shown on your hard
copy.

Congratulations! You are now ready to take your fully verified EDIF netlist into Actel's Designer
for place and route!
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Lab 7

Importing and Compiling an EDIF Netlist

Tasks

In this lab, the student will import and compile an EDIF netlist in Actel's Designer software.

Creating a Designer Database

This lab assumes that the Actel DeskTOP is running and that dmac.prj is the open preject.

TASK

RESULT

[

From the Vendor Manager tab in DesignView, go
to the Place-Route Files directory and highlight the

dmac.edn entry.

Right-mouse click to select Open in Place and

Route.

The EDIF netlist should import without error. Call

the instructor if you get errors.

From the Designer flow chart, click Compile.

Make the following selections:

Device = A32100DX
Packuge = 84 PLCC
Speed Grude = STD

Click Next.

In the Pin Restrictions section, check both Reserve
JTAG Pins and Reserve Probe Pins {(we will

discuss these later),

A

Actel's Designer software will be invoked and
the dmac.edn netlist will automatically be
imported.

In addition. a database file called dmac.adb
will be created and added to the project.

The Compile routine will begin and you will
be prompted to enter a device, package, and
speed grade.

A Device Variations window will open,.
prompting for voltage and special pin
reservations.



Click Next

Inthe Operating Conditions dialog box, click
Finish to accept the defaults.

Verify that you have no errors.

Save the database and exit from the Designer.

&

An Operating Conditions window wil] open,

Notice that if the Range is specified as either
commercial or industrial, the Temperature and
Voltage values are preset.

Custom temperatures and voitages can be
specified by setting Range to Custom.

The Compiler will begin to run.

When the compile is complete, the Compile
tcon will be highlighted. The status area wilj
display any error or warning messages.,
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Lab 8

Making Pin Assignments with Pin Edit

Tasks

In this lab, the student will:

1. invoke the Pin Edit tool.

2. make single pin assignments and group pin assignments.

3. save pin assignments.

4. generate a pin report.

Making Pin Assignments

TASK

RESULT

.

From the Vendor Manager tab in DesignView,
highlight the dmac.adb file and right-click to select
Open.

Click Pin Edit from the Designer’s flow chart.

Use the View > Zoom Area command to zoom in on
the lower lett corner of the package pinout diagram.

Click on addr{0) from the Unplaced list and drag it
over to pin 30

Use the sume procedure to make the following
assignments:

addr(1) > pin 31
addr(2) > pin 32

Scroll up to the upper left corner of the package
pinout.

The Designer will be invoked and the
dmac.adb database will open.

The Pin Edit tool will open displaying a
package pinout diagram for the 32100DX and
a list of unplaced I/O nets.

addr(0) will disappear from the Unpluced list
and appear on the Placed list. Also. pin 30
will fill in, showing addr(0) adjacent to it



From the Unplaced list, scroll down and click
wen_cntl(0). Hold down the Shift key and click
wen_cntl(1), wen_cntl(2), wen_cntl(3), and
wen_cntl(4)

From the top menu, select Edit > Place.

In the pinout diagram, click on pin 13,

- In the pinout diagram. click on pins 14, 15, 16 and 17

(in that ordery,

. Zoom in on the top, left corner and scroll around

until you see the PRB pin (pin 4). Try to place the
en(l) net on this pin.

. Drag en(1) trom the Placed list to the Unplaced list.

- Try to assign rd_clk to pin 3.

Why doesn’( this work?

- From the muain menu, select Options > Configure

List Boxes

- Inthe Name ticld. type re*,

Click OK.

- Make the following assignments:

req(l) > pin 24
req(2) > pin 25
req{3) > pin 26

- Select File »> Commit to commit your pin

ASSTERMIC N

All five net names should be highlighted.

This selection is necessary whenever you are
assigning a group of nets.

Since wen_cntl(0) was the the first net
selected, it will be assigned to pin 13.

The following assignments should appear:
wen_cntl(1) > pin 14
wen_cntl(2) > pin 15
wen_cntl(3) > pin 16
wen_cntl(4) > pin 17

It will accept your assignment, but you will
receive a warning:

pin is also used by probes

The PRB pin is used by probe circuitry of the
Silicon Explorer.

en(1) will be unplaced.
You will receive an error:

location incompatible with type
of macro
A Configure Listhoxes dialog box will appear,

The Unplaced list will be tiltered to only
display I/O nets that start with re.
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. Select File > Close to close Pin Edit.
. Save the database.

. From the Designer’s main menu, select Reports >

Pin.

. From the List By pull-down, select Number.

Click OK.

. From the Pin Report menu, select File > Save.

In what directory is the pin report going to be saved?

23. In the File name field, enter dmac.prp and click OK.

24. Close the Pin Report window.

A dialog will open allowing you to specify
how the pin assignment report is sorted.

The pin assignment report will open and be
displayed.

A Save As window will open.




Analyzing Pre-Layout Timing

Tasks

In this lab, the student wili:

Lab 9

I. generate a pre-layout timing report and determine whether or not timing constraints are necessary.

2. use the DirectTime Analyzer to perform a detailed timing investigation.

Generating Timing Reports

TASK

RESULT

I. Verify that the dmac.adb database is still open.

~a

From the Designer’s main menu, select Reports >
Timing.

3. Be sure to select Pre-layout.

It you select Post-layout, the layout will
automatically rn first.

4. Sort by Actual.
In the Maximum Paths tield, enter 10,
Click OK.

5. Review the information in the report. If you have
any guestions about what you see, ask the instructor
to explain,

0. Go down 1o the section titled:
Register ird_clk_1 _net) to Register (rd_clk_1_net)

Based on this delay. what is the maximum
operating frequency for this design?
7. In the Timing Report window, select File > Save.

Name the file std.erp.

8. Sclect File » Close Window to exit the Timing
Report,

A Warning box will appear prompting you to
select pre or post layout.

A Timing Report window will open.

A Timing Report will open, displaying the
set-to- set measurements discussed in cliss.

This will save the report to an ASCII file

which may be useful for future comparisons.
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Using DT Analyzer

TASK

RESULT

[

From the Designer’s flow chart, click the DT
Analyze icon and again select Pre-layout.

The Filters window will open as shown in
Figure 9. You will use this window to filter
the data reported by the DT Analyze tool.

Figure 9. The DT Analvze Filters Window

On the Source side, click the Register box.
Select wrt_clk_1_net from the adjacent pull- down.

On the Sink side. click the Register button and
select wrt_clk_1_net from the adjacent pull-down.

Leave all the other buttons at their default setting.

Click the Preferences button.

This will set-up the DT Analyze tool to
display only the register-to-register delays tor
registers driven by wrt_clk

The Preferences window will open similar to
the one shown in Figure 10.



6.

Preferences

Figure 10. The DT Analyze Preferences Window

In the Preferences window enter:

10 for Longest/Shortest Paths
5 for Expanded Paths

Leave all the other settings at their default
value and click OK.

In the Filters window, click QK.

From DesignView, open the dmac
schematic. Use the Start and End points
shown in the DT Analyzer results to trace
the paths on the schematic.

[f vou have any questions about your results,
call the instructor over.

In the DT Analyzer window, select Options
> Filters.

Thus time set the Source side to Register -
rd clk_1_net and the Sink side to Register-
rd_clk 1 net.

Chek OK.

The DT Analyze tool will list the specified
register to register delays.

The Filters window will open again,

The DT Analyze tool will list the specified
register o register delays similar to those
shown in Figure 11.

NOTE: Your delays may vary from those
shown,
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. DuectTime Analyzer

S A

b ]

Start

End

dwnent_1_DFMBA_Q_3_inst:

CLK

cantrolll _cs_1_5:DC

CLK

controlll_cs_i_5:DZ

1
?ldwncent 1 DFMBA_Q 3_inst:
Aldwnent_1_DFM6A_Q 3_1inst:

CLE

controlll_ecs_i_5:D3

dwnent_1_DFMBA_Q 3_inst:

CLR

contrelli es_1i_5:D0O

dwncent_1_DFMBA_Q 3_inst:

CLR

controlll es_1i_5:DZ2

CLR

contralll_cs_i_5:D3

controlll cs_1:CLK

upcnt_1_DFM6A_Q_6_inst:

4
5
fldwnont 1_DFMBA_Q_3_1inst:
7
5]

controlll_cs_1:CLK

upcnt_1_DFMBA_Q_4_inst:

9lcontrolll_cs_1:CLK

upcnt_1 _DFM7A_Q_7_inst:

10lcontrolll_cs_1:CLR

upcnt_1_DFMEA Q_6_1inst:

11l|lcontrolll_gs_1:CLK

upcnt_1 DFM7A_Q_5_inst:

LA OTT

Vet ek a1 “
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Fieure 1. The DT Analyzer Results for rd_ctk Register 10 Register Delavs

9. From the DT Analyze results, click on the first
dwnent_1 entry so it highlights.

From the mamn menu, select Expand > Chart.

An Expand Chart window will open as shown
in Figure 12. This window has two areas:

A graphical display showing ALL paths from
the endpoint in question to a various
startpoints.

A tabular display with an expanded listing of
each path.

NOTE: Your data may vary slightly from that
shown.
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1st Path Net Macro |D Typ|Total
controlll_es_1_5:DO N_97_n DFM7A Tsul 29.8
G_36_n:300 tc CM8 5.3(r)|{Tpd| 29.3
dwncnt_1_NOR4A4 Tent :B dwnent 1_or3_0_y|NOR4A 5.5(f)[Tpd| 24.0
dwnent_1_OR3_(0:B down_core 3 OR3 6.0(r)|Tpd| 18.5
dwnent_1_DFM6A_0_3 inst:CLK rd_clk_y DFMea | 12.3 (r)|Tpd| 12.5
SKEW 1 rd_clk_y SKEW 1 0.2 Psk g.z

End Pin: controll1_cs i ¢

Figure 12. The Expand Chart Display for the Ist Path

10. Read through the DT Anailyze expansion
from bottom to top and follow the signal
through DWNCNT and CONTROLL.

If you have any questions about reading this
expansion dask the instructor.

1 In the tabular display headings, click the text:

Ist Path,

What happens?
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12. In the tabular display headings, click the text: 2nd
Path (you may need to scroll to the right to find it).

What happens?

13. Back in the DT Analyzer window, select File >

Close

t6



Lab 10

Applying Constraints with DT Edit

Tasks

It this lab, the student will:

invoke DT Edit.

I~

use the Clock Constraints Editor to apply clock constraints and designate clock exceptions.

3. use the Path Constraints Editor to apply timing constraints on individual paths and the clock exception
paths.

4. practice exporting and importing timing constraint files.
5. generate “slack™ reports.

0. change the speed grade.

Setting Clock Constraints

TASK RESULT

I Ifitis not still open, invoke the Designer and
open the dmac.adb database.

2. Click the DT Edit icon, After a few seconds, the DirectTime Edit
window will open. displaving the Clock
Constraints editor.

3. Display the pull-down menu under Global Signal.

What signals do you see and why are they listed?

4. From the list. select rd_clk_1_net and enter a This sets a constraint of 33ns on the register-
pertod of 33ns and a 50% duty cycle. to- register delay for all sequential elements
driven by rd_clk.
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Setting Constraints on Other Paths

TASK RESULT

I. In the Path Constraints area of the DT Edit A blank Path Constraints Editor will open.
window, click the New button.

2. In the lower left hand corner, designate Inpad as
the source.

In the fower right hand side, designate Register as
the sink.

3 1In the filter box on the Source side, set the filter to  Only the source pins that start with “R” will
R* and hit retum be displayed as shown in Figure 13.

Path Constiaint Editor - constraint DELO.

[r
controlll i _5:30 -
controlll_es_1_5:511

R ontrolll lreg line O:5

controlll_lreg line_0:3511
: zontrolll_lreq line_1:50

Figure 13. The Path Constraint Editor
4. Use the Shift key to select the req<l>, req<2> All three pins should be highlighted as shown

and req<3= pins. in Figure 13.

When a source net is selected. all its register r
endpoints witl appear in the Sink list.



5. From the Sink list, click the SA button (Select This will highlight all the end points. At this
All). point, you have selected the on-chip delays
for the req inputs.

6. In the Delay field at the top, type 25. You have now specified that the on-chip delay

for the req signals be 25ns or less.
Click OK.

The Path Constraint Editor will close and you
will see your path constraint listed in the Path
Constraints area of the DT Editor window.,

Notice also that next to the title Path
Constraints there is now a 1 of | count
displayed.

When this constraint is displayed, you can use
the Edit or Delete buttons to change or
remove it.

7. Use this same procedure to set a 20ns constraint
on the on-chip delay from all the addr inputs to
their subsequent register inputs.

8. From the main menu of the DT Edit window,
select File > Commit and then File > Close.

9. Save the database.

Exporting and Importing a Delay Constraints File

The Designer allows you to export your delay constraints to a file so you can investigate more than one set of
constraints without overwriting your old ones. In this section, you will practice exporting and importing your
delay constraints file,

TASK RESULT

I, Fromthe Designer's main menu, select An Export dialog box will open.
File > Export.

=]

In the File Type pull-down, select Aucxiliary File.
3. In the File Name field, type dmac_1.dcf

In the Parameters area, make sure that the Type is
Delay Constraints.

19
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Click OK.

To practice importing, go to the Designer’s main
menu and select
File > Emport > Auxiliary File

Verity that the File Type is Delay Constraint
and use the Browse button to find and select the
file name dmac_1.dcf

Click OK

Save the database.

This will save your current delay constraints
to a file so that it can be imported later.

Using this feature, you can set up multiple
constraint scenarios and easily switch from
one to another.

An Import dialog box will open.

Assuming this was a different file, it would
overwrite any constraints that were currently
in the database.

Generating Slack Reports and Changing the Speed Grade

TASK

RESULT

1~

6.

In the Designer's main menu, select
Reports > Timing and specify Pre-layout

in the Timing Report dialog box, set Sort By to
Slack.

Notice that the Slack Threshold is 0.0. If we are
meeting atl our timing constraints, what will this
slack report look like?

Click OK

Close the report and go back to the Designer.
From its main menu, select Options > Device
Setup Wizard.

In the top of the Operating Conditions dialog box,
set the Speed Grade to -1.

Regenerate vour slack timing report.

Do the prelayout timing estimates meet the
constraints?

Save the database.

-2
=

The Timing Report dialog box will open.

A timing report will appear displaying all the
negative slack values (if any exist).



Lab 11

Laying Out DMAC

Tasks

In this [ab. the student will:

l.
2.
3.
4.

pertorm a Standard Mode layout.
use Timing Reports to view any post-layout timing failures.
perform a DirectTime Mode layout.

change the DMAC schematic slightly and perform an Incremental layout.

Performing a Standard Mode Layout

TASK RESULT
I, Fromthe Designer’s flow chart, click the A dialog box will open, prompting you to
Layout icon. select the mode of layout.
2. Select Standard and verify that Incremental The layout will begin. It will report an
is OFF. estimate of the time required to complete the
. layout.
Click OK,

3. What length of time is estimated for Standard
Made lavour?

Generate a iming report. Were the timing requirements met”

Performing « DirectTime Mode Layout

TASK RESULT
I. From the Designer’s flow chart, click the A dialog box will open, prompting you to
Layout icon. select the mode of layout.
2. Setect DirectTime and verify that The layout wilt begin. It will report an
Incremental is OFF. estimate of the time required to complete the
layout.

Chick OK.
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3. Which layout took longer?

Were the timing requirements met?

If not, change the speed grade.

4. Save the database and exit the Designer.

Changing the DMAC Schematic and Running Incremental Layout

TASK RESULT

6.

In the Design Hierarchy tab of
DesignView, open the dmac schematic and
go to page 2.

Use the Bus icon J%%f to add a bus and
hierarchical output connector to the Q[7:0]
output of the DWNCNT block as shown in
Figure 14.

Be sure to name the hierarchical connector
pin as down[7:0] as shown.

nClacks o
lsiead sl e
lacle 'ZZiZZﬁLZZiIQZ*Z‘_Iij;ﬁi
S T [ SO LN gy
—JFnahle . Do "'iiIIZaI‘II.‘TId]I‘ /
_ WAl T0) e
T ey pr————
=DatalThy it
“—m'r—““

Figure 14. Additional OUTBUFS block for DMAC.2

Save the schematic and verify it € )

Close the schematic.

From the Design Hierarchy tab, re- Hint (Highlight and right-click to select Open
synthesize dmac. in Synthesis)

FExit from the Svnplify.

o)



7.

9.

From the Vendor Manager tab,
highlight dmac.adb and right-mouse
click to select Open.

What do you notice about the flow
chart?

Click Layout and make the following
setings:

Mode - Standard
Incremental - FIX

Before the layout is begun, notice that

the database automatically recompiles.

[ ]
L

The Designer will be invoked and the
dmac.adb database will open,

The Designer recognizes that the EDIF netlist
has been updated. Because of this, your
compile and layout steps are invalidated and
will no longer be highlighted green,
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Lab 12

VeriBest Backannotated Simulation

Tasks

In this lab, the student will:

I.
2.

Extract the actua! timing delays for a given set of operating conditions.

Use the extracted delay information to perform a post-layout simulation

Extracting and Exporting Timing Delays

TASK RESULT

1.

From the Designer’s flow chart, click Extract. The Extract window will open as shown in
Figure 15.

The Status area of this window displays the
operating conditions for which the delays will
be extracted. To extract a different set of
conditions, change the conditions first with
the Options > Device Setup Wizard menu.

‘Extracted File Directony:
] C\actproji\dmac\Default\place_and_

Figure 15. The Extract Window

[
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2.

Verity that the CAE pull-down is set to The delays will be extracted and exported to a
VERIBEST. file.

Click OK.

What is the name of the extracted delay file and where is it placed?

Save the database.
Exit from the Designer.

[ the Vendor Manager tab of DesignView, look You should see a new dmac.sdf file.
under the Place-Route Files directory.

Using the dmac.sdf File to Perform Post-Lavout Simulation

To perform post-layout simulation, you must work with the dmac.vhd file that resides in the Place-Route
Files directory of the Vendor Manager tab listing.

TASK RESULT

[

ad

Before we can simulate a .vhd file, we must
associate stimulus,

From the Vendor Manager tab in DesignView, go
to the Place-Route Files directory, highlight
dmac.vhd and associate it to the same
dmac_stim.vhid stimulus file that we used for
previous simulations,

Once a stimulus tile has been associated. highlight  This stmulator will open as we have seen
dmac.vhd again and right click your mouse to before.
select Open Post-Layout Simulator.

Perform a 2600ns simulation and display the Hint: Compile all modules
wiveforms tor all FOs. Execute the simulator
Open WaveBench and add the [/Os
Set the simulation time to 2000ns.
Click the Run button.

You will receive several assertion warnings of the form:

Assertion [WARNING] in . . .

VitalGlitch: GLITCH Detected on port ¥ ; Preempted Future Value :
0 @ B64.5 ns; Newly Scheduled Value := 1 @ 866.2 ns;

These gliteh warnings are normal. You can ignore them.

26



4. Verify that your results match the pre-layout
-t simulation results shown on your hard copy.

5. Exit from the simulator.

Notice in the Vendor Manager tab, that a new file has been added to the Place-Route Files
. directory: PostRoute.vpd

What is the purpose of this file?

iz
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Lab 13

Using Activators to Program an Actel FPGA

Tasks

[n this lab, the student will:

I. Specify a silicon signature for an Actel FPGA design.

2. Invoke the Windows Programming software and open an existing database.
3. Perform a blank check on a 32100DX chip provided by the instructor.

4. Program the 32100DX without security.

Creating the Fuse File and Silicon Signature

TASK RESULT
I. Open the dmac.adb database.

2. In the Designer flow chart, click Fuse. The Export dtalog box will open as shown in
Figure {6

Figure 16. The Exporr Dialog Box

XK
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3. All the defaults should be correct,
except that we want to enter a silicon
sigznature,

In the Silicon Signature field, enter
some 5 digit hexidecimal.

Click OK.

4. Save your design database, then exit
from the Designer.

5. In the Vendor Manger tab of
DesignView, notice that a new
dimac.afm file has been added to the
Place-Route Files directory.

Programming an FPGA

This is the file that will be opened to start the
programmer,

TASK

RESULT

Get a 32100DX FPGA from the instructor.

Line it up properly and latch it into your
Activator 2 or 25,

From the Vendor Manager tab's Place-Route
Files directory. highlight dmac.afm and right
mouse click to select Open.

After the database has opened. click the
Blankcheck button,

I your chip is not blank, see the instructor.
Click the Activate button.

Verify that onty Array Fuses are set to be
programined.

Click OK.

When programming has completed, again
perform a Blankcheck.

Does the stlicon signature match the value you

set when yvou ran FUSE?

The Windows APS window will appear.

The inserted chip will be scanned to
determine whether or not it has been
programmed.

Device programming will begin.

Congratulations! You just programmed an Actel FPGA!



Lab 14

Running Actel’s Debugger - INCOMPLETE!!!

Tasks

In this lab. the student will:

I. invoke Actel’s Debugger.

2. run Debugger commands interactively.

3. toad and run a provided Debugger command file.

4. create and run their own Debugger command file.

Invoking the Debugger

NOTE: The Debugger can only be run on a programmed chip which is clamped in the Activator.

TASK RESULT

[. It it is not already running, invoke the Windows
Programnnng tool by selecting and opening the

dimac . al'm rile.

2. From the Windows APS main menu, click the The Debugger will be initialized.
Debugger burion.

Running « Debug Session

TASK RESULT
I In the Command fieid at the top of the Windows ~ The initial.deb file will load and run. You wil]
APS window, type loadfile “initial.deb” ses the foliowing message:

e e S IERINT NI BY P2INTING
Look at your hard cony of the infrial 2L 7o FTRENE VO BY PENTING

muke sure you understans a6 e coonn 25
you have any questions. cali the fns.ogote, ADATA=Z777

sl
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Now that the required vectors and macrds (CYCLEMAIN and CYCLE) have been
loaded. you will use interactive commands to test the serial to parallel shift function.

[n the Command field, enter each of the debugger commands shown below.
Remember that each time you CYCLE, the signals in the TABLIST will be printed.

emit “TESTING S2P REGISTERWn”

tablist reset srst -

emit “RESET CIRCUIT\n"

L reset

asstgn Ob1 111 ctl

cycle

H reset

cycle

tablist serial p ydata

emit "CYCLING 1s ON SERIAL INPUT\n"
H serial

repeat 6 (cycle)

At the end of this series of commands, you should see that YDATA = 1111

In the Command field, load the
adder.deh tile,

Look at vour hard copy of the adder.deb
file and mmake sure you understand all
the commands. If you have any
questions about the results, call the
gmstructor,

Load and run the upentr.deb file.

Look at vour hard copy of the
upentr.deb file and make sure you
understand all the commands. If you
have any questions about the results,
call the instructor.

Use the Windows Explorer to copy the
upentr.deb to a file named

dovwnentinodebh.

Modity dovnenirdeb so that it tests the

3



down counter (you may find the ACE
truth table in your schematic handout to
be useful).

Load and run your new file in the
Debugger until it works successfully,
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Debugger Command Files

INITIAL.DEB

(vector ctl ctl3 ¢ctl2 ¢t ¢tl0)

(vector adata adata3 adata2 adatal adata0O)

(vector bdata bdata3 bdata2 bdatal bdata0)

(vector p p3 p2 pl pO}

{vector up up3 up2 upl upQ)

(vector down down3 down2 down down0)

(vector ydata ydata3 ydata2 ydatal ydataQ)

(define (cyclemain) (L sysclk) (step) (H sysclk) (step) (print) (emit “An”’))
(define (cycle) (L cticlk) (step) (H cticlk) (step} (cyclemain))
(emit “TEST THE PRINTING BY PRINTING ADATAW")
(tablist adata)

{print)

S2P.DEB

(emit "TESTING THE SERIAL TO PARALLEL SHIFT\n™)
(tablist reset)

(emit "RESET THE CIRCUIT\"™)

(L reset)

(assign Obt i cth

(cyele)

(H reset)

(cycle)

(tablist serial p vdata)

(emit *“CYCLING IN 1s ON THE SERIAL LINEwW”)
(H serial)

{repeat G icvelen

(emitU'DONE (YDATA should equal 11117n")



ADDER.DEB

(emit “TESTING THE ADDERW”)

(tablist reset)

{emit “RESET THE CIRCUIT\n™)

(L reset serial)

(assign 0b0O0OO adata)
(ass1gn 0b000O bdata)
{assign 0ObOOT 1 ctl)
(cycle)

(H reset)

{cvcle)

(tablist adata bdata ydata co)
(emit “"ADD | + [\n™)
(assign 0b000| adata)
{assign Ob000] bdata)
(repeat 3 {cycle)s

(emit "TADD 1 + 15\n™)
(asstgn Ob1 1] adata)
(repeat 3 (cyele))

{femit”DONEW™)

e
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UPCNTR.DEB

(emit “TESTING THE UP COUNTERW™)
{tablist reset)

(emit "RESET THE CIRCUIT\n")

(L reset serial)

(assign 0b000O adata)

(assign 0b00OO bdata)

{assign ObO111 ¢l

(cycle)

{H reset)

{cycle)

(tablist bdata up ydata)

(emit “SET BDATA TO 8wn™)

(assign Ob1000 bdata)

(repeat 2 (cycle))

(emit “DISABLE LOAD AND COUNT UP TO 11\n™)
{Lctlh)

{repeat 4 (cycle))

femit "DONEW



=———————=Chapter 1

Software Overview
and Design Flow

DeskTOP 2.0 - Sept 99 1.1

Objectives
After completing this chapter, you will be able to:
* List the three vendors that are combined in the Actel DeskTOP

* Explain how to obtain, install, license and get technical support for
the DeskTOP software.

* Briefly describe the example design that will be used in class.

* Describe the purpose of VeriBest's DesignView software and
explain
the four different DesignView tabs.

1-1




s DeskTOP Tools

VeriBest Synplicity Actel
DesignView Synplify ACTgen ' Designer
« Design management « Synthesis « Macro builder * Place & route
« Design capture . : :
« Simulation

1 d

Silicon Explorer

*Programming . = Dehugger

E i DeskTOP 2.0 - Sept 99 1-2

Notes

The Actel DeskTOP is an FPGA design environment that tightly
integrates the tools from three vendors: VeriBest, Synplicity and Actel.

The DeskTOP interface and design management is handied by VeriBest's
DesignView tool. Through this tool, you can capture the design in many
forms including schematic, VHDL, Verilog, state diagrams, flowcharts,
truth tables and ACTgen blocks. Besides design capture and
management, VeriBest also provides their VHDL simulator which can
pertorm behavioral, structural and post-place & route simulations.

HDL synthesis is handled by Synplicity’s Synplify tool. After synthesis,
which creates an EDIF file, VeriBest automatically performs an EDIF-to-
VHDL translation to facilitate post-synthesis simuiation.

All the FPGA definition and layout is handled by Actel’s Designer. Once
the design has been successfully placed and routed, the Designer can
export a delay file that can be used to perform post-place&route
simulation.

Programming and debugging is also provided by Actel tools.

1-2




Obtaining & Installing

B DeskTOP CD is free - order from the web
— www.acteldesktop.com

B Don’t forget to install the right Actel library.

Sefec

ACTgen Macro Builder o 802 K -

APS ' 266RE K

Silicon Expert [Beta) 24004 K
{1 Verilog Libraries

Vit gl Lib e -

e M A R O o AR e Sdmei i P

B VeriBest and Synplicity tools can be installed and
upgraded independently

DeskTOP 2.0 - Sept 59 1-3
Notes
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1 d:

i

e

Licensing and Support

W License is required
— order via email
- reference must be added to autoexec.bat file or Systems window:

SET LM_LICENSE_FILE=C:\lexIm\license.dat

m Support is only available if you purchase maintenance
— $995 for one year.

DeskTOP 2.0 - Sept 99 1.4

Notes
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Design Flow:
Schematic Only

Capture & Management
v

Simulation Generate EDIF

ﬂ ”

Place & Route
S

-
[

ree

:

Post-P&R Simulation Programming

2 N1

g‘ EZ DeskTOP 2.0 - Sept 99 1-5

Notes

Schematic-only designs can still be simulated with the VeriBest VHDL
Simulator. Upon invoking the simulator, VeriBest automatically
translates the schematic netlist into a structural VHDL format.

When you are ready to move on to place & route, you will have to
manually generate the EDIF netlist in DesignView.,

1-5
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A

Design Flow:
Mixed Schematic-HDL

Capture & Management

Simulation

ﬂ

Synthesis

™ —P
—~—

Post-Synthesis Simulation

—

Place & Route

L

A

Post-P&R Simulation

Programming

DaskTOP 2.0 - Sapt 98

Notes

Notice that the presence of and VHDL blocks (including those generated
by ACTgen) adds two new steps to the recommended design flow:

« Synthesis

* Post-Synthesis Simulation

The result of synthesis with Synplify is an EDIF netlist so the Generate
EDIF step is inherent and does not need to be run manually.
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— ~—Design Example

DATA([7:0]
ADDR[2:0]
WEN_CNTL{4:0]
RCLK
WCLK
ic
REQ1 L
REQ2
REQ3
EN_FIFO1
EN_FIFQ2
tc EN_FIFO3
—————— DaskTOP 2.0 - Sapt 99 1.7

Notes

The functional block diagram of the DMAC design example is shown
above,

The purpose of DMAC is to control the filling of three external FIFQs.
Which FIFO is enabled depends on which one is requested (see the
REQI. REQ2, and REQ 3 signals).

The starting address for the appropriate FIFO 1s read from MY_RAM and
15 then incremented by the ADDR_OUT;7:0] output of UPCNT. The data
{which also comes from some external source) is shifted in until the TC
signal from DWNCNT is asserted.

Therefore, the data contained in MY _RAM are pairs of starting addresses
and shift lengths.

The CONTROLL block is a state machine that selects the appropriate
pair from MY_RAM based on the request signals (REQL, 2, and 3). The
CONTROLL block also loads the counters and enables both the counters
and external FIFQOs.

See your schematic handout for a detailed diagram of DMAC and all its
hierarchical blocks.

1-7
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It all starts with VeriBest
DesignView . . .

B Project Creation

Project directory
VHDL version (87 or 93) } Must specify

Actel family

Custom settings
« custom libraries
+ default schematic borders
* colors, etc.

M Project Management
— Putting the right file in the right location

Optional

= .l

DeskTOP 2.0 - Sept 99 1-8

Notes

The first step (after installation and licensing), is to create a VeriBest
project. VeriBest makes this easy with a step-by-step user interface that
prompts you for the information above. The new project is saved to a file
with a .prj extension.

Once the project is created, you can open it and select Project > Settings
to make further customizations.
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DesignView Tabs

B Design Hierarchy
B Simulation Manager
B Vendor Manager

H File Manager

%‘ E__l DeskTOP 2.0 - Sept 99 1.9

Notes

There are four tabs in the DesignView Window. The next 4 slides will
explain how the project data is arranged in each tab.

1-9




i 4

|

cwd

j—

=} Default Configuration
- 5] dmac
my_ram
dwnecnt
upcnt

strobe
controll

P

s 5 : ; ; 7‘
DeskTOP 2.0 - Sept 99 1-10

Design Hierarchy Tab

Dispiays hierarchical
decode  “G—— relationship of all blocks in

the project

Notes

The Design Hierarchy tab lists all the blocks in the project, arranged by
hierarchy. From the listing above, you can see that the dmac schematic
includes 6 lower-level blocks: my_ram, dwncnt, upcnt, decode, strobe

and controll.

Notice that the tcon for each block indicates its type:

is a VHDL block

There are also icons for state diagram blocks, flowcharts and truth tables.

== iy a schematic block

E is an ACTgen block (that is, created by Actel’s ACTgen)



Simulation Manqger Tab

™ dmac - Vevési Dés&mVu:wI [Pm|‘ W acel

#3 \VB Project Simulation E nvirorment
= dh dmac. wsw

& bdm;c_stim-vhd €———Displays stimulus files available
¥ o o : :
S B for each design block
* ‘ stiobe. wsw
*: ‘ decode. wsw
- ‘. upcnt. wsw
dmac_s_hm1.vhd

g‘ gz DaskTOP 2.0 - Sept 99 1-11

Notes

The Simulation Manager tab displays all the stimulus files that belong
to the project. Each stimulus file is displayed “under” the .wsw directory
tor its corresponding block.

For example, the DMAC block has a stimulus directory called dmac.wsw.
Within that directory is a stimulus file called dmac_stim.vhd
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Vendor Managerf Tab

gn¥iew  [Project Workspace]

= W5 Synthesis Files
decode.vhd
contiok.vhd . .
wobevhd d==Displays files generated by

e other vendors (like Synplicity

4= &P Place-Route Files and ACtEI)
&P decode.adb

&P dmac.adb

fi‘a dmacpm

@ dmac.pib

DeskTOP 2.0 - Sept 99 1-12

Notes

The Vendor Manager tab displays all the files generated by or for other
vendors. In the case of the Actel DeskTOP, the other vendors are
Synplicity and Actel.

When synthesizing with Synplify, two files are generated: an EDIF file
and a structural VHDL file. The VHDL file is place in the Synthesis
Files directory and can be used to perform post-synthesis simulation.
Since the EDIF file is used by Actel, it is placed the Place-Route Files
directory.

In addition, all files generated by Actel are placed in the Place-Route
Files directory.




File Manager Tab

™ dinac - Veni-iesl Demgn‘-’mw - iPm;m:l \-'-J.(.ul-.sp..l.r.e]

5}1 h:’r::‘t:iig:es “4—Displays all the project files

dmac.vhd according to their type
‘&3] State Diagram Files
48) Fiow Chart Files
| Truth T able Files

¥ (8] VHDL Files
B Verilog Files
'+, o] Block Symbol Files

DeskTOP 2.0 - Sept 99

Notes

As shown above, the File Manager tab organizes the project files based
on their type. It is important to keep in mind that this is NOT the way the
tiles are arranged on your hard disk. This is not a Windows File
Manager,

The project files arrangement on your hard disk is shown on the next
page.
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1

Organization of Project Files on
Your Hard Drive

=8 - dmac
E! - Default
E-{Z3 Default.cdb
& - genhdl
{23 log
-3 place_and_route
LE simulator_buiid
. {23 synthesis
& design_definition
- &1-{35 actgen
(23 graphics
n . hdl

61-37 stimulus

DeskTOP 2.0 - Sopt 99

Notes

The slide above shows how a project’s files are organized on your hard
drive. Most of the directory names are self-explanatory with the
exception of graphies which contains all the schematics. Schematics
have an .shk extension for “schematic block™.

It is SERIOUSLY SUGGESTED that you never manipulate, edit, move,
copy. elc. any of your project files using any tool other than DesignView.

1-14



== Introduction to Lab

B Complete the Lab Setup
— Create a new project

g‘ El DeskTOP 2.0 - Sapt 99 115
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Chapter 2

Block Generation with
ACTgen and VHDL

Capture & Management

Simulation Synthesis Post-Synthesis Simulation
g M o [ e '
s
Place & Route
e,
“ads
Post-P&R Simulation i
ﬁ ] Progrgmmg

DeskTOP 2.0 - Sept 99

Objectives
At the end of this chapter, you will be able to:
» Describe the purpose of ACTgen.
*» Invoke ACTgen.
» List the types of macros that ACTgen can generate.

+ List the different output formats of ACTgen and describe
circumstances for using each one.

« Create new VHDL blocks in a project.
» Add existing VHDL blocks to a project.
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Chapter 1

Software Overview
and Design Flow

——————— DeskTOP 2.0 - Sept 99 1-1

Objectives
After completing this chapter, you will be able to:
« List the three vendors that are combined in the Actel DeskTOP

» Explain how to obtain, install, license and get technical support for
the DeskTOP software.

« Briefly describe the example design that will be used in class.

« Describe the purpose of VeriBest's DesignView software und
cxplain
the four different DesignView tabs.

1-1
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Chapter 2

Block Generation with
ACTgen and VHDL

Capture & Management
-

Simulation Synthesis Post-Synthesis Simulation

% S [ g2
+ ]

Place & Route
L,
le'/

v

POSt-P&H Simufation Programming
=

=
ed 2

DeskTOP 2.0 - Sept 99

Objectives
Al the end of this chapter, you will be able to:
* Describe the purpose of ACTgen.
* Invoke ACTgen.
* List the types of macros that ACTgen can generate.

* List the different output formats of ACTgen and describe
cireumstances for using each one.

* Create new VHDL blocks in a project.
* Add existing VHDL blocks to a project.




s it

RIS TSGR 13 0o

Fill-in-the-blank
description for:

+« Counter
« Adder
* Subtractor

* Accumulator —p

* Register

* Comparator
* /O Blocks

* Logic Blocks
* Decoder

* Multiplexor

« RAMS

ACTgen Overview

* FIFOS

ACTgen

—>| ADL Nems-]
__...’I EDIF Neﬂile

Structural
p| and Behaviorai
Verilog Netlist

Structural
| and Behavioral
VHDL Netlist

DeskTOP 2.0 - Sept 93

Viewlogic WIR File
and Symbol




— The ACTgen User Interface

CALTaen Macto Builder '"'

Select the family ————»

—

Seiect the
macro type

DeskTOP 2.0 - Sept 99

Notes
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L

Wy

4. Click Generate

button

ycrlsy

For Example: A Counter

AL Tarm Mot 1

1. Select variation

Compact

Ripple

Balanced

Fast Enable

Register Look-Ahead
Pre-Scaled

2. Enter width

3. Complete the
rest of the
description

DaskTOP 2.0 - Sept 99 2.4

Notes




Component Generation

aetate Macin

Select the
output format —>

“+— Specify the target
directory and
macro name

upcnt VHDL Files
upcnt.vhd

DeskTOP 2.0 - Sept 99

Notes
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Creating New VHDL Macros

File > New

State Diagram

library ieee
use ieee.std logic_ll64.all:

ﬁQﬁe:rn:.:‘.t:'}g strobe is

# port(rst, wrt_clk, decode: in 3td_logi:;
strobe: out atd_logic):

“end strobe;

|

" sarchitecture behave of strobe iz

" type state is (strobe lo, strobe_hi, waiting):

zignal ¢3, na: scate;

@;@ o " % i % e

£

DeskTOP 2.0 - Sept 99 2-6




Lab Introduction

B Complete Lab 1

— Perform all labs in your dmac.prj project.
— Generate three ACTgen macros:

* MY_RAM

* UPCNT

* DWNCNT

B Complete Lab 2

— Create a new VHDL block:
« DECODE

— Add two existing VHDL biocks to the project:
* CONTROLL
* STROBE

M——__{
DeskTOP 2.0 - Sept 99 2-7

Notes




t ke

it

Review
B What is ACTgen for?

B What output format is automatically selected by the
DeskTOP? Why?

B What useful information is stored in the ./og file?

B What is the .gen file for?

=~k

DeskTOP 2.0 - Sept 98 2-

Notes




Chapter 3
Introduction to VeriBest
VHDL Simulator
Capturc:zﬁ& Magrl}%gemem
v
Simulation Synthesis Post-Synthesis Simulation
) S |7 ]
* ]

P tP&FI’i: i i
ost- almulat on proggmmg

Objectives
After completing this chapter, you will be able to:

I. Diagram the design flow for stimulus generation and simulation

!\J

Explain how to generate a stimulus file.
Associate a stimulus file.
Invoke the VeriBest VHDL. Simulator.

A e

Explain how to view simulation results for block 1/Os as well as internal
nets (including cross-probing)

6. Show how to restart a simulation.



a

' 3

wd

———— S imulation Design Flow

For each block you want to simulate . . .

Generate stimulus —FrAssociate stimulus I P | Select waveforms to view
- r Invoke simulatorJ
Lot T
h 4

Compile and Link Run the simulation

- s

DaskTOP 2.0 - Sepl 89 3-2

Notes

Before you can simulate, you must have a stimulus file. This file is easily
created using VeriBest's graphical stimulus generation tool.

Once created, the stimulus file must be associated to the block that you want
to simulate. This allows for easy switching from one stimulus file to
another.

When the simulator is invoked, the VHDL block and its associated stimulus
file must be compiled and linked.

Next you must use the Wave Viewer to select nets that will be tracked and
displaved during simulation. You may select block I/0s or use cross-
probing to select internal nets as well.

Finally vou run the simulation and review the results.

¢



23] Default Configuration
2] demo ————»

Right
Mouse
Click!

Open . -

Open in Simulator
Open in‘Syninesis

Set as Root

Genorate Stimulus
Assoclate Stimujus
Unassoctate Stimulis

Croate a New View
Create Block Symbol

Prépér't'ie_é ‘

Invoking the Stimulus Generator

Notes

To invoke the stimulus generator tool, highlight the desired block and right-

mousce click to select Generate Stimulus.
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wd
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———— Drawing the Stimulus

2 3
Insert edges Adjust the levels

1 :
Select the 1 1
input —-{D et | [—“l_‘\
40w ek 5 N\
[ decode 4 :
i : 4 Adjust the transition times puemmes

] & suobe

¥

ﬂ
A DeskTOP20- Septd9 3.4

Notes

The stimulus generator has icon buttons that make it very easy to quickly
draw the input waveforms.

First you select the waveform and insert edges at approximately the desired
times.

Next. vou select each segment and adjust its level to high, low, tristate or
unknown.

Finallv. you select each transition edge and position it exactly in time using
the mouse or a type-in field.



Saving the Stimulus File

—

File > nge'_;f._

{—@ VB‘_-F-:’.rciect Simulation Environment .
; E]‘ demo. wsw
1 @8 demo_stim.vhd

SIS > LR _
\.‘% m——

Notes

By default, the stimulus file is name <block>_stim.vhd and placed in a
<block> wsw directory under the Simulation Manager tab. The next time
the stimulus generator is invoked, this same file wil] automatically be
opened.

To generate another, separate stimulus file, you must make modifications to
an existing one and be sure to select File > Save As, Otherwise, the old file
will wutomatically be overwritten.

C
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Associating Stimulus and
Invoking the Simulator

Open:

Iz8] Default Configuration LR S~
- 2] demo ———» Open'in Simulator
Open in Synthesls . ¢

Set asnout S

1 | Generate Siimulus . -
—3p Assoclate Stimulus -
Unassociate Stimulus--

Create a New View
Create Block Symbol

Properties

M

Note

To use the stimulus file, you must associate it to the block as shown above.

Once associated, the block can be opened in the simulator as shown above.



Compiling, Linking and Invoking
WaveForm Viewer

demo.vhd Files associated
{8 demo_stimvhd 31§ with the block

A etk Message area |

Vo CONP —uns_vis C:\actproj\test\design_definition\stimulus\gm
VeriBest VHDL Compiler - 15.00.00.48 ;

s

(B o i 3

Notes

After invoking the simulator, you should first verify that all the files
associated with the block are listed and in the correct order. The top -to-
bottom order should match the hierarchy order from lowest to highest level,
ending with the stimulus file. This prevents one block from referencing an
uncomptled one.

If all the files are listed, you should:
+ compile all I_%f_l and then click €

When compilation and elaboration are successful, you should:

* sct up the WaveForm Viewer by clicking g



&

i

!‘L

-y

iy

—— S e tting-up the WaveForm Viewer

i |/Os are listed by default

FTOCLE
- DECODE
& STROBE
mcs
Pt NS

Expand the UDUT hierarch
to list internal signals

@ KILLERPROC [Line

& STANDARD !
~d@ TEXTIO N
L@ STD_LOGIC_1164 # [

\: . ; },g%
DaskTOP 2.0 - Sept 99 3-8

Notes

Before running the simulation, you must indicate the waveforms that you are
interested in viewing. To do this, click the Add Signals icon in the
Wavelorm Viewer.

The result is shown above. By default, the block I/Os will be listed and
ready to add (with the Add button).

To see a list of internal signals, expand the UDUT entry as shown above.



Cross-Probing to View Internal
Nets

B Schematic must be open and Transmit icon must be
selected. g3

DaskTOP 2.0 - Sapt 99




V L ]
. Cross-Probing (cont.)
ST || You highlight the
CEUOZ | : o netand. ..
- _
- ™} DECODE T .
ricm lv
roest v :
" f"i STROBE {v 1 v
- - vee U :
- .. [T URT_CLR U 1. |...it gets added to your
- TUDIMO_ L 4—1% — | list of waveforms to view
J™\ DEMO_2 : L 1
DeskTOP 2.0 - Sapt 99 3-10
Notes
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o
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Starting or Resetting Simulation

To reset the start time, select

To start the simulation, Simulate > Restore

enter the duration and
click the Run button

OeskTOP 2.0 - Sept 99 3.

Notes

In the example above, the initial simulation is set to run from 0 to 100 ns. 1If
another simulation is performed, it will run from 100 to 200ns. By default,
the start time of a subsequent simulation is always the end time of the
previous simulation.

To reset the start time, select Simulate > Restore as shown above, then
sclect the desired start time and click QK.

3-11
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How WaveBench Setup is Saved

23 VB Project Simulation Environment - -
= & demowsw When you exit the simulator, a

= demo_stim.vhd .vpd file is created.

% demo.vpd g
Next time you open the
simulator, it automatically opens

the .vpd file

DeskTOP 2.0 - Sept 99 3.12

Notes
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}*Introduction to Lab

B Complete Lab 3

- Generate stimulus for a VHDL block
- Simulate a VHDL block

Notes

DeskTOP 2.0 - Sept 99 3-13




L

1

K I

L—-— Chapter 4

Introduction to Synplify

Capture & Management

Simulation Synthesis N Post-Synthesis Simulation
[ | > T "
¥
Place & Route
v
Post-P&R Simulation Programming
™ | i

ﬂ
= N . DeskTOP2.0-Sept93 41

Objectives
After completing this chapter, you will be able to:
* Invoke Synplify
« Explain the various files that may appear in the Source window.
« Explain the global synthesis options.
« Explain the various Target options.
« Pertorm synthesis
« Usc the log file to view and locate the cause of errors, warnings and notes,

« State the nume and location of the file that should be opened to perform
post-synthesis simulation.

-

e



L‘ How to Invoke Synplify

23] Default Configuration Open

¥ upent ~ Open i Simulator
T [O#) | Openinsynthests

Generate Stimuliss
Associate Stimulus-
Unassociate Stimulus -

Right
Mouse
Click!

Craate a Now View
Create Blo'ci_( Sym_bql_._- :

Fr.obértie# :

DeskTOP 2.0 - Sept 59 ks

Notes
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s The Synplify Interface

Frequency (MHz) 100

Symbaolic FSM Compiler ¥ )
v

DaskTOP 2.0 - Sept 99 4.3

Notes



WORK C:\<project>\blockl.vhd } Optional - only if top.vhd is
WORK C:\<project>\blockl.vhd hierarchical

WORK C:\synplcty\lib\actel\3200dx.vhd You'll always have at
WORK C:\<project>\top.vhd least 2

WORK C:\<project>\top.sdc

Optional - only if you want to include
- Timing constraints

- HOL attributes

- Vendor-specific attributes

——

Notes
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L—— Synthesis Options

B Frequency -

® Symbolic FSM Compiler - Turns on proprietary state
machine optimization techniques.

m Resource Sharing - Turns on automatic sharing of
operators (adders, subtractors, etc.) for exam ple:

A

If s='1', then c
Y«= A + Bj

B

D

Else
Without resource sharing With resource shatring

[+ =

Y <= C + Dy

DaskTOP 2.0 - Sept 99

Notes

The options above are global and each can be overridden by
constraintsfattributes embedded in the code itself.

If you want to specify a global state machine encoding method (instead of
letting the Symbolic FSM Compiler decide for you), select Tools > Options

and vou'll see the  window shown below

onehot

gray
sequential
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—— T arget Options

Target
Chcmge Actel 3200DX. part: A3265DX, speed grade: Std, Fanout Lim:t: 16

By default, Synplify will insert
Actel 1/O macros on all the
HDL IYO ports.

For synthesis of blocks, this
must be disabled.

DeskTOP 2.0 - Sept 99 4.6

Notes



=== For More Info . . .

m General Information
DEFarrrg Surpdhy

Very thorough
online help!

L,

Geting started
Running in Batch Mode
Synpiify Editing Window
Symboiic FSM Compiler
Hierarchy Browser
Menus and function keys
@ SCOPE, the constraints editor
Q Area/Delay and Fanout Control
Q Output Files, Reports, Log File
Q;I Actel support

Designing with Actel
Q Actel-specific Attributes
@ Using Tel

REEREE

DeskTOP 2.0 - Sept 99

Notes



Performing Synthesis

.‘ Source Files T ( :
vork ¢ “synpletyslibhactel~a3d2i0dx.v g )
Synplicity

work c “actprojsdmac‘design_definiti
.- Freguency (MHz) |1UU
- s

Symbolic FSM Compiler ¥
o T e 3;;;,;@ Resource Shanng ~
. Result Fils

c Nactprojdeacidefaul t place_and_route~actel>controll edn

| W3

speed grade: Std. Fanout Limit 186

DeskTOP 2.0 - Sept 99 4-9 l
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=== Reading the Log File: Errors

; 5 Sv7arv of Compile
S #3at Feh 27 0B8:15:43 1994
Synplify VHDL Compiler, wersion §.0. 8, built Dec 22 1998
Copyright (C) 1994-1998, Synpl1c1ty Inc. All Rights Reserved
‘BEy e \u’ﬁ\d&i Hul.mbf-. qen \.Iul [vhdli N )

: library ieae;
juse ieee.std_logic_ll64.all;

entity strobe gen is

port{vrt_clk, decode: in std_logic:
strobe: out std logicj:

s end scrobe_gen:

ity

architecture hehave of strobe _gen i3
type 3state is {strobe_hi, waiting)
CS, ha: state;

n

=

2,

—

Notes

All errors, warnings and notes will be highlighted in the log file. To
investigate, double click on the highlighted line and a VHDL editor will
open. showing the offending code and the error message.

In this editor, you can correct the problems, save the file and immediately
retry svnthesis,
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Reading the Log File Report
R

]

#VHDL syntax check successful!
M afile c: \acrproj\dmacidesign_definition\hdl\vhdlistt
+ Synthesizing work.strcbe.behave
_%fN:"ci\test\design_definition\hdlivhdl\stzobe,vhd":
" gPoat processing f£or work.strobe.behave

* HEHD
iynthesxzed design as a chip
Resource Usage Report
P
5 Target Part: a3265dx
. Combinational Cells: 0
43equentiel Cells: 2 of $10 (0%)
JTotal Cells: 2 of 985 (l1x)
;. Clock Buffers: 1
410 Ceils: 4
- Decails:
%1 ditm7a: 2 seqil
cl¥buf: 1 clock buffer
inbuf: 2
oythuf: 1
-—-—--—- DeskTOP 2.0 - Sept 99 4-10
Notes
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Post-Synthesis Simulation

& Default Vendor Configuration Open
- HOL io i '
=y Synthesis Files » Generate Stimulis :
. strobe.vhd |~ (O —> Open Pcst~$ynmeals Simulator .

= B Place-Route Files ‘> Assoclate Stimulus -
[ strobe.edn Unassaciate Stlmulus

Remove File from Pm)ect
Propartles :

—

Notes

When synthesis is successfully completed, two new files are added to the
project: the EDIF netlist and a structural VHDL file. Both files are
displayed in the Vendor Manager tab as shown above.

The EDIF netlist can be imported into Actel’s Designer (if it represents the
whole FPGA).

The structural VHDL file is used to perform post-synthesis simulation

4-11
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Introduction to Lab

m Complete Lab 4
- Synthesize 3 VHOL blocks
- Perform post-synthesis simulation

M Complete Lab 5

- Complete the DMAC schematic by adding in ACTgen and
VHDL blocks.

# Complete Lab 6
- Synthesize and simulate DMAC

DaskTOP 2.0 - Sepl 99

Notes







I EEL

!]:
X .

T ¥
A .

== Chapter 5

Introduction to Designer:
Preparing for Place and Route

Capture & Management

¥

Simulation Synthesis Post-Synthesis Simulation
ad S - | ‘l
¥
Place & Route
L a
2
Post-P&R Simulation H

a i~ Progrgmmg

—_———— DeskTOP 2.0 Sept 99

Objectives
At the end of this chapter, you will be able to:

« List the Designer tools that impact how an FPGA is placed and routed
or “layed out”.

« Differentiate between opening a new design and opening an
existing one.

» Describe the purpose of the Compiler.
« Discuss the pros and cons of making pin assignments.

« Explain the Pin Edit user interface and how it is used to make pin
assignments.

« Differcntiate between an assigned pin and a fixed pin and explain how
they “end up that way”.



. Invoking the Designer

1 Default Vendor Configuration
S ’.‘.';; Synthesis Files

----- stiobe. vhd
e @ Place-Route Files

DeskTOP 2.0 Sept 99

3 File from Project

Propeities -

Notes
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—=—= The Designer Interface

These tools “set th
stage” for layout

DeskTOP 2.0 Sept 99

e

Notes




Prompts you for:
* Device
* Package
* Operating Conditions

Verifies:
: * Logic module count
* YO module count
* Fanout

Optimizes logic

DeskTOP 2.0 Sept 99

Notes



= The Pin Edit Tool

i

) Compile I List of unplaced List of placed
/O nets

[ o7 Edit
¥
‘ DT Analyze l—H Layout Chip

Extract <

Top view of
package
- pinouts

[ 8

“Dyrag and drop” from the lists to the pinout diagram

e —————————————————
DeskTOP 2.0 Sept 99 5.5
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Suggested procedure:

Pin Assignments:
To be or not to be ....

Enter design as completely as possible
(don’t worry about functionality)

2 l&)mpile (ignore warnings) and Layout]

3 ﬁx”ail pin assignments (Edit > Fm

LeskTOP 2.0 Sept 95

4 LSend the pin report to PCETI

5 Continue working out bugs
(future Jayouts will honor “fixed”
assignments)

e




—=— Reporting Pin Assignments

Select Reports > Pin

o

Ll wnw - -
Pin Report - Date: Wed Sep Bh 15:42:M1 1996 Pinchecksum: 7696dd2_fcele
Design Mame: ACE Family: ACT2/1208XL pie: A12253L Package: 84 PLCC

Number Hame Fixed Load Level

1 RESET

2 UNRSSIGHED

3 Co

&  UNASSIGHED

S UMASSIGHED

5 GHD FIXED
7 UNASSIGMED

8 UMASSIGMED

9 UNASSIGHED
UHASSIGHED

11 UNASSIGHED

12 MODE FIXED
13 ADATAG FIXED

_M
DeskTOP 2.0 Sept 99 5.7

Notes
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o Saving Pin Assignments

Save pin assignments from the Designer’s main File menu!

Designer
Joels Reports Options Help
n...
Close...

Impaort »
Expont..,

Execute Script...

Save As.
Preferences...
Exit

DeskTOP 2.0 Sept 99

Notes
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. Opening an Existing
Database

‘#f Default Vendor Configuration

= Y Synthesis Files
-[A strobe.vhd
=D Place-Route Files
" b [Fuobe.ags— [OM) ——>Topen —— ~
. - Genefate Stimulis -~
strobe.edn Opén POst_?Lay@n,_lt'Sl_rnuIatcir,
Open in Place and Route -

Assoclate Stimutus
Uniassoclate Stimulus

i@ DeskTOP 2.0 Seot 99 5-9

Notes




. Lab Introduction

B Complete Labs 7 and 8.

— Import and compiile the DMAC schematic.

— Make some pin assignments for the DMAC design.

UeskTOP 2.0 Sept 99

Notes

T
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- Review

= How do you begin a Designer session for a new
design?

B What does the Compiler do?

® What is Actel’s recommendation with respect to
manual pin assignments?

m Besides the Pin Edit tool, what other ways can you
make manual pin assignments?

m Where is the Designer data stored? Where is it
displayed in DesignView?

ZSCSSY] mmmmmssse——————————————
—_—————— DeskTOP 2.0 Sepl 9% 5-11

Notes
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Chapter 8

Introduction to Silicon
Explorer

Capture & Management

e &
Simulation Synthesis Post-Synthesis Simulation
- =" e “l
¥
Place & Route
e
‘1"5’ Debugging
Post-P&R Simulation :

ﬂ N Prog:;rlmmg

DeskTOF 2.0 Sept 99 B8-1

Objectives
At the end of this chapter, you will be able to:

* Describe the overall functionality of the Silicon Explorer.

* Describe the purpose of the MODE, SDI, PRA, PRB and DCIK pins on
Actel devices.

* Correctly connect a Probe Pilot to an “in-circuit” FPGA.
* Explain the user interface of the Analyze software.

* Explain the three steps that prepare a design for debugging.
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What is the Silicon Explorer?

Once the FPGA is placed “in-circuit”, Silicon Explorer
is...

m The Probe Pilot - hardware that allows you to probe
up to 18 different signals

_ 2 of the signals may be internal nodes of the FPGA!

m Analyze - Software that allows you to display and
analyze the behavior of the probed nets.

M
= e . DeskTOP 2.0 Sepls9 8-2

Notes

AC L



— . Silicon Explorer Set Up

Silicon

Logic
Explorer

Analyzer
Probes

j port

Every Actel FPGA has 5
pins specially designed for
debugging

| Printed Circuit Board |

DeskTOP 2.0 Sept 99 8-3

Notes

Every Actel device has 5 pins that are specially designed for debugging
with the Silicon Explorer.

Three of the pins, MODE, SDI and DCLK are inputs to the FPGA.

The other 2 pins, PRA and PRB send the behavior of internal nets back for
viewing with the Analyze software.

The Silicon Explorer itself is connected to the computer via the serial port.
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How does Silicon Explorer

work?

1. User selects

the desired net.

CRC_ERR_core
CRC_OK_core

OIR_y_7?
2. This places an “address”

3. Based on this “address”, the
PRA pin is temporarily
connected to DIR y_2.

I Y

for DIt _y_2 on the SDI pin sol ] '
rT 1T 17T 1T 177171
4. The value of DIR_y_ 2 can now
be displayed and analyzed.
M
LA DeskTOP 2.0 Sept 99 B-4

Notes

When a user invokes the Silicon Explorer software, the MODE pin is set

high and the PRA, PRB, SDI and DCLK pins operate as follows:

Based on a user’s request for the value of an internal signal (¢.g. the

DIR_y_2 net above), an “address” corresponding to that signal’s
location in the FPGA is generated and placed on the SDI pin and
clocked in with DCLK.

Based on the SDI signal, the node of the signal in question is

multiplexed out and made externally availabie on either the PRA or

PRB pin. From here, its behavior can be viewed with the Analyze

software.

AN




e e OVeTvView of the Analyze
Window

beon daplorer 300 Lo deme bee]

Toggle between

i cables 1 and 2 and
TZ (D teotw =N PRA and PRB.

1 F amdy: 400 b

Davice: 40ma0é el ’
; Package: gip80 : Values of signal at
List of alf nets m:wwzg;wlw . Cursori and Cursor2
m o FUITy: Vs *? . =
= @ Nets -
CLK_y
CRC_ERA_core s Trigger levels (fow,
gl':f-?‘ﬂ" rising, high, falling, etc.) |
Ly Jrrr—
OR_g 1

DeskTOP 2.0 Sept 89 8-5

Notes
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Preparing for Debug

1. If possible, avoid using probe pins for regular user Vo

This is the detault

2. Make probe pins accessible (e.g. jumper leads,dedicated connector)

DeskTOP 2.0 Sept 99 B-6

Notes

When you compile your netlist in the Designer, you are prompted to set the
device variations as shown above. If possible, avoid using the probe pins
by leaving the Reserve Probe Pins box checked as shown above. This is
the default.



Preparing for Debug (cont. )

3. Export a “probe” file from the Designer

DeskTOP 2.0 Sept 99

Notes

The Silicon Explorer understands a design’s netlist by reading its “probe”
file.

This file has a .prb extension and is created in the Designer by selecting
File > Export and making the selection shown ahove.

/1/:/\
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=== Lab Introduction

m Complete Lab 14.
— Connect the Silicon Explorer to the CRCDEMO board.
— Open the provided .prb file.

- Investigate some internal nets.

__%___‘ DeskTOP 2.0 Sepi 99 g-8 [

Notes



