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1. Introduction.
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CompiCat is an application for editing and compiling catalogs of earthquakes, which is essential part of
any study of seismic activity. The application combines the features of EdCat and Catal console
applications developed in the early 1980ies (the latest versions of these programs were distributed at
the Abdus Salam ICTP Workshops on Nonlinear Dynamics and Earthquake Prediction, last time in
2005 http://cdsagenda5.ictp.trieste.it/full_display.php?ida=a04209).

CompiCat program is a C—t- code using Qt C++ tool kit for multiplatform Graphic User Interface and
application development. It has single-source portability across Linux, UNIX, and Windows.

CompiCat program was designed for reproducible studies of seismic activity based on catalogs of
earthquakes. It could be applied for

importing catalogs available in different formats and converting them into the standard one;
exporting catalogs into commonly used formats;
selection from a given catalog;
comparison of catalogs;

- editing and compilation of earthquake catalogs, which includes check for errors and disorder;
converting of magnitudes of different kinds into the common one;
identification of duplicates and their removal;



merging several catalogs into a single one;
calculation and visualization of spectrograms and histograms of a given catalog, etc..

Thus, CompiCat provides a tool-box that allows preparing the catalog of earthquakes in the
standard format without evident errors or disorder.

CompiCat supplies users with online help in three levels of detail. Its project wizard allows users to
create a project file as a sequence of operations on seismic catalogs for future implementations, e.g.,
for reproduction of the analysis by other parties.

CompiCat allows writing down a protocol, which contains information on all corrections of errors,
identified duplicates, parameters used in different operations, etc.

Running CompiCat results creation and output of the following optional files: output catalog of
earthquakes, the project binary file, and the protocol text file.



2. Catalog formats and import/export options.

CompiCat program works with catalogs of earthquakes filed in the standard format that specifies the
origin time, location, and magnitude of event (see Appendix A).

The ASCII text formats of the original seismic data reported by the US Advanced National Seismic
System, the USGS/NEIC Preliminary Determinations of Epicenters, the Northern California
Earthquake Data Center, the Southern California Seismographic Network, and other agencies (see
Appendix B) are supported for importing research information. The supported formats are listed in a
special file, which could be upgraded according to the instructions provided in Appendix B.

CompiCat program allows importing catalogs in the following way:

Click Import ^45 button
catalog browser.

in the uppermost tool bar or Import entry of File menu to open the import

i Choose a catalog and it's formal

Look in: ^ j D:\ecp\Import HQ Q Q 3
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File name: catsearch 60.anss80col Open
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Preview:

1: 2005/ 1/ 1 1:42:24,85
2:2005/ 1/ 1 1:43:40,14
3: 2005/ 1/ 1 1:55:28.46

7.290 93.920 30.0 5.00 000 0.00 0,00 0
7.030 92.460 35.5 5.20 0.00 0.00 0 00 0
2.910 95.620 24.5 5.70 0.00 0,00 0.00 0

Find and select file for import from the list that appear in the upper left frame. CompiCat tries
recognizing the catalog format automatically and reports in Preview frame either the first three records
of the catalog or ' Error format' message. Note that (i) errors of the imported catalog, if any, will appear
in Errors page of protocol frame ( see 4.2.3 Protocol Frame) and can be corrected ( for details see 6.
Catalog editor ); (ii) catalogs with detectable errors cannot be transferred into the standard format (csf
files). "

To simplify import CompiCat program allows classifying catalog files by their type. The following
extensions listed in Files of type box are used in the import browser:



• Any files (*)

• Standard Format - Binary (*.20bytes)

• Standard Format - Text (*.41 bytes)

• Standard Wide Format - Text (*.68bytes)

• Advanced National Seismic System (*.anssreadable)

• Advanced National Seismic System (*.anss80col)

• Southern California Earthquake Data Center (*.scedc)

• Southern California Seismographic Network (*.scsn)

• NEIC Preliminary' Determinations of Epicenters (*.pde)

• Summary hypo71 format year 2000 (*.hypo71)

• NEIC Hypocenter Database System (*.hds)

When recognizing the catalog format automatically CompiCat uses format description block listed in
ASCII text file named .../ecp/ref/standardforrnat.list and displays one of the following TITLE strings in
Format box:

• 20 bytes - Standard Binary Format

• 41 bytes - Standard Text Format

• 68 bytes - Standard Wide Text Format

• anss readable - Advanced National Seismic System

• anss 80-col - Advanced National Seismic System

• pde - NEIC Preliminary Determinations of Epicenters

• scedc - Southern California Earthquake Data Center

• scsn - Southern California Seismographic Network

• hypo71 - Summary hypo71 format year 2000

• hds - NEIC Hypocenter Database System

CompiCat program outputs the compiled catalog of earthquakes in the standard binary format. If
requested, the program exports the compiled catalog either in the 20 bytes - Standard Binary Format,
or 41 bytes - Standard Text Format, or 68 bytes - Standard Wide Text Format. (The first two formats
were used previously in the console applications developed at MITP, which applications require "dat"
as the file name extension.)



To export the catalog toggle on Export button and select an appropriate format.

20 BYTES - STANDARD BINARY FORMAT

41 BYTES - STANDARD TEXT FORMAT

68 BYTES - STANDARD WIDE TEXT FORMAT

At this point CompiCat opens Save file browser that allow the user to save the catalog under any name.
CompiCat manages file name extension name automatically, specifically, if for the 20 and 41 bytes
formatted files the extension is ".dat", while for the 68 bytes formatted files the extension is ".68bytes".



3. Quick start
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There are the four possibilities to start CompiCat session. All but the four buttons listed bellow are
disabled when the user enters the program.

1. £3* Open an existing file in the internal binary Catalog Standard Format (file name extension .csf)
with file navigator
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2. ~3 - Generate a new project

3 Project Wizard: unnamed
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4. • tf - Import a catalog with file navigator
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When the user selects file for import, the program tries to recognize the appropriate format
automatically. If the program cannot do it then Preview box will report' Error format'. Otherwise, the
first three records of the catalog will appear in Preview ( for details see 2. Catalog formats and
import/export options ).
If imported catalog contains errors, e.g., records of parameters out of range or sorting disorder, then
these will appear in Errors page of the protocol frame ( see 4.2.3 Protocol Frame for the list of errors
). The user must correct all errors (see details in 6. Catalog editor).
After starting a CompiCat session the user can execute either the project or any of the catalog Tools
(see 7. Tools ). The user can save current catalog or project or protocol files at any time of a session by
clicking the following buttons:

- Save the current catalog file;

' - Save the current catalog file under a new name;

^r - Save the project file;

^w - Save the project file under a new name.

-CJ - Save the protocol file;

-Li - Save the protocol file under a new name.
CompiCat will prompt the user about saving output files on exit. Catalog files have standard extension *.csf, project files have standard
extension *.pro, protocol files have standard extension *.protocol. All these extensions are added lo the filename automatically.

The user can export the current catalog t any time of a session by clicking Export button i-fl "*" . ( For
details of export formats see 2. Catalog formats and import/export options).

CompiCat remembers the last saved settings (i.e., sizes and positions of windows and some other
options) across sessions. For details see Appendix C.

10



4. Main window

4.1 The Tool Bars.

4.1.1 The File Tool Bar.

- Open an existing catalog file. Correspondent menu option is File->Open and keyboard shortcut is Ctrl+O.

- Import a catalog file. Correspondent menu option is File->lmport and keyboard shortcut is Ctrl—I.

- Save currently open file. Menu option is File->Save and keyboard shortcut is Ctrl-S.

^ - Save the current file under a new name. Menu option is File->Save as ....

^ J - Save the catalog, project and protocol files to disk. Menu option is File->Save AH ...
•ji "*• - Export a catalog file. Menu option is File->Export...

- Generate a new project. Menu option is Project->IVew Project and keyboard shortcut is Shift+N.

'- Open an existing project. Menu option is Project->Open Project and keyboard shortcut is Shift-O.

- Edit an opened project. Menu option is Project->Edit Project and keyboard shortcut is Shift+E.

- Execute project task list. Menu option is Project->Execute Project and keyboard shortcut is Shift-B.
i

- Save the project to disk. Menu option is Project->Save Project and keyboard shortcut is Shift—S.

- Save the project under a new name. Menu option is Project->Save Project As ...

4.1.2 The Edit Tool Bar.

^ "* 4 - -J ft a k K . - &
"- Undo edit action. Correspondent menu option is Edit->Undo and keyboard shortcut is Ctrl+Z.

- Redo edit action. Menu option is Edit->Redo and keyboard shortcut is Ctrl-Y.
v 1 - Cut the current selection's contents to the clipboard. Menu option is Edit->Cut and keyboard shortcut is
Ctrl+X.

" - Copy the current selection's contents to the clipboard. Menu option is Edit->Copy and keyboard shortcut
is Ctrl+C.

•_J- Paste the clipboard's contents into the current selection. Menu option is Edit->Paste and keyboard
shortcut is Ctrl-V.

.*] - Delete the current selection. Menu option is Edit->DeIete and keyboard shortcut is Del.

11



L—J- Insert row before the selected row. Menu option is Edit->Insert row and keyboard shortcut is Ctrl+I.

i-" *V Zoom in. Menu option is View-> Zoom In and keyboard shortcut is Ctrl-r-.

-^V Zoom out. Menu option is View->Zoom Out and keyboard shortcut is Ctrl--.
. ,

H - Enter What's This? mode. Menu option is HeIp->\Vhat's This? and keyboard shortcut is Shift—F1.

V - Exit the application. Menu option is File->Exit and keyboard shortcut is Ctrl+Q.

4.1.3 The View Tool Bar.

"-* - Information of catalog and view catalog segment. Keyboard shortcut is Shift+I.

- Find catalog record by date or by number. Menu option is View->Find record and keyboard
shortcut is Shift-F.

- Save view catalog segment changes. Menu option is View->Save view segment changes and
keyboard shortcut is Shift+V.

- Cancel view catalog segment changes. Menu option is View->Cancel view segment changes and
keyboard shortcut is Shift-C.

4.1.4 The Tools Tool Bar.

* 9- Check time order. Menu option is Tool->Check order and keyboard shortcut is Alt+K.
1
* »- Sort catalog records by ascending time. Menu option is Tool->Sort by time and keyboard
shortcut is Alt+I.

*u~- Convert magnitudes to common type. Menu option is Tool->Convert magnitudes and keyboard
shortcut is Alt+N.

~^~ Check and remove duplicate records. Menu option is Tool->Remove duplicates and keyboard
shortcut is Alt+D.

tJr- Select subcatalog. Menu option is Tool->Select and keyboard shortcut is Alt+S.

- Merge catalogs . Menu option is TooI->Merge and keyboard shortcut is Alt-'-M.

^ Substitute parts of the initial catalog. Menu option is Tool->Substitute and keyboard shortcut is
Alt-HJ.
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Check range of parameters. Menu option is Tool->Check range and keyboard shortcut is Alt+C.

Compare two catalogs. Menu option is Tool->Compare and keyboard shortcut is Alt+L.

Draw the histograms. Menu option is Tool->Draw histograms and keyboard shortcut is Alt-G..

4.1.5 The Protocol Tool Bar.

~h ( "2 Protocol: test.protocol

I—-> - Preview Protocol. Correspondent menu option is Options->Preview Protocol and keyboard
shortcut is Shift+R.

LC3 - Save the protocol to disk. Menu option is Options->Save Protocol and keyboard shortcut is
Shift+T.

LQ - Save the protocol under a new name. Menu option is Options->Save Protocol As...

4.2 Central Area
4.2.1 Catalog Frame

The main part of the central area displays Catalog frame.
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The frame contains part of the catalog named View catalog segment. By default the size of View
catalog segment is 50 records, which could be changed in Options. The frame has the following
navigator buttons:

(J>- Moves to the beginning of the catalog.
O - Moves to the end of the catalog.
O - Moves one view segment up.
O- Moves one view segment down.

The following buttons to the right of Catalog frame allow the user to

get the brief info on the current catalog and view segment;

find a record by date and time or by sequential number;

save the changes made in the current view segment;

cancel all the changes made in the current view segment.
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4.2.2 Project Frame

The CompiCat main window has the project frame that appears in its upper-left part. By default it is
empty. It is not empty if some project has been either opened or newly created.

Tasks

a iProject

& Cat~i?Q
3

B Tasks:

a 16

&

project, pro

cairfbrn.csf

Rercwe duplicates
Merge cataloqs
j seconq.csf
3 frst.csf
2 tftrd.csf
U fourth.csf
Select subcatafcq
Substitute cataaxB
3 substitute3.csf
• substitute!.csf
3 substitute2.csf
Convertirq magnitudes

The frame contains the project name, the input catalog name, and a brief description of the sequence of
tasks considered. If additional catalogs exist in a task, then the list of these add-ins is provided as
branches of the project tree (for details see 8.1 Manage Project).

4.2.3 Protocol Frame

CompiCat displays Protocol frame at the bottom of the central area. The frame has the three tabs, i.e.,
Errors, Messages, and Corrections.

Errors tab page shows the evident errors recognized by CompiCat automatically, as well as the values
out of the user defined ranges of parameters (7.7 Check specified range).

Recorc j Description #

Range check completed. 4 errors foLnd.

1

2

3

4

3

4

8

29

Errors

Mhute (rn) s out of range: value 94 , range [ 0 ,59 ]

Month (M) is out of range: value 15 , range [ 1 , 12 ]

Hour (h) is out of range: value 35 , range [ 0 , 23 ]

Latitude (Lat) is out of range: value 94.082 , range [ -90 , 90 ]

°- Messages j S Corrections

The user must fix the errors by (i) clicking Description of the error and (ii) making appropriate
corrections in prompted cell of Catalog frame above.

In case of recognized disorder in time the user has to check the records of disorder and either correct

non-evident errors or sort the catalog by clicking * Sbutton.



Record Description

57

58

iOrder check completed. 4 errors found. I

place in sorted catalog: 90

place in sorted catalog: 2

place n sorted catalog: 91

place in sorted cata'og: 56

after: 91

after: 1

after: 2

after: 56

«- Errors j i« Messages > Corrections J

When checking the temporal disorder the user can view the record in question, its place . as well as the
preceding record in sorted catalog by clicking the appropriate cell.

The other two tab pages of Protocol frame sum up the comprehensive info about the tasks performed
during the current session of CompiCat. Specifically, Massages page contains info about project (if
any), input-output catalogs, tools and their parameters, while Corrections page contains info about
editing, details on tasks and tools, and their applications. For details see 9. Protocol of CompiCat
session..

4.3 The status bar.
The status bar is horizontal bar at the very bottom of the CompiCat window presenting status
information, which indicators corresponds to the three categories, i.e., temporary, normal, and
permanent. The temporary one briefly occupies most of the status bar and explains, for example, menu
entries, icons, etc. The normal one occupies part of the status bar and may be hidden by temporary
messages and displays the tool name or state of readiness. The permanent one is never hidden and
indicates either Start, or Tools, or Project.

i Action: | ;Edir project 4

5. Menu entries

5.1 The File Menu.

The keyboard shortcut is (Alt+F). The following functions are available from the File menu:

File->Open ( Ctrl-O) - Open an existing catalog file.

File->lmport (CtrW) - Import a catalog file.

File->Save ( Ctrl+S) - Save currently open file.

»J* File->Save as ... - Save the current file under a new name.

16



_ r File->Save All ... - Save the catalog , project and protocolt files to disk.
mt "* File->Export... - Export a catalog file.

File->Open Recent - Displays a list of recently opened files to choose from.

W File->Close (Ctrl+L) - Close a catalog file.

File->Exit (Ctrl+Q) - Exit the application.

5.2 The Edit Menu.
The keyboard shortcut is (Alt4-E). The following functions are available from the Edit menu:

Edit->Undo ( Ctrl+Z) - Undo edit action.

Edit->Redo ( Ctrl+Y) - Redo edit action.

- . Edit->Cut (Ctrl-X) - Cut the current selection's contents to the clipboard.

~ 1 Edit->Copy (Ctrl-C) - Copy the current selection's contents to the clipboard.

• J Edit->Paste (Ctrl+V) - Paste the clipboard's contents into the current selection.

Al Edit->Delete ( Del) - Delete the current selection's.

—I Edit->Insert row ( Ctrl+I) - Insert row before the selected row.

Edit->Select all - Select all rows of catalog workspase.

5.3 The View Menu.
The keyboard shortcut is (Alt-V). The following functions are available from the Edit menu:

View->Find record (Shift+F) - Find catalog record by date or by number.

View->Save view segment changes (Shift-V) - Save view catalog segment changes.

View->Cancel view segment changes (Shift+C) - Cancel view catalog segment changes.

View-> Zoom in (Cntrl++) - Increase the display font size.

^ S View-> Zoom in (Cntrl+-) - Decrease the display font size

5.4 The Project Menu.

The keyboard shortcut is (Alt+P). The following functions are available from the File menu:

Project->N'ew ( Shift-t-N) - Generate a new project.



~& Project->Open Project (Shift+O) - Open an existing project.

Project->Edit project(Shift-HE) - Edit an opened project.

Project->Execute project ( Shift+P) - Execute project task list.

Project->Save Project ( Shift+S) - Save the project to disk.

H 1 Project->Save Project As ... - Save the project under a new name.

Project->Open Recent - Displays a list of recently opened project files to choose from.

C? Project->Close ( Shift+L). - Close an opened file project.

5.5 The Protocol Menu.
The keyboard shortcut is (Alt+R). The following functions are available from the Protocol menu:

1—~ Protocol->Preview Protocol (Shift+R) - Preview protocol.

L Q Protocol->Save Protocol ( Shift-T) - Save the protocol to disk.

Uaji Protocol->Save Protocol As... - Save the protocol under a new name.

5.6 The Tools Menu.

The keyboard shortcut is (Alt-'-T). The following functions are available from the Tools menu:

1
* 9 Tool->Check order ( Alt+K) - Check sorting oder.
1
* 9 Tool->Sort by time (Alt+I) - Sort catalog records by ascending time.

'^Tool->Convert magnitudes (Alt+N) - Convert magnitudes to common type.

jTool->Remove duplicates (Alt+D) - Check and remove duplicate records.

LTTool->Select (Alt+S) - Select subcatalog.

^7?Tool->Merge (Alt+M) - Merge catalogs .

=1 Tool->Substitute (Alt+U) - Substitute parts of the initial catalog.

•**Tool->Check range (Alt+C) - Check range of parameters.

Tool->Compare catalogs (Alt+L) - Compare two catalogs.

Tool->Draw histograms (Alt-G) - Draw histograms.
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5.7 The Options Menu.
The keyboard shortcut is (Alt-O). The following functions are available from the Protocol menu:
Option->Catalog veiw segment - Change the number of records in a segment on catalog part of main window.
Option->Change Errors page size - Change the maximum error lines on the Errors page of the mane window
protocol frame .
Option->Change Correction page size - Change the maximum number of lines on the Correction page of the
mane window protocol frame .

5.8 The Help Menu.
The keyboard shortcut is (Alt+H). The following functions are available from the Help menu:

VHelp->Content (Fl)
&Help->What'sThis (Shift+ F1)

Help->About - Displays a simple message box about compicat program.
Help->About Qt - Displays a simple message box about Qt C++ tool kit.
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6. Catalog editor.
CompiCat allows the user to edit many-item selections of earthquake catalog entries displayed in
Catalog frame (see 4.2.1 .Catalog Frame ). Fore example, to change a single value in a cell double
click it and enter a new value. The edited values are given in blue, while those recognized as errors are
marked in red. The user cannot enter erroneous values of parameters.

When changing view segment of the catalog CompiCat will suggest saving the changes, if any. The

user may save the current changes or cancel them any time by clicking H» or ^ , respectively (which
buttons are located to the right of Catalog frame).

The key-bindings and buttons which are implemented for editing are as follows:

"• L - Cut the current selection to the clipboard (menu Edit->Cut or keyboard shortcut CtrHX);

J - Copy the current selection to the clipboard (menu Edit->Copy or keyboard shortcut Ctrl+C);

- Paste from the clipboard into the current selection (menu Edit->Paste or keyboard shortcut Cirl+V);
Note: The copy (cut) and paste areas must be of the same size and refer to the same kinds of parameters;

*1 - Delete the current selection (menu Edit->Delete or keyboard shortcut Del);
Note: many-item selections can be deleted at once.

-—J- Insert row before the selected row (menu Edit->Insert row or keyboard shortcut CtrKl)..

Note: a single row can be inserted before selected row and will appear as a copy of selected one;

^*"- Undo edii action (menu Edit->Undo or keyboard shortcut CtrKZ.

~ - Redo edit action (menu Edit->Redo or keyboard shortcut Ctrl+Y.

Undo-redo buffer is unlimited. All corrections made is written into Corrections of protocol (see 9.
Protocol of CompiCat session.).
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7. Tools

7.1 Convert magnitudes.

Catalogs may report magnitudes of different types, which values should be calibrated if used in
calculations together. CompiCat allows the user to make linear conversions of the four magnitudes
reported in a given catalog. To open the window for magnitude conversion (Convert magnitudes) click

button "V-.

Converting magnitudes

Output magnitude; i m4

--Common magnitude: —

? X

Magnitude function: maximum

* f( m l | T : ) if ( m >= [0.1 \ ) then ( m* [<M9 + [-7.96 ) else 0.0 :

K. f( m2 " ) i f ( m >= jo. l ) ) then ( m* [l.O | + [o.O ) else 10.0 j

I f( [m3 • •*[) if ( m > = ["o.O | ) (hen (m* 1.0 l + 0.0 ;)else |o.O J

D f( 'm4 \-r) ) if (m >= [o.O | ) then ( m * Ĵ .O + jo.O | ) else 'o.O '

Reset

0%

OK Cancel

Each of the boxes with magnitudes, e.g., , allows to chose one of the four magnitudes (ml, m2, m3,
m4) reported in the catalog to be used in recalculation.

Output magnitude identifies the magnitude field where the result of the magnitude conversion
described in the block Common magnitude. All the four magnitudes reported in the catalog in process
could participate in the unique determination of the four magnitudes in the output catalog.

The Magnitude function box in Common magnitude allows the four choices - value, maximum,
minimum, average - that determine the unique conversion:

• value - The output value is determined by the priority order of recalculated magnitudes that are
checked in below. The higher rows are of higher priorities.

• maximum - The output value is the maximum of recalculated magnitudes that are checked in
below.

• minimum - The output value is the minimum of recalculated magnitudes that are checked in
below.

• average - The output value is the average of recalculated magnitudes that are checked in below.
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The user can introduce up to four recalculated magnitudes to be used to derive the converted,
presumably, calibrated value by clicking with the left-mouse button the appropriate check-boxes Don
the left. To avoid using the magnitude function f(m) in the absence of input magnitude determination
you can adjust the values in the leftmost and rightmost edit boxes to a desired magnitude cutoff and
output constant, respectively. In the presence of input magnitude determination (i.e., when input
magnitude equals to or is above magnitude cutoff) the recalculated value equals to the linear function,
which coefficients should be typed in the two appropriate edit boxes.

By clicking the Default button the user sets the default values of the Tool. By clicking the Reset button
the user can remove all the changes introduced after entering the Tool window. (Note that Reset button
during the first usage of the Tool is equivalent to the default values.)

7.2 Remove duplicates.

Catalogs may have duplicate entries referring to the same events. CompiCat allows the user to make
search for duplicates and either to delete or to leave intact the candidates for being duplicate entries
reported in a given catalog. To open the window for duplicate removal {Remove duplicates) click

button -i—'.

Remove duplicates

Proximity limits: [ criterion far autpremovaI:

Proximity limits: —

Time: |l20 j y j Latitude: (a5^_J Longitude: |o.5J ! Depth: [lOO fy j Magnitude: j 9.0

Common magnitude:

Magnitude function: | value

1 f( |ml

m2

' ) if (m >- 0.0 i )thsn (m * 1.0 + 0.0 ) else 0.0

, ) if ( m >= [oo j ) then ( m * [Tci 1 + ftxa | ) else |0.0

I f ( rrt3 _[^J ) if ( m >= [o.O J ) then ( m * [ U) J + |o,O j ) else [op

* f ( |m4 " ) i f ( m > = 0 , 0 j ) then(m* ;i.O j + 0.0 | ) else 0.0

Default

Help Apply

The Proximity limits tab of Remove duplicates window allows setting the limits of the temporal,
location, and magnitude differences to be use in duplicate search. Specifically, the two catalog entries



are considered candidates for being duplicates if all the differences are less than or equal to the selected
values in the five Proximity limits boxes. Note the difference in magnitude is related to the Common
magnitude, which definition could be adjusted by the user in the same way as Common magnitude from
7.1 Converting magnitudes

Remove duplicates

Proximity limits: J Criterion for autoremoval:

Duplfcate removal:-

O Automatic • Interactive

Remove by magnitude: value greater

Priority: <-Then by order: —~ m

• first _ second

FOLnd so far: 2 Remove record <6> by magnitude: "vaiue greatEr" > <6>:7.50; <7>:8.50

6

7

Leave

1942

•1

M |

10

s
•

D i

21

9

•

0

B

m | s

22

Bl
0

Lat Lon

32.97 -116

24%

Dep |

0

•
M l

7.5

M

M2

0

•
M3

0

B

M4 |

0

Bl
•
0

B

#

Leave intact

. Next j

Help Apply OK

The tab Criterion for auto removal allows switching the program from Interactive to Automatic
removal of duplicate entries by choosing the appropriate radio-button in the Duplicate removal section.
Moreover, in the Automatic mode the user has an option to define the rule of unique identification and
removal of catalog entries. Specifically, the user defines the criterion for choosing one of the two
candidate entries by magnitude and, in case of the equality, by their order (the program simply removes
either first or second entry marked with the appropriate radio-button). The magnitude value greater (or
value less) indicates higher priority for the entry to remain in the output catalog; in these cases, the
choice of magnitudes in the checked boxes Don the left define the priority for the unique magnitude
determination. Each of the magnitude indices maximum greater, maximum less, minimum greater,
minimum less, average greater, average less applied to the checked magnitudes defines higher priority
for the entry to remain in the output catalog.



In the Interactive mode the user has an option to follow the automatic suggestion, or to chose the
alternative entry, or leave both entries intact. The two candidates for removal are shown in the lower
part of either Proximity limits and Criterion for autoremoval tabs. The button Next confirms the choice
and proceed to the next candidates for duplicate removal.

The button Apply confirms the choice from the Proximity limits and Criterion for autoremoval tabs and
runs duplicate removal procedure.

The button OK confirms the choices already made in the Interactive mode and, from this very point,
continues duplicate removal procedure in the Automatic mode. The button OK is also used to accept all
the results of the Tool. To rerun duplicate removal anew without saving the current results the user can
change some of the Tool parameters and click the button Apply.

The button Cancel is used to cancel all the actions performed by the Tool earlier and closes the Remove
duplicates window.

By clicking the Default button the user sets the default values of the Tool. By clicking the Reset button
the user can remove all the changes introduced after entering the Tool window. (Note that Reset button
during the first usage of the Tool is equivalent to the default values.)
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7.3 Select subcatalog.
Working with the entire catalog, a large or humongous one, in particular, may appear inconvenient

and/or time consuming. CompiCat allows the user to make searches from a given catalog and to create
its subcatalog(s). The program may perform different kinds of selection of earthquakes by time, record
number, geographic location, depth, magnitudes (or their linear function), and intensity. To open the

window for subcatalog search {Select subcatalog) click button U". The window has the four tabs. To
activate searches by parameters listed in the tab, the user must check on the box d i n its upper leftmost
comer.

Select su be dialog

Date or number [ Rypocenter , Mayiitudtes

H 4 DatETime \ Number

-Date:

Intensity

1984/01/23 05:40:19

Date: from [ 1984/01/23 05:40:19 j j ] to [l989/10/18 10:04:15 |-y

2001AW10 20:19:00

Reset

Process completed: 91 records selected.

The Tab By date or number allows the user to set the limits either for the time period or for the segment
of consecutive record numbers by checking the appropriate radio button.
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Select subcatalog

Date or number Hypocenter . Majtiftjdtes Intensity ;

X • Rectangle ' Crete 0 Polygon

Latitude:

Laiqitucte:

Pom

fr3Ti

-90.0

-180.0

j t o

• d

90,0

U80.0 LJ Across longitude 180

Latitude: Longitude j

X DepSiifrcm ;0,0 to 999.0

I Reset

Process consisted: 51 records selected.

The Tab Hypocenter allows the user to set the location limits. There are several options each associated
with a choice of the three radio buttons and/or interval of depths. The Rectangle, Circle, and Depth
sections are rather self-explanatory' and fool-tolerant, while the Polygon one needs a few explanations.

CompiCat can select earthquakes with epicenter coordinates inside any simply connected polygon,
which vertices must be listed in the clockwise order. Click Set Vertices button to open Set Polygon
Vertices window.

1

2

L*

3?

37.75

36.2

Lon { *
-IZZ.S

-121.5 •.

-120.5

L
,

OK

Cetxt'

he(p

_J Across longitude 180

Check on Polygon crosses 180, if the vertices are located on both sides of the 180th meridian and fill in
the desired coordinates of the polygon vertices. If needed, select any row then invoke the context menu
by clicking the right mouse button on the selected row
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Delete

Insert row

Del

Ctri+I

and complete insertion or deletion. (The user can also use the standard hot keys Del to delete a row
and Ctrl+I to insert one.)

Select subcdtafoe

Date or number J Hypacenter Magriitudies . Intensity

JC; * Range 0 Commcr magnitude

M
;M

D
D

•nl from 5 0

m2 Tom ' 3.0

m3from 0.0

m4from [0.0

|ta

J t o

tD

tD

9.0

N
9.0

5.3

Magnitude ftrcttn: [saiue

Z) f ( I .-rl |-v ) if ( n >- |." '. | ) than ( m • [~J -

\3 f { [m2 | T | ) if ( n >- L J) Shen (rn '

13 f ( !n i I ' j ) if < m '--= { I }thsn (m *

3 f f |rM I'l | f im >= fc | ) tren (rr. * f "1 -
i, nj i • ( j ^ . ;

. . h else |

etee[0£]

Ceise

Resstj

Process completed: 91 records seiectEd.

The Tab Magnitude allows the user to set the limits either for any set of checked magnitudes or for the
the common magnitude range by checking either Range or Common magnitude radio button. (For
details on definition of the common magnitude, see 7.1 Convert magnitudes.)
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Select subcataloa

Date or number j Hypocenter Magiitudies Intensity

i t Intensity: (ram D ~~ to J12

Reset Default

Process completed: 51 recor-fe seiectEd.

He*, Apply etc i C: eel

The Tab Intensity allows the user to set the limits on the reported intensity of an earthquake.

The button Apply confirms the choice of parameters from all activated Select subcatalog tabs and runs
the requested search.

The button OK accepts all the results of the Tool. To rerun Select subcatalog anew without saving the
current results the user can change some of the Tool parameters and click the button Apply.

The button Cancel is used to cancel all the actions performed by the Tool earlier and closes the
window.

By clicking the Default button the user sets the default values of the Tool. By clicking the Reset button
the user can remove all the changes introduced after entering the Tool window. (Note that Reset button
during the first usage of the Tool is equivalent to the default values.)
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7.4 Merge catalogs.

Catalog compilation may require merging data from different source catalogs. CompiCat allows the
user to merge the records of the catalog in work (called Initial) with those from a number of additional
source catalogs. When being merged into Initial catalog the Catalog add-ins pass through automatic
identification and removal of duplicates according to the user defined choice of Proximity limits.

To open the window for duplicate removal (Merge catalogs) click button

Merge catalogs ? X

Merged Catatog(s):

Catalog add-tis: -

Proxfrity Irrtts:

-Info:

- Initial catalog

Catalog: "4lDouble.ct"

First record: 1934/12/30 13:52: 0.00

Last record: 1987/12/ 1 1: 1: 0.00

Records: 26

-Additional catalog; —

Catalog: "Firstct"

Rrst record: 1934/12/30 13:52: 0.00

Last record: 1987/12/ 1 1: 1: 0.00

Records: 11

Reset |

Doubles (32 ) have ftxnd. Process of identification of dottles is completed.

If Catalog add-ins list is empty or its content would not be used in merge, click Browse button, browse
the directories on your computer for the catalog add-ins to Initial catalog and open one or several of
them in any order. To add one by one more add-ins to the existing Catalog add-ins list from any
directory use Insert button. Other buttons - Delete, Down, Up - permit to manage the list. Note that the
order of the add-ins defines the priority in automatic duplicate removal during the catalog merge: the
higher is the file position in the list the higher priority has its record in duplicate removal.
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Merge catalogs

Merged Catabg(s): Proximity imits:

Proximity Imits:

Tme: [ l |-y1 Latitude: jo.01 J Longitude: JQ.Ol ~~) Depth: | l -~j Magnitude: [Lu

Common magnitude:

Magnitude function: | value

f ( [mlj - ] ) if ( m >- [go ~ ) then ( m * [l.O _ ] + |o.o ""] ) else foIT

f ( [m2v*j ) if Cm >= [o.O i ) then (m * [io_ J jo.0

f( m3 | ^ \ ) if ( m > • |0,0 J ) then ( m * JJLO_ __ + J0.O_

|0.0

] ) else

1) eke

jm4|T] ) if (m >= [O.O ) then ( m * jl.O ) else jo IT

-

Reset

Doubles ( 32) have found. Process of identification of doubles is completed.

-PPV OK

Default

The content of Proximity limits tab window of Merge catalogs tool is the same as of Remove
duplicates.

Note that Merge catalogs tool PERFORMS AUTOMATIC removal of duplicates. For a finer
identification of duplicates the user may wish, first, to make merge with extremely restrictive Proximity
limits, then process the result with Remove duplicates tool .

The button Apply confirms the choice from the Catalogs and Proximity limits tabs and runs merge
procedure. To rerun merge anew without saving the current results the user can change some of the
Tool parameters and click the button Apply.

The button OK is used to accept all the results of the Tool.

The button Cancel is used to cancel all the actions performed by the Tool earlier and closes its window.

By clicking the Default button the user sets the default values of the Tool. By clicking the Reset button
the user can remove all the changes introduced after entering the Tool window. (Note that Reset button
during the first usage of the Tool is equivalent to the default values.)
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7.5 Substitute catalog parts.
Catalog compilation may require addition and/or substitution some parts of data from different source
catalogs. CompiCat allows the user to upgrade the catalog in work (called Initial) with data from a
number of additional source catalogs (called Catalog add-ins). The Substitute tool may seem rather
similar to Merge catalogs tool although the rules for merging the data from different sources are quite
different. Contrary to Merge catalogs tool, the Catalog add-ins have higher priority than Initial catalog
- all the records of the initial catalog that fall within any of the time spans of all add-ins will not appear
in the resulting output catalog being substituted with data from add-ins. Specifically, Substitute starts
with the uppermost add-in from the list, determines its time span from the first to the last record, and
substitutes all the data from the initial catalog from this time span with all data of the add-in (note that
depending on the initial catalog time coverage and the add-in time span, the add-in data would either
prepend or insert or replace or append records to the initial catalog). Turning to the next add-in, if any,
Substitute considers the result of the previous step as the initial catalog and proceeds with the current
add-in. Finally, step by step Substitute comes to the last add-in and completes the task. Note that the
order in in Catalog add-ins list defines the ascending add-in priority, according to which the records
from the last add-in, evidently, will all be present in the output catalog.

To open the window for duplicate removal (Merge catalogs) click button

Substitute catalogs

-Catalog add-ins:-

Infb;-

- Initial catalog:

Catalog: "caWom.csf

first record: 1932/ 1/ 3 17:57: 0.00

Last record: 1985/ 6/29 18:23: 0,00

Records: 19668

Add-ii catalog:

Catalog: "secong.csf"

First record: 1980/ 1/ 3 3:37: 0.00

Last record: 1980/ 1/ 3 22: 6: 0.00

Records: 17

; Reset I ; DefaJt

Resiit; Time: (1932/ 1/ 3 17:57: 0.00 ) - ( 1987/12/ 1 1: 1: G.00 ) Records: 732

_Heb_J | Apply j OK~" Cancel

If Catalog add-ins list is empty or its content would not be used, click Browse button, browse the
directories on your computer for the catalog add-ins to Initial catalog and open one or several of them
in any order. To add one by one more add-ins to the existing Catalog add-ins list from any directory
use Insert button. Other buttons - Delete, Down, Up - permit to manage the list.

31



The button Apply confirms the choice of the Initial catalog and Catalog ins list and runs Substitute
procedure. To rerun the procedure anew without saving the current results the user can change Catalog
ins list and click the button Apply.

The button OK is used to accept all the results of the Tool.

The button Cancel is used to cancel all the actions performed by the Tool earlier and closes its window.

By clicking the Default burton the user sets the default values of the Tool. By clicking the Reset button
the user can remove all the changes introduced after entering the Tool window. (Note that Reset button
during the first usage of the Tool is equivalent to the default values.)

7.6 Compare catalogs.
CompiCat allows the user to compare the initial catalog with the reference one and determine their
intersection or difference and catalog of equivalent pairs or nonequivalent events. The tool makes use
of the definition of equivalent events set up by the user defined Proximity limits.

To open the Compare catalogs tool window click button ^ 3

Compare catalogs

Catalogs | Prcwrtiity frntts

Reference catalog: ,-Info;-

Initial catalog

Catalog: "ex6merged.csf

Frst record: 2007/ 1/ 3 13:14:19.40

Last record: 2007/ 7/15 16:36:52.25

Records: 52

--Reference catalog: —

Catalog: "ex6rttial.csf"

Frst record: 2007/ 1/ 3 13:14:19,40

Last record; 2007/ 7/15 16:36:52.25

Records: 46

Apply • > : Cancel !

The Catalogs tab allows to chose Reference catalog for the comparison with Initial catalog along with
the method of this comparison.
Click Browse button, browse the directories on your computer for the reference catalog, and open it.



The two catalogs could be compared by Intersection, Difference, Equivalence, and Noneqitivalence.
• Intersection mode selects all events from Initial catalog that have equivalent in

Reference catalog.
• Difference mode selects all events from Initial catalog that have no equivalent in

Reference catalog.
• Equivalence mode creates the catalog of groups of equivalent events from Initial catalog

and Reference catalog.
• Nonequivalence mode selects all events from either catalogs that do not appear in groups

of equivalent events.
The resulting catalogs could be Exported in the standard 68-bytes ASCII format. In case of Equivalence
and Nonequivalence modes the records from Initial catalog and Reference catalog are marked
respectively with 1 and 2 in the field of Intensity (which original content is lost after completion of
Compare catalogs).

Compare catalogs

Catalogs J Proximity knits |

Proximity frrtts: — — —

Time: W^~ Latitude: Jo.25 Longitude: J0.25 j Depth: jio ^ Magnitude: T o "

Common magnitude:

Magitudefunction: lvalue

Z f ( ml - )if (m >' JO.O

D f ( ''m2~jV{ ) i f ( m >= (ocT

|o.of ( m3 V ) i f ( m >

f ( ;m4 ~' ) if ( m >

) t h e n ( m * ji.O

) then (m * [To

) t h e n ( m *

) then ( m * jl.O

I Reset |
1 i 1

fixnd 45 duplicates. Identification compited.

The content of Proximity limits tab window of Compare catalogs tool is the same as of Remove
duplicates. By definition, the two events, one from Initial catalog and another one from Reference
catalog, are equivalent, if all the differences are less than or equal to the selected values in the five
Proximity limits boxes. (Note that CompiCat program presumes no equivalent events in Initial catalog.
Therefore, a record from the initial catalog may have several equivalent records in the reference
catalog, while a record from the reference catalog may have no more than 1 equivalent in the initial
catalog.)
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The button Apply confirms the choice from the Catalogs and Proximity limits tabs and runs the selected
procedure. To rerun Compare catalogs anew without saving the current results the user can change
some of the Tool parameters and click the button Apply.

The button OK is used to accept all the results of the Tool.

The button Cancel is used to cancel all the actions performed by the Tool earlier and closes its window.

By clicking the Default button the user sets the default values of the Tool. By clicking the Reset button
the user can remove all the changes introduced after entering the Tool window. (Note that Reset button
during the first usage of the Tool is equivalent to the default values.)

7.7 Check specified ranges.
Catalogs may have records that were put in by mistake from irrelevant sources or are erroneous though
their parameters being quite acceptable. CompiCat allows the user to search for the records that fall
outside the user defined ranges of the parameters and, if needed, to correct those that appear the first
records (with up to 200 misfits).
To open the window for checking the specified ranges {Check ranges) click button .

Check specified ranges

have been ftxnd h 1 records.
In total 53 records have been checked.

[-Range Lint

43 <= Latitude < =

5 <= Longitude < =

-10.0 ] <= Depth < =

jo.o

0.0

0.0

<= Ml <=

<= M2 < =

<=M3< =

[0.0 J J <= M4 < =

Reset

2 values of parameters out of range

50 [

1 5 •

9999.9

9.0

9.0

9.0 i

9.0

H *

j Default ,

Apply

If needed, change any content of the boxes for the preferred limits.
The button Apply confirms the choice of the ranges and runs Check ranges procedure. To rerun Check
ranges anew without saving the current results the user can change some of the Tool parameters and
click the button Apply again. The statistics of the run, i.e., the total number of misfits of the ranges
along with the number of the corresponding records, appear on top progress bar.

To accept the results of the Tool click OK. The tool completes Check ranges procedure with (i) the
report to Messages tab page the list of user defined ranges and the total number of misfits of the ranges
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along with the number of the corresponding records and (ii) the listing in Errors tab page of the
references to the first records with misfits (up to 200 misfits, 25 by default). To change the number of
misfits to report use Options->Error page size (see 5.7 Option menu ).

ex9initial.csf - Compilation Catalog Panel
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Description

fcxnd.

Latitude (Lat) is out of range: value -8.46 , range [ 43

Longitude (Lon) is out of range:
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To correct the records with misfits follow instructions described in 4.2.3 Protocol frame.

The button Cancel is used to cancel all the actions performed by the Tool earlier and closes its window.

By clicking the Default button the user sets the default values of the Tool. By clicking the Reset button
the user can remove all the changes introduced after entering the Tool window. (Note that Reset button
during the first usage of the Tool is equivalent to the default values.)

7.8 Draw histograms.
CompiCat allows the user to display graphically different kinds of tables associated with the catalog in
work. The graphical output could be a traditional (i.e. 1-D), as well as a 2-D histogram. Moreover, the
tool permits producing a series of histograms, which display slices of the frequencies considered by an
additional parameter, and, therefore, represent either a 2-D or 3-D histogram. Besides frequencies,
which is the default option, CompiCat may display maps of some other catalog integrals (like sum of
energies etc) denoted as Intensity. The tool may export output tables as comma separated values (the
Microsoft Excel CSV format), as well as print and make PDF of the display.

To activate Draw histograms tool click button JBU. By default, CompiCat displays the 2-D histogram of
the earthquake frequencies on the longitude-latitude plane.
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5ex10southCA.tsf - Draw Histogram Panel

Frequences of earthquakes.
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The 2-D histogram displays frequencies as color coded cells, which size could be adjusted by changing
the Number of intervals (from 10 to 150) and the min and max limits attributed to X and Y axes. The
associated colors of Intensity scale are shown on the right side of the histogram. The user may change
the X and Y axes to time (in years), latitude, longitude, depth, and any of the four magnitudes. To

confirm the choice and redraw 2-D histogram, click button I
The button allows the user to zoom on an area of interest in a 2-D histogram. Toggle the button,
bring the cursor on the histogram plate, outline the area of interest by pressing the left mouse button
and dragging the cursor. (With the left mouse button pressed at any place of the histogram plate the
program displays the cursor XY coordinates. Clicking the right mouse button will zoom out the display
one step back . Zooming can operated as often as possible.)

The button -^-allows the user to switch Intensity scale from linear to logarithmic one. To switch scales
toggle the button and redraw histogram.

To display a traditional 1-D histogram either for X- or Y-axis click either button ]Hl or S33,
respectively. Traditional histograms displays frequencies as bars of different heights.
The user may wish mapping catalog integrals that differ from the default frequencies. CompiCat
provides making a choice between sums of earthquake energy, area, and length, as well as the user
defined 10a*mb weights (where a and b are arbitrary constants, and m is the earthquake magnitude).
These quantities permit better understanding of of the energy release, or the area ruptured, or the total
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length of ruptures in the area of interest. To specify weights open Weight tab on the left; click on radio
button and make the choice of weights.

Weight

iff

AxfcX

* on

Settings.
Type: | Energy

Magnitude: ;ml

a: lxi.8

b: .1.5

: off

j

To produce series of histograms toggle Invoke by List button .. Make the choice of an additional
parameter, Number of intervals (from 2 to 20), and the min and max limits to be used. Toggle button
Switch image scale to specify either a common or interval dependent normalized scales of intensity.
Click either of Redraw buttons to display a series of 1-D or 2-D histograms. Click or button to display
the previous or the next histogram in a series.

If needed, invoke help text on buttons by clicking • . , then click a button to get the appropriate quick
help on it.

™ opens the dialog for printout. (Note that a histogram image can be saved in the PostScript
format by using print to file option.)

h. saves a histogram image as a PDF file

lz~lsaves a histogram table as a Comma Separated Values (CSV) Microsoft Excel file. Note
that there might be a problem in reading CSV format files due to Regional Options and
Microsoft Excel International Options (see Appendix C. Platform Notes).

Click Ok button to leave Draw histograms window. CompiCat saves Number of intervals for each of
the X, Y, and additional axes.
Click Cancel to leave window with no save.



8. Project

8.1 Managing Projects.
When using CompiCat on routine basis the user may wish repeating the same or similar sequences of
tasks. This is of special importance when reproducing the results of compilation achieved in the past.
CompiCat allows the user to create project files that specify sequences of operations performed with
seismic catalogs. This could be done with the project wizard, which invokes when the user opens either
New project or an existing project for editing (Edit project). The project wizard allows the user to
define a project file as a sequence of catalog operations for implementation in the future. Any single
sequence may include the following tasks in any order although without a repetition:

1. Check specified ranges
2. Convert magnitudes
3. Remove duplicates
4. Select subcatalog
5. Merge catalogs
6. Substitute catalogs
7. Compare catalogs

Note that tasks /. Check specified ranges and 7. Compare catalogs define a single sequence by
themselves and could not be combined in one project with tasks 2-6.

The following buttons and menu entries (ordered as they appear on the upper Tool bar) facilitate
managing of the projects:

ITTJ

' generates a new project (optional entries Menu item Project->Ne\v Project or keyboard shortcut ShifHN)

Ej?opens an existing project (optional entries Menu item Project->Open Project or keyboard shortcut Shift+O).

"Ls'edits an opened project (optional entries Menu item Project->Edit Project or keyboard shortcut Shift+E).

^'executes the project task list (optional entries Menu item Project->Execute Project or keyboard shortcut Shift+P).

Brsaves the project file to disk (optional entries Menu item Project->Save Project or keyboard shortcut Shift+S).

-firsaves the project file under a new name (optional entries Menu item Project->Save Project As ...)•

"fc'closes the project without saving (optional entries Menu item Project->Close project or keyboard shortcut Shift+L).

Menu item Project lists the most recent project files, which could be loaded easily.

The project file names have extension '.pro' or '.PRO' as a CompiCat standard added automatically
when you save project files.
In case, some of the catalogs listed in the project files are not found, the user is given automatically an
opportunity to fix the problem (see 8.3 Repairing Project).
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8.2 Project Wizard.

The project wizard allows the user to define a project file as a sequence of catalog operations for
implementation in the future. Its window appears when the user generates a new project (e.g., by

clicking button - ") or opens for editing an existing project file (e.g.,. by clicking \s'). An example of
Project wizard window for the existing project file is given below.

Initial Catalog:

californ.csf

Tasks:- -

Parameters of Tasks:

;#• Currency defined Defadt

v 2u C n e ck specked ranges

* . Optional Tasks: List of Tasks:

$r Convert magnftudes
3 Remove dupicates

Select subcatalog
Merge catalogs
Substitute catalogs

| Compare catalogs

I Help Cancel Next-> Rresh

The window consists of the two frames - Initial Catalog and Parameters of Tasks - on the top and a
larger Tasks frame below.
To change Initial Catalog for different one Browse computer directories and select a csf formatted
catalog.
The Parameters of Tasks could be set either to Default values or to Currently defined ones, those in
progress before Project wizard has been invoked. The Currently defined'values of parameters can be
obtained by opening some previously saved project file or by working out the tasks parameters anew,
without reference to any project.
Tasks frame lists on the left the five Optional tasks along with Check specified ranges and Compare
catalogs, low. The user defines the tasks by toggling one of the three radio buttons, adding (Add ->) a
selected task to the List of Tasks, deleting (<- Del) a selected task from the List of Tasks, and by using
Up and Down burtons for setting the desired order of tasks.

Reset burton removes all the changes made after invoking Project wizard. Project button reloads the
initial project parameters. Default button sets default project parameters. In case of a new project,
clicking any of the three burtons would lead to the same (Default) values.
Clicking Next-> button invokes one by one, from the first to the last, the current task tool window for
setting the desired parameters. (For details of the tools see the appropriate chapter in 7. Tools.) At any
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moment of time the user can return to the previous task tool window by clicking <-Back button or exit
Project wizard without changes by clicking Cancel button. After setting the last task parameters click
Finish button (i) to complete formation of the project, (ii) to close Project wizard, and (iii) to put the
brief info into the project frame of the CompiCat main window.

After formation of the project the user can execute the project by clicking LObutton and save (i) the

project file by clicking -fir, (ii) project output catalog by clicking t-3, (iii) project protocol by clicking

El, etc.

8.3 Repairing Projects.
It may happen that the files mentioned in the project have changed their placement. Such a situation is
in common when changing computer or computer disk structure. In such a case, when opening the
project file CompiCat will find out the problem automatically and will suggest to repair the project
with the following comment - "Some input files do not exist. Try fixing the problem?" If the user

agrees, the following window of Repair Project Dialog opens with the files in absence marked by ^ .

Repair Project Dialog

Tasks

- Pro:?:t:
3 C/Dooxnents and Settinqs/sasha/ecp/exafnples/pfoiect/proiect.pfo

-. Cataoq:
.1 C r:q-nents and Settincg/sasha/ecp/examples/catfixn.csf

3 Tasks:
~~\ Remove dujlicates

- S', N*grqe cata oqs
I1, C:/Documents and Settnqs/sasha/ecp/examples/secong.csf
2 C:/DoQjments and Settnqs/sasha/ecp/exa^^Jgs/first.csf

C:/Documents and Settnqs/sasha/ecp/exSTipias/third.csf
i |C:/Drxjments and Settinas/sasha/ecp/examples/fourth.csf
Select subcatabq

^ i';q Subs: • te catalogs
3 C:/Documents and Settriqs/sasha/ecp/exanxtes/ai3stitute3.csf
J C./Documents and Set'.nqs/sasha/ecp/e-iamples/substitutel.csf

C'DccLr-ents v J Set: -as/sasha/ecp/e>i-nptes/subft '^,:e2.csf
Convertinq maqnitudgs

OK Cancel

to invoke open file button 3t\ find new location and select the file, which

full path reference will appear in blue marked by ^ . (Each correction in blue can be changed in the
same way as the marked ones.). After fixing the problem click OK to accept repaired file names of the
project file.
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9. Protocol of CompiCat session.
Each time CompiCat opens an initial catalog or a project a new session opens. For each session
CompiCat generates the protocol, i.e., the comprehensive info about all tasks performed. The protocol
has the three pages associated with tabs of the protocol frame. Specifically, Massages page that
contains info about project (if any), input-output catalogs, tools and their parameters and Corrections
page that contains info about editing, details on tasks and tools, and their applications. The third page of
the protocol frame contains temporary info on Errors to be fixed, w:hich corrections when made appear
in Corrections page.

Project Messages:

Project Fie: Cyprogram Fles/Earf-quake Catalog Processirg/ecp/exercses/exl2-p<-oject-coTp.pro

Initial catalog 'ex ianMcsf has 46 records from 2007/ 1/ 3 13:14 19.40 :o 2037/ 7/15 16:36:52.25

** * Task: Merge catalogs ;<**

Current:catalog has 46 records from 2007/ 1/3 13:11:19.^ :o 20O7'7/:5 16-36:52.25

^stacid-ns files:
1: "exl2-merge-l-cs-"" has 3 records f-cm 2CO7/ 7/12 0- 9:32.90 to 2007/ 7/15 16:35:52.25

2: "exl2-merge-2.csf has 6 records Tom 2007/6/27 21:2?: 2.10 tc 2007/ 5/30 :2. 7:29.C0

Data thresholcs: T-ne: 5C ; _antuos: 0.50 ; Longffixle C.50 ; Deptn: 10 ;

Fouid 3 duplicates. Identricabxi compited,

Output catalog nas 52 records f-o-n 2037/ 1/ 3 13.14: -.9.40 to 2007/ 7/:5 15:36.52.25

** * End of Task: : Merge catalogs **x

i Errors « Messages O Corrections

2. Mergrg cjrrer: arid

Current catalog has 47 records from 2007/ 1/ 3 :3 :4 19.4C tc 2007/ 7/15 15:35 52.25

Adcki cataba "ex:2-me^ge-2.csf" nss 5 records frorr 2007/ 6/27 21:27: 2.10 tc 2007/ 6/30 12:
7:29 00

Fotxid 1 cJupfcates. Identfication cotpited.
1 :> 1: 40- 20076 286 326 45.75 10.62 2.6 3.3 00 0 0
1 :> 2: 3 - 2007 5 28 6 32 5 45.75 1C.62 2.6 3 C 3 3 3.1 2

Output cataiog has 52 records from 2037/ : / 3 13:14:19.43 to 2X7/ 7/:5 16:36:52.25

*** ^d o f T s s k . rj^-ge catalc.35 **x

*'** Task: SuDsctLte catalogs ***

Catabg r process Catalog n process has 52 reccrds from 2CO7' 1/ 3 13:14:29.40 to 2007/ 7/15
15:3652.25

Errors « Messages V Corrections
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The user can manage the protocol by invoking the following buttons:

— - preview protocol ( menu Options->Preview Protocol; keyboard shortcut
Shift-̂ P ) - opens text editor window with the content of Messages and Corrections;

click LJbutton to save protocol as an ASCII text file.

-C3 - save the protocol as an ASCII text file ( menu Options->Save Protocol;
keyboard shortcut Shift+S)

X3 - save the protocol as an ASCII text file under a new name ( menu Options->Save
Protocol As...)

The standard extension name for protocol ASCII text file is *.protocol added automatically.

10. Help Online.
CompiCat program provides online help with three levels of detail:

1. Tool Tips and Status Tips.

Tool Tips is extremely brief help that appears when cursor is hanging over a toolbar button for
a certain period of time. Tool Tips are given in black on yellow. Status Tips provide a short
piece of descriptive text, a little longer then a tool tip. When the mouse hangs over a toolbar
button, a status tip appears in the Status bar.

2. What's This? provides a single window with an explanatory text that pops up when the user asks

"What's this?" When you push button " ( o r push keyboard buttons Shift - Fl) the cursor changed

to and you can click on any toolbar button to obtain help text on it.

3. Online Help is provided by help browser. CompiCat program have Content entry in the Help menu
and Help buttons in all other windows. Click Content of Help menu (or keyboard button Fl) to open
HTML-based program manual.

y^ Pfoftritl edtat - i telpvif-wcT - to

10. Help Online.
I an* * -, D » « ronin „ * » Mto «*h t r ,« I *** of * . a j :

I Tool I*» and Status Tijrt

Tool Tipi is ei^a-^y trtS•'*& Chat ap^eJ-J •fiv ZXKT *•_ -.*rqrq over A b .£•» tijlt
T*» * * avwi r Ha:*- w> * nl^f. Statue 1 %n c^vos i ireft 3»ce tf ddi'BOvt te«.
tfie reuse hdnp :\w s *o3b*r button a rt sr_ri 'c t; ct rrj r- :1s Stat L« bar.

2 What's Thn' [W#tw • Wjh i iruim •

^W(irixshkfi>r)c«dtputtiDm5hP: -F l j l h

•-jiL-m p

th ai ê  p^nsco-v i f ^i thai pop* \o "he'i '.he u«r

e cusot ^dnjiC :^ a"d r*J can cfct- on »ry

^Fl]tDoper KlM-tiwedptoo'anr-iS-ua liaehr

x\ fo a ce'!4r ;*?r»d cf t>rw. Tool
3 Uĉ s onger the- a coo : t . HTtsr

cwtw button t ; Dttsn ht.-p t=j.[ =r t.

HL and ^*ft tuttnni m al ether f*nfo«s.
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Menu entries and tool bar of the help browser:

View menu:

^•* View->Print (Cntrl P) - print current HTML page.

t 'S View->Zoom in (Cntrl—) - Increase the display font size.

^ \ View->Zoom in (Cntrl+-) - Decrease the display font size

W View->Exit (Ctrl-Q) - Exit the application.
Go menu:

^Go^Backward (Alt -*- Left Arrow) - Go back one page.
•^Go^Forward (Alt + Right Arrow) - Go forward one page.
uK}o->Home (Alt - Home) - Go program contents page.

Help menu:
Help->About - Displays a simple message box about Help Browser program.
Help->About Qt - Displays a simple message box about Qt C++ tool kit.

Bookmarks menu:
Bookmakrks->Add Bookmark (Cntrl++A) - Add Bookmark.
Bookmakrks->Manage Bookmarks ... (Cntrl++M) - Manage Bookmarks.
List of chosen bookmarks.

Manage Bookmarks:
Click this menu item to manage bookmarks and following the dialog window will appear:

" Manage Bookmarks

Compfcat Pro-am:: Table of Contents
Compicat Pro-am: The Options Menu
Cowwcaf Pi oar am: Tne Fte Tods*
Compicat Program: StisKute subcataiog

OK

Click Up, Down buttons to change the position of bookmarks. Click Del button to remove one, click
Del All to cleare bookmarks list.
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Appendix A. The ECP standard formats for earthquake data, program project,
and protocol.

1. Earthquake catalog format.

The standard format specifies -
- the origin time, i.e., year, month, day, hour, minute, and second with the accuracy of one hundredth,
- the latitude and longitude in degrees with the accuracy of one thousandth,
- the depth in km with the accuracy of one tenth,
- the four magnitudes (presumably mb, ms, ml, m2) with the accuracy of one hundredth, and
- the macroseismic intensity (presumably, Modified Mercalli Intensity; 0 - no data, 1-12).

CompiCat program supports the Gregorian calendar. This calendar was adopted by England from
September 14, 1752. The valid year range is [0, 8000]. The standard ranges of other parameters are as
follows - latitude [-90, 90], longitude [-180. 180], depth [-10, 999], magnitudes [-10, 10], intensity [0,
12].
CompiCat program checks the ranges of parameters each time you edit catalog and set parameters for
catalog operations. Therefore, you cannot type in the value which is outside the standard range.

2. Project format.
CompiCat program creates the binary project file to be used for a repetition of the compiled catalog

in the future. See 8.1 Managing Projects.

3. Protocol file.
CompiCat program creates automatically the protocol job file, which lists information about even-

step and decision you make when compiling the catalog. See Protocol of a session.

Earthquake catalogs (in the ECP standard format) and CompiCat project files are binary files of
encoded information, which is compatible with the package running under MS Windows and LINUX.
Thus, for example, a catalog compiled on a PC under MS Windows can be used for further runs of the
package installed on a PC under LINUX. CompiCat project files are compatible with the package
running under UNIX (e.g., a Sun SPARC station under Solaris).
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Appendix B. How to register a new format as supported?
CompiCat program helps to upgrade the list of supported earthquake catalog formats, so that only a

few lines of description are needed to access earthquake catalog data in a text format.
CompiCat program generates formats from the information listed the file named siandardformatMst

located in the subdirectory Install Directory/ecp/ref ( see Installation Notes )

To register a new format in the list of supported put an additional block of description at the end of
the standardformat.list file. Each block should start and end with a line of minus characters, which
embrace the description. Each line of description starts with one of the following locators - TITLE,
URL, REF, TIME, LAT, LON, DEP, Ml, M2, M3, M4, INTEN, SKIP, REM (note that some of the
locators like URL, REF, REM could be not necessary). A locator may have parameters listed in the
brackets. Usually, these indicate the starting position of the value followed by the string of its format.
For example, TIME(1,YYYY/MM/DD HH:mm:SS.ss) indicates that the origin time is given in
positions 1-22, DEP(34,DDDd) - the string of depth format is DDDd, SKIP(1,!GS) - each record that
starts with GS will not be skipped, etc. The format specifications for each locator are as follows -

TITLE - used by CompiCat to display the format name;

TIME: Y(year), y(fraction of the year), M(month), D(day) or d(day of the year from January 1st),
H(hours), m(minutes), S(seconds), s(fraction of the second);
LAT: D(integer degrees), d(fraction of a degree) or M(minutes.'), m(fraction of a minute) or s(seconds.
"), - or N or S(sign);
LON: D(integer degrees), d(fraction of the degree) or M(minutes, ')> m(fraction of the minute) or
s(seconds,"), - or E or W(sign);
DEP: D(integer including sign if any), d(fraction);
Ml, M2, M3, M4 - D(integer), d(fraction);
INT: one character;
SKIP: If the string starts with "!" character than each record that contains this string at the specified
position will be read or skipped otherwise. Up to ten SKIP lines are allowed;

URL - the web site reference to receive catalogs, not used by the program;
REF - the place for the reference to format description, not used by the program;
REM - remarks, not used by the program.

The following formats are initially supported after installation of CompiCat program -

1. 20 byte - Standard Format - Binary - used in some MITPAN programs.
2. 41 byte - Standard Format - Text - used in some MITPAN programs.
3. swf.txt - Standard Wide Format - Text - text format of internal standard CompiCat binary format.
4. anss - Advanced National Seismic System - URL http://quake.geo.berkeley.edu/anss/catalog-
search.html
5. anss 80-col - Advanced National Seismic System - URL

http^/quake.geo.berkelev.edi^'anss/catalog-search.html
6. pde - NEIC Preliminary Determinations of Epicenters - URLs PDE-monthly -
ftp://ghtftp.cr.usgs.gov/pub/pde;



PDE-weekly and QED -
ftp:, / ghtftp. cr. us gs. go v/pub/weekl v
7. scec - Southern California Earthquake Data Center - URL

http://www.data.scec.org/ftp/catalogs/SCEC DC/
8. scsn - Southern California Seismographic Network - URL

http://www.data.scec.ora^ftp/catalogs/SCSN/
9. hypo71 - Summary hypo71 format year 2000 - URL

http://www.data.scec.org/catalog search/date mag loc.php
10. hds - NEIC Hypocenter Database System - URL VX-format - ftp:/7hazards.cr.usgs.gov/hds

For example:

TITLE pde - NEIC Preliminary Determinations of Epicenters
URL PDE-monthly - ftp://ghtftp.cr.usgs.gov/pub/pde
URL PDE-weekly and QED - ftp://ghtftp.cr.usgs.gov/pub/weekly
REF
TIME(5,YYYYMMDDHHmmSSss);
LAT(21,DDdddN);
LON(27,DDDdddE);
DEP(34,DDDd);
Ml(48,Dd);
M2(52,Dd);
M3(57,Ddd);
M4(67,Ddd);
REM a - ascii character list(X -10,E - 11,T - 12)
INTEN(80,a,XET);
SKIP(1,!GS);

Examples of the fonnat files

TIME(1,YYYY/MM./DD HH:mm:SS.ss);
LAT(24,-DD.dddd);
LON(33,-DDD.dddd);
DEP(43,DDD.dd);M3(51 ,D.dd);

TIME(3,YYYYMMDDHHmmSSss);
LAT(21,DDdddN);
LON(27,DDDdddE);

DEP(34,DDDd);
Ml(48,Dd);
M2(52,Dd);
M3(57,Ddd);
M4(67,Ddd);
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INTEN(80);
SKIP(IJGS);

TIME(1,YYYY/MM/DD HH:mm:SS.sss);
LAT(35,-DD.ddd);
LON(43,-DDD.ddd);
DEP(52,DDD.d);
Ml(73,Ddd);

TIME(1,YYYY MM DD HH mm SS.ss);
LAT(25,-DD MM.mm);
LON(34,-DDD MM.mm);
DEP(54,DDD.dd);
Ml(47,D.d);
SKIP(1,#);

Name of the fields:

TIME - year, month, day, hr, minute, second I have not considered possibility to give time in years and
fractions
LAT - latitude
LON - longitude
DEP - depth
Ml - first magnitude, or "MS"
M2 - first magnitude, or "MS"
M3 - first magnitude, or "MS"
M4 - first magnitude, or "MS"
INT - intensity (only one character can be read)
SKIP - to manage skipping non-data records

Format specificators:

TIME: Y(year) y(fractions of the year) M(month) D(day) d(day from 1 January of the year) H(hours)
m(minutes) S(seconds) s(fraction of second)
LAT: D(integer degrees) d(fraction of a degree) M(minutes.') m(fraction of a minute) s(seconds,") -, N
or S(sign)
LON: D(integer degrees) d(fraction of a degree) M(minutes,') m(fraction of a minute) s(seconds,") -, E
or W(sign)
DEP: D(integer part including sign if any) d(fraction part)

M1,M2,M3,M4 - D(integer part) d(fraction part)
INT: no specificators, only one character will be read
SKIP: multiple (upto 10) strings of SKIP are allowed. If first character after position and comma is ! -
including rule will apply, otherwise excluding rule will apply; the following string upto ) will be
compared with the input string starting from the indicated position


