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An introduction to 
XMI-MSIM



XMI-MSIM

• Based on msim, developed by Laszlo Vincze

• Fortran 77 and C

• Command-line only

• Advanced variance reduction techniques

• Impressive execution speed due to tables 
with inverse cumulative distribution data

• 4 publications between 1993-1999



XMI-MSIM

• Collaboration between 
Ghent University and ESRF

• Goal: rewrite msim from 
scratch and create plug-in for 
PyMca → Quantification!

• First commit: August 16, 2010

• Development hosted on 
Github

• GPLv3 license



XMI-MSIM:
major additions

1. Simulation of XRF M-lines

2. Cascade effect

3. Detector escape peaks

4. Detector pulse pile-up simulation

5. Collimator support

6. Graphical user interface



XMI-MSIM: dependencies

• Written in Fortran 2003 
and C

• OpenMP

• xraylib

• hdf5

• libxml2

• libxslt

• GNU Scientific Library 
(GSL)

• FGSL

• glib2

• Graphical User 
Interface: Gtk2 & 
GtkExtra

• MPI (optional)



XMI-MSIM:
supported platforms

• Mac OS X: 64-bit Intel native app bundle (Snow 
Leopard and later)

• Windows: 32-bit and 64-bit installers available 
(Windows 7/8 recommended)

• Linux: 64-bit RPM/DEB packages available for 
CentOS/ScientificLinux/Fedora and Debian/Ubuntu

• Installer size: 2.0 GB HDF5 data file!

• Memory usage: varies between 14 MB and 1.5 GB 



Examples



16 keV
1500 s RT
pdeg ∼ 92 %
10 x 10 µm2

L→M cascade





16 keV
1500 s RT
pdeg ∼ 92 %
60 x 60 µm2

Gaussian
excitation
profile



29 keV
1500 s RT
pdeg ∼ 92 %
10 x 10 µm2

K→L cascade
Compton 
escape peak





Quantification using 
iterative Monte Carlo 

simulations



XMI-MSIM-PyMca



XMI-MSIM-PyMca

• Alternative for fundamental 
parameter based quantification

• Produces spectrum: direct 
verification of results

• Arbitrary high interaction orders

• Scatter enhancement

• Implemented as a plug-in for PyMca
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XMI-MSIM

PyMca

Cr 18.37% 18.37%

Mn 1.62% 1.92%

Fe 64.31% 65.72%

Co 1090 ppm 5325 ppm

Ni 12.35% 12.63%

Cu 1750 ppm 2184 ppm

W* 1100 ppm 1183 ppm

Pb* 10 ppm 75 ppm



NIST SRM 1412
multicomponent glass
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O - 47.61

Si 19.81% 27.83%

K 3.44% 3.26%

Ca 3.24% 3.17%

Fe* 217 ppm 220 ppm

Zn 3.60% 3.63%

Sr 3.85% 3.97%

Cd 3.83% 2.85%

Ba 4.18% 4.27%

Pb 4.08% 3.38%



Goodfellow
Nickel Silver rod
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XMI-MSIM
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Mn - 0.19%

Fe - 0.17%

Ni 10.0% 10.12%

Cu 45.0% 46.57%

Zn 43.0% 41.66%

Pb 2.0% 1.29%



Using XMI-MSIM



1. Launching XMI-MSIM

2. Creating and saving an input-file

3. Starting a simulation

4. Visualizing the results

5. Global preferences

6. Advanced features

Outline



Launching XMI-MSIM



• Installation instructions: https://github.com/
tschoonj/xmimsim/wiki/Installation-
instructions

• Mac OS X: use Finder or Spotlight to locate 
the App bundle

• Windows: Start Menu → Programs 
→XMI-MSIM

• Linux: Start Menu → Education →XMI-MSIM
or from the command-line: xmimsim-gui

https://github.com/tschoonj/xmimsim/wiki/Installation-instructions
https://github.com/tschoonj/xmimsim/wiki/Installation-instructions
https://github.com/tschoonj/xmimsim/wiki/Installation-instructions
https://github.com/tschoonj/xmimsim/wiki/Installation-instructions
https://github.com/tschoonj/xmimsim/wiki/Installation-instructions
https://github.com/tschoonj/xmimsim/wiki/Installation-instructions




Input parameters:
create input-files



Simulation controls:
launch simulations



Results:
visualize generated spectra



Creating and 
saving an input-file



General parameters



General parameters

Name of the outputfile:
File extension: XMSO



General parameters

Number of photons
that will be simulated



General parameters

Maximum number of 
interactions per photon 

trajectory



General parameters

Comments section



Sample composition

• Each layer defined by a composition, density and 
thickness along sample normal vector

• Add, Edit and Remove layers

• Ordering is very important: according to distance from 
the source. First layer is closest!

• Reference layer corresponds to Sample-source distance



Add or modify a layer

Includes density!



Ordering the layers

BAD

GOOD



Ordering the layers

BAD

GOOD

•Most often the Reference layer is the 
first non-atmospheric layer

•Ensure atmospheric layers are 
placed before (and after) the actual 
sample!

•Use the Top/Up/Down/Bottom 
buttons for ordering the layers



Geometry

• The coordinate system is right-handed Cartesian

• The z-axis is aligned with the beam direction and points from the source 
towards the sample.

• The y-axis defines, along with the z-axis, the horizontal plane

• The x-axis emerges out from the plane formed by the y- and z-axes



Geometry

• The coordinate system is right-handed Cartesian

• The z-axis is aligned with the beam direction and points from the source 
towards the sample.

• The y-axis defines, along with the z-axis, the horizontal plane

• The x-axis emerges out from the plane formed by the y- and z-axes
By Jan Garrevoet

Hover mouse over image 
or over the entries



Excitation spectrum

• Discrete energy components (line intensities): photons/s

• Continuous energy components (intensity densities): 
photons/s/keV 



Excitation spectrum

• Discrete energy components (line intensities): photons/s

• Continuous energy components (intensity densities): 
photons/s/keV 

Add and Edit
manually spectrum 

components

Import from ASCII file:
2, 3 or 7 columns!

Scale the intensities of 
selected components



Manually adding or editing 
a spectrum component



Manually adding or editing 
a spectrum component

Energy of the component 

Intensity according to degree 
of polarization: if equal then 

unpolarized

Source sizes and divergence: 
advanced sources with 
Gaussian distributions

Energy distribution type: 
monochromatic, Gaussian and 

Lorentzian distributions 
(discrete only)



Absorbers: excitation and 
detector channel

1. Beam absorbers: exciting radiation

2. Detection absorbers: X-ray fluorescence!



Detector parameters



Detector parametersSelects detector 
response function



Detector parameters
Number of channels



Detector parameters

Spectrum and peak 
broadening parameters



Detector parameters

Experiment live time ≠ real time!



Detector parameters

Pulse resolution time → pile-up!



Detector parameters

Crystal composition → for detection 
efficiency and escape peaks



Saving an input-file

• Only possible when acceptable values of all 
parameters have been introduced

• Use menubar or toolbar Save and Save As 
buttons

• XMSI file extension



Saving an input-file

• Only possible when acceptable values of all 
parameters have been introduced

• Use menubar or toolbar Save and Save As 
buttons

• XMSI file extensionInput-file Output-file



Import from XMSI
and XMSO files

• In menubar: File→Import

• Select the desired 
components



Starting a simulation



Control panel

• Input-file has to be loaded in Input parameters!

• Either just created (and saved) or loaded
from filesystem



Control panel

• Input-file has to be loaded in Input parameters!

• Either just created (and saved) or loaded
from filesystem

Play → Start/Resume simulation
 Pause → Suspend simulation
 Stop → Terminate simulation



Control panel

• Input-file has to be loaded in Input parameters!

• Either just created (and saved) or loaded
from filesystem

CPUs: sets the number of threads that will 
be used during the simulation. Default is to 
use the number of available logical CPUs



Control panel

• Input-file has to be loaded in Input parameters!

• Either just created (and saved) or loaded
from filesystem

Three progressbars allow to estimate how 
much longer a simulation will take. First and third 
bar will often not be used → Loaded from file



Control panel

• Input-file has to be loaded in Input parameters!

• Either just created (and saved) or loaded
from filesystem

Logwindow



Simulation options



Simulation options
Enable advanced Compton scattering 
simulation: alternative more accurate 
simulation of Compton scattering, 
taking into account partially 
populated sub-shells. Also enables 
simulation of XRF following 
Compton effect.



Simulation options

Enable OpenCL: if activated, and if 
OpenCL drivers have been installed, 
will calculate the solid angle grid on 
the GPU at greatly increased speed!

Warning: may cause the screen to 
become less responsive for a couple 
of seconds!



Export results

• XMSO: always

• SPE file prefix: suitable for PyMca and AXIL

• Scalable Vector Graphics (SVG) file: plot of spectra

• Comma Separated Values (CSV) file: contains spectra for 
increasing number of interactions (Excel)

• Report HTML file: standalone interactive overview of the results



Export results

• XMSO: always

• SPE file prefix: suitable for PyMca and AXIL

• Scalable Vector Graphics (SVG) file: plot of spectra

• Comma Separated Values (CSV) file: contains spectra for 
increasing number of interactions (Excel)

• Report HTML file: standalone interactive overview of the results

Export may be performed
at any moment using
Tools→Convert XMSO file to



During a simulation



Visualizing the results



Plot canvas



Plot canvas

Show/Hide spectra or change 
properties: line style, color, thickness



Plot canvas

Send canvas to printer or save 
as an image file (PNG, EPS, PDF)



Plot canvas

Moving the cursor updates the 
current spectrum coordinates



Plot canvas



Plot canvas

Plot area: Click and drag a box 
to zoom in. 
Double-click to zoom out again



Net-line intensities

• Show and hide lines on plot canvas: individual or 
per element

• XRF net-line intensity per element, per line and 
per interaction!



Global preferences



Simulation 
defaults

Determines the default 
settings in Simulation 
controls.
Requires a restart of 
XMI-MSIM before 
becoming active



Automatic 
updates

•Enable/disable checking 
for updates on startup.

•Download locations 
should be left untouched.

•Optional feature



User defined 
layers

•Delete layers defined in 
the Modify layer dialog



Advanced 
preferences
•Remove HDF5 files: 

when doing a complete 
uninstall

• Import from other 
HDF5 files: saves time

•Notification support 
(optional)



Advanced features



X-ray tube
spectrum generator



X-ray tube
spectrum generator

Based on H. Ebel’s model from X-ray 
Spectrometry 28 (1999), 255-266 and 
X-ray Spectrometry 32 (2003), 46-51

Implementation inspired by PyMca

http://dx.doi.org/10.1002/(SICI)1097-4539(199907%2F08)28%3A4%3C255%3A%3AAID-XRS347%3E3.0.CO%3B2-Y
http://dx.doi.org/10.1002/(SICI)1097-4539(199907%2F08)28%3A4%3C255%3A%3AAID-XRS347%3E3.0.CO%3B2-Y
http://dx.doi.org/10.1002/(SICI)1097-4539(199907%2F08)28%3A4%3C255%3A%3AAID-XRS347%3E3.0.CO%3B2-Y
http://dx.doi.org/10.1002/(SICI)1097-4539(199907%2F08)28%3A4%3C255%3A%3AAID-XRS347%3E3.0.CO%3B2-Y
http://dx.doi.org/10.1002/xrs.610
http://dx.doi.org/10.1002/xrs.610
http://dx.doi.org/10.1002/xrs.610
http://dx.doi.org/10.1002/xrs.610


X-ray tube
spectrum generator



X-ray tube
spectrum generator

Tube operation and
design parameters



X-ray tube
spectrum generator

Bremsstrahlung 
interval width



X-ray tube
spectrum generator

Anode material: density and 
thickness when operating in 
transmission mode 



X-ray tube
spectrum generator

Beam filters: optional. Set 
thickness to 0 if not required



X-ray tube
spectrum generator

Transmission efficiency file: 
two column ASCII file with 
energy vs efficiency (∈ [0, 1])



X-ray tube
spectrum generator

Update spectrum: click after changing parameters
Export spectrum: save spectrum in ASCII file
Save image: save plot in image file (PNG, EPS, PDF)
About: links to H. Ebel publications
Ok: close window and copy spectrum to Excitation
Cancel: close window without making changes



Radionuclides



Radionuclides

Choose from a list of 
commonly used radionuclides: 
55Fe, 57Co, 109Cd, 125I, 
137Cs, 133Ba, 153Gd, 238Pu, 
241Am and 244Cm



Radionuclides

Set the activity of the source 
in mCi, Ci, GBq or Bq



Batch mode

Click toolbar button or go to menubar: 
Tools→Batch mode

Behavior determined by file-selection dialog

1. Simulate a batch of unrelated input-files

2. Create a batch based on one input-file by 
varying one or two parameters



Batch mode

Click toolbar button or go to menubar: 
Tools→Batch mode

Behavior determined by file-selection dialog

1. Simulate a batch of unrelated input-files

2. Create a batch based on one input-file by 
varying one or two parameters



Batch mode I: 
simulation options



Batch mode I: 
running the batch



Batch mode I: 
running the batch

Logwindow

Simulation controls: set 
the number of logical 
CPUs, Start, Pause and Stop

Set verbosity level and 
direct output to a logfile



Batch mode 2: 
select the variable parameters



Batch mode 2: 
select the variable parameters

• Only items in green are selectable
• Select one or two parameters
• When selecting one weight_fraction, 

at least one other element must be 
present in that same layer

• Also when selecting two 
weight_fractions within the same layer



Batch mode 2: 
set the simulation options



Batch mode 2: 
set the simulation options



Batch mode 2: 
set the simulation options



Batch mode 2: 
set the simulation options



Batch mode 2: 
set the simulation options

XPath parameter: 
reference to 
selected parameter 
(XML node)



Batch mode 2: 
set the simulation options

Define range from 
Start to Stop using 
#Steps. 



Batch mode 2: 
set the simulation options



Batch mode 2: 
confirm and simulate

And wait...



• Region of interest integration: use channel or energy ranges.

• X-ray fluorescence lines: select element or specific lines

• Choose number of interactions: individual or cumulative

• Updates after every modification



• Region of interest integration: use channel or energy ranges.

• X-ray fluorescence lines: select element or specific lines

• Choose number of interactions: individual or cumulative

• Updates after every modification

Save plot canvas as 
image or export 
the data as CSV for 
further processing.

Change plot titles 
to something more 
human readable...



Batch mode 2: 
one variable parameter



File manipulation with 
XPath and XSLT

• XMSI, XMSO and XMSA are XML files

• Conversion to SPE, SVG, HTML, CSV 
performed with XSL transformations: easy 
to write customized variants

• Modify and create new files using an XML 
parser/writer in your favorite language...

• Example script available in manual (Perl)



Generate XRMC
input-files

• Use: Tools → Convert XMSO file to XRMC

• Especially useful when a proper simulation 
of the collimator is required

• Requires installation of XRMC with its 
bindings to XMI-MSIM!



Command-line tools

• xmimsim: actual simulation executable
(use xmimsim-cli.exe on Windows)

• xmimsim-pymca: PyMca’s quantification plug-in

• xmimsim-db: generates xmimsimdata.h5

• xmimsim-harvester: seed collecting daemon (UNIX)

• xmso2xmsi, xmso2spe, xmso2csv, xmso2htm, 
xmso2svg: command-line equivalents of GUI’s 
“Convert XMSO to” functions



Including XMI-MSIM in 
your own application

• Link against libxmimsim

• Many functions exported through 
interfaces in C and Fortran 2003: headers 
and modules

• Example: XRMC uses XMI-MSIM’s detector 
response function and X-ray tube spectrum 
generator



Custom detector 
response functions

• To be used when the builtin functions fail at 
properly describing your detector response 
functions

• Create a dynamically loadable module (plug-in) that 
exports the function: 
xmi_detector_convolute_all_custom

• Use the XMI-MSIM API to minimize work

• Works well in C/C++ and Fortran

• Detailed instructions in manual!



• Based on the manual at https://github.com/
tschoonj/xmimsim/wiki

• Access from XMI-MSIM: Help→Visit XMI-
MSIM User guide

• Also available as pdf

• Send me bug-reports and feature requests

https://github.com/tschoonj/xmimsim/wiki
https://github.com/tschoonj/xmimsim/wiki
https://github.com/tschoonj/xmimsim/wiki
https://github.com/tschoonj/xmimsim/wiki


Exercise 1
three-layer system

1. Air

• Composition: 78 % N2, 21 % O2, 1% Ar

• Thickness: 5 cm

• Density: 0.001205 g/cm3

2. CaSO4 → reference layer!

• Thickness: 500 µm

• Density: 2.96 g/cm3

3. Gold

• Thickness: 50 µm

• Density: 19.3 g/cm3

Afterwards: exchange
layers 2 and 3 and
simulate again!

Disable escape peaks!!!

Simulate 1 million photons



Exercise II
batch mode: one parameter

• Start Batch mode

• Select the file from the 
previous exercise

• Composition → Layer 2 → 
Element (third one) → 
weight_fraction

• Parameter variation between 
0 and 100 in 10 steps

Disable escape peaks!!!



Exercise III
collimator

• Add collimator to existing 
file

1. Height: 1 cm

2. Diameter: 0.2 cm

• Move collimator to y = 2 
cm

• Simulate and compare 
results with first exercise

Disable escape peaks!!!



Exercise IV
batch mode: two parameters
• Start Batch mode

• Select the file from the previous 
exercise

• Geometry → 
p_detector_window_x AND 
p_detector_window_z

• Parameter 1 variation between 
-1 and 1 in 5 steps

• Parameter II variation between 
99 and 101 in 5 steps

Disable escape peaks!!!


